summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2009-05-20 02:08:39 +0000
committerDenis Dupeyron <calchan@gentoo.org>2009-05-20 02:08:39 +0000
commitb3b3a34b1feb481f7f0f1f3ec00cc490cb88a975 (patch)
treec6f62db4a43f99374830c3d4a1e43fccd02c71a7 /sci-electronics
parentNew split ebuild, thanks a lot to Stefan Salewski (bug #266358). (diff)
downloadgentoo-2-b3b3a34b1feb481f7f0f1f3ec00cc490cb88a975.tar.gz
gentoo-2-b3b3a34b1feb481f7f0f1f3ec00cc490cb88a975.tar.bz2
gentoo-2-b3b3a34b1feb481f7f0f1f3ec00cc490cb88a975.zip
New split ebuild, thanks a lot to Stefan Salewski (bug #266358).
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/geda-gattrib/ChangeLog10
-rw-r--r--sci-electronics/geda-gattrib/geda-gattrib-1.4.3.ebuild52
-rw-r--r--sci-electronics/geda-gattrib/metadata.xml16
3 files changed, 78 insertions, 0 deletions
diff --git a/sci-electronics/geda-gattrib/ChangeLog b/sci-electronics/geda-gattrib/ChangeLog
new file mode 100644
index 000000000000..e18eed9667b8
--- /dev/null
+++ b/sci-electronics/geda-gattrib/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-electronics/geda-gattrib
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/geda-gattrib/ChangeLog,v 1.1 2009/05/20 02:08:39 calchan Exp $
+
+*geda-gattrib-1.4.3 (20 May 2009)
+
+ 20 May 2009; Denis Dupeyron <calchan@gentoo.org>
+ +geda-gattrib-1.4.3.ebuild, +metadata.xml:
+ New split ebuild, thanks a lot to Stefan Salewski (bug #266358).
+
diff --git a/sci-electronics/geda-gattrib/geda-gattrib-1.4.3.ebuild b/sci-electronics/geda-gattrib/geda-gattrib-1.4.3.ebuild
new file mode 100644
index 000000000000..4213319e7329
--- /dev/null
+++ b/sci-electronics/geda-gattrib/geda-gattrib-1.4.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/geda-gattrib/geda-gattrib-1.4.3.ebuild,v 1.1 2009/05/20 02:08:39 calchan Exp $
+
+EAPI="2"
+
+inherit fdo-mime versionator
+
+DESCRIPTION="GPL Electronic Design Automation: attribute editor"
+HOMEPAGE="http://www.gpleda.org/"
+SRC_URI="http://geda.seul.org/release/v$(get_version_component_range 1-2)/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="=sci-libs/libgeda-${PV}*
+ =sci-electronics/geda-symbols-${PV}*
+ >=dev-libs/glib-2.4
+ >=x11-libs/gtk+-2.4
+ || ( =dev-scheme/guile-1.6* =dev-scheme/guile-1.8*[deprecated] )
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ !<sci-electronics/geda-1.4.3-r1
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ # nls may not work if LINGUAS is set -- upstream bug, they use only variants
+ # like de_DE.po. See Debian bug #336796
+ use nls && unset LINGUAS
+ econf \
+ $(use_enable nls) \
+ --disable-dependency-tracking \
+ --disable-update-desktop-database
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS BUGS NEWS README
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/sci-electronics/geda-gattrib/metadata.xml b/sci-electronics/geda-gattrib/metadata.xml
new file mode 100644
index 000000000000..d91ffab44117
--- /dev/null
+++ b/sci-electronics/geda-gattrib/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-electronics</herd>
+ <longdescription>
+ gattrib reads a set of gschem .sch files (schematic files), and creates a
+ spreadsheet showing all components in rows, with the associated
+ component attributes listed in the columns. It allows the user to add,
+ modify, or delete component attributes outside of gschem, and then save
+ the .sch files back out. When it is completed, it will allow the user to
+ edit attributes attached to components, nets, and pins. Currently, only
+ component attribute editing is implemented, pin attributes are displayed
+ only, and net attributes are TBD.
+ </longdescription>
+</pkgmetadata>
+