summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2010-11-04 02:15:20 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2010-11-04 02:15:20 +0000
commit94b7c597ce0063cb3cc3b06694afc898c6b3e18c (patch)
tree902b7bad42da3fec51a561ba5434abc7ac673d71 /sci-electronics
parentadd some missing deps for prev commit (diff)
downloadgentoo-2-94b7c597ce0063cb3cc3b06694afc898c6b3e18c.tar.gz
gentoo-2-94b7c597ce0063cb3cc3b06694afc898c6b3e18c.tar.bz2
gentoo-2-94b7c597ce0063cb3cc3b06694afc898c6b3e18c.zip
Version bump.
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/gtkwave/ChangeLog8
-rw-r--r--sci-electronics/gtkwave/gtkwave-3.3.14.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/sci-electronics/gtkwave/ChangeLog b/sci-electronics/gtkwave/ChangeLog
index de878445a0b5..ecb7e063bbfb 100644
--- a/sci-electronics/gtkwave/ChangeLog
+++ b/sci-electronics/gtkwave/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-electronics/gtkwave
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gtkwave/ChangeLog,v 1.53 2010/10/11 17:03:42 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gtkwave/ChangeLog,v 1.54 2010/11/04 02:15:20 rafaelmartins Exp $
+
+*gtkwave-3.3.14 (04 Nov 2010)
+
+ 04 Nov 2010; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +gtkwave-3.3.14.ebuild:
+ Version bump.
11 Oct 2010; Thomas Beierlein <tomjbe@gentoo.org> gtkwave-3.3.13.ebuild,
metadata.xml:
diff --git a/sci-electronics/gtkwave/gtkwave-3.3.14.ebuild b/sci-electronics/gtkwave/gtkwave-3.3.14.ebuild
new file mode 100644
index 000000000000..a32360083ae8
--- /dev/null
+++ b/sci-electronics/gtkwave/gtkwave-3.3.14.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gtkwave/gtkwave-3.3.14.ebuild,v 1.1 2010/11/04 02:15:20 rafaelmartins Exp $
+
+EAPI="2"
+
+DESCRIPTION="A wave viewer for LXT, LXT2, VZT, GHW and standard Verilog VCD/EVCD files"
+HOMEPAGE="http://gtkwave.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+IUSE="doc examples fasttree fatlines judy lzma tcl"
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-libs/glib-2
+ >=x11-libs/gtk+-2
+ x11-libs/pango
+ judy? ( dev-libs/judy )
+ tcl? ( dev-lang/tcl dev-lang/tk )
+ lzma? ( app-arch/xz-utils )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/gperf"
+
+src_prepare(){
+ sed -i -e 's/doc examples//' Makefile.in || die "sed failed"
+}
+
+src_configure(){
+ econf --disable-local-libz \
+ --disable-local-libbz2 \
+ --disable-dependency-tracking \
+ --enable-largefile \
+ $(use_enable fatlines) \
+ $(use_enable tcl) \
+ $(use_enable lzma xz) \
+ $(use_enable fasttree) \
+ $(use_enable judy)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ dodoc ANALOG_README.TXT SYSTEMVERILOG_README.TXT CHANGELOG.TXT
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins "doc/${PN}.odt" || die "Failed to install documentation."
+ fi
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "Failed to install examples."
+ fi
+}