summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-02-15 20:36:11 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-02-15 20:36:11 +0000
commit89edecc087f4b21fef41d766853fd426ee511f0a (patch)
treebcde6967af3f8be17ccbb7b0b70d5c4e4b31ed11 /sci-electronics
parentInitial Import, based on an ebuild by Christian Kauhaus (#257580) (diff)
downloadgentoo-2-89edecc087f4b21fef41d766853fd426ee511f0a.tar.gz
gentoo-2-89edecc087f4b21fef41d766853fd426ee511f0a.tar.bz2
gentoo-2-89edecc087f4b21fef41d766853fd426ee511f0a.zip
Fix build with GCC 4.3. Patch by Arttu Valo in bug #251705
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/gnucap/ChangeLog8
-rw-r--r--sci-electronics/gnucap/files/gnucap-0.35-gcc43.patch22
-rw-r--r--sci-electronics/gnucap/gnucap-0.35.ebuild8
3 files changed, 34 insertions, 4 deletions
diff --git a/sci-electronics/gnucap/ChangeLog b/sci-electronics/gnucap/ChangeLog
index d7ff8a1696d2..7e16afd5ba54 100644
--- a/sci-electronics/gnucap/ChangeLog
+++ b/sci-electronics/gnucap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-electronics/gnucap
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gnucap/ChangeLog,v 1.43 2008/12/27 19:05:26 calchan Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gnucap/ChangeLog,v 1.44 2009/02/15 20:36:11 dirtyepic Exp $
+
+ 15 Feb 2009; Ryan Hill <dirtyepic@gentoo.org>
+ +files/gnucap-0.35-gcc43.patch, gnucap-0.35.ebuild:
+ Fix build with GCC 4.3. Patch by Arttu Valo in bug #251705
*gnucap-0.35.20081223 (27 Dec 2008)
diff --git a/sci-electronics/gnucap/files/gnucap-0.35-gcc43.patch b/sci-electronics/gnucap/files/gnucap-0.35-gcc43.patch
new file mode 100644
index 000000000000..3bd648916102
--- /dev/null
+++ b/sci-electronics/gnucap/files/gnucap-0.35-gcc43.patch
@@ -0,0 +1,22 @@
+diff -Naur gnucap-0.35-orig/modelgen/md.h gnucap-0.35/modelgen/md.h
+--- gnucap-0.35-orig/modelgen/md.h 2006-08-28 00:15:43.000000000 -0600
++++ gnucap-0.35/modelgen/md.h 2009-02-15 14:31:22.000000000 -0600
+@@ -44,6 +44,7 @@
+ #include <csetjmp>
+ #include <csignal>
+ #include <iostream>
++#include <cstring>
+ // types
+ #include <complex>
+ #include <string>
+diff -Naur gnucap-0.35-orig/src/md.h gnucap-0.35/src/md.h
+--- gnucap-0.35-orig/src/md.h 2006-08-28 00:15:43.000000000 -0600
++++ gnucap-0.35/src/md.h 2009-02-15 14:31:22.000000000 -0600
+@@ -44,6 +44,7 @@
+ #include <csetjmp>
+ #include <csignal>
+ #include <iostream>
++#include <cstring>
+ // types
+ #include <complex>
+ #include <string>
diff --git a/sci-electronics/gnucap/gnucap-0.35.ebuild b/sci-electronics/gnucap/gnucap-0.35.ebuild
index 1e08dfa9baae..13f7b5e5ccff 100644
--- a/sci-electronics/gnucap/gnucap-0.35.ebuild
+++ b/sci-electronics/gnucap/gnucap-0.35.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gnucap/gnucap-0.35.ebuild,v 1.7 2008/05/13 07:17:17 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gnucap/gnucap-0.35.ebuild,v 1.8 2009/02/15 20:36:11 dirtyepic Exp $
+
+inherit eutils
DESCRIPTION="GNUCap is the GNU Circuit Analysis Package"
SRC_URI="http://www.gnucap.org/dist/${P}.tar.gz"
@@ -17,6 +19,8 @@ src_unpack() {
unpack ${A} || die "Failed to unpack!"
cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+
# No need to install COPYING and INSTALL
sed -i \
-e 's: COPYING INSTALL::' \