summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2014-12-01 19:49:33 +0000
committerJason Zaman <perfinion@gentoo.org>2014-12-01 19:49:33 +0000
commit7b9d5f59237ff1b47fa33f9f6ced6b6656139f77 (patch)
tree3276ad5a4a7d61fadf771b72be12f90e2de2028a /sci-electronics
parentVersion bump, now with QRCode printing support. (diff)
downloadgentoo-2-7b9d5f59237ff1b47fa33f9f6ced6b6656139f77.tar.gz
gentoo-2-7b9d5f59237ff1b47fa33f9f6ced6b6656139f77.tar.bz2
gentoo-2-7b9d5f59237ff1b47fa33f9f6ced6b6656139f77.zip
version bump to 7.2.0
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0x7EF137EC935B0EAF)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/eagle/ChangeLog7
-rw-r--r--sci-electronics/eagle/eagle-7.2.0.ebuild109
2 files changed, 115 insertions, 1 deletions
diff --git a/sci-electronics/eagle/ChangeLog b/sci-electronics/eagle/ChangeLog
index c7295013d11b..2169e638ef1b 100644
--- a/sci-electronics/eagle/ChangeLog
+++ b/sci-electronics/eagle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/eagle
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/ChangeLog,v 1.62 2014/10/15 21:05:09 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/ChangeLog,v 1.63 2014/12/01 19:49:33 perfinion Exp $
+
+*eagle-7.2.0 (01 Dec 2014)
+
+ 01 Dec 2014; Jason Zaman <perfinon@gentoo.org> +eagle-7.2.0.ebuild:
+ version bump to 7.2.0
15 Oct 2014; Pacho Ramos <pacho@gentoo.org> eagle-4.16_p2-r2.ebuild,
eagle-5.11.0.ebuild, eagle-5.12.0.ebuild, eagle-6.6.0.ebuild,
diff --git a/sci-electronics/eagle/eagle-7.2.0.ebuild b/sci-electronics/eagle/eagle-7.2.0.ebuild
new file mode 100644
index 000000000000..eb08e4c37b12
--- /dev/null
+++ b/sci-electronics/eagle/eagle-7.2.0.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-7.2.0.ebuild,v 1.1 2014/12/01 19:49:33 perfinion Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="CadSoft EAGLE schematic and printed circuit board (PCB) layout editor"
+HOMEPAGE="http://www.cadsoft.de"
+SRC_URI="ftp://ftp.cadsoft.de/${PN}/program/${PV%\.[0-9]}/${PN}-lin-${PV}.run"
+
+LICENSE="cadsoft"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 -*"
+IUSE="doc linguas_de linguas_zh"
+
+QA_PREBUILT="opt/eagle/bin/eagle"
+
+RDEPEND="
+ sys-libs/glibc
+ || (
+ (
+ || ( virtual/jpeg:62[abi_x86_32(-)] media-libs/jpeg:62[abi_x86_32(-)] )
+ >=media-libs/libpng-1.2.51:1.2[abi_x86_32(-)]
+ >=dev-libs/openssl-0.9.8z_p1-r2:0.9.8[abi_x86_32(-)]
+ >=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)]
+ >=media-libs/freetype-2.5.0.1[abi_x86_32(-)]
+ >=media-libs/fontconfig-2.10.92[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ >=x11-libs/libXrender-0.9.8[abi_x86_32(-)]
+ >=x11-libs/libXrandr-1.4.2[abi_x86_32(-)]
+ >=x11-libs/libXcursor-1.1.14[abi_x86_32(-)]
+ >=x11-libs/libXi-1.7.2[abi_x86_32(-)]
+
+ )
+ amd64? (
+ app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ )
+ )
+"
+
+# Append ${PV} since that's what upstream installs to
+case "${LINGUAS}" in
+ *de*)
+ MY_LANG="de";;
+ *)
+ MY_LANG="en";;
+esac
+
+src_unpack() {
+ # Extract the built-in .tar.bz2 file starting at __DATA__
+ sed -e '1,/^__DATA__$/d' "${DISTDIR}/${A}" | tar xj || die "unpacking failed"
+}
+
+src_install() {
+ local installdir="/opt/eagle"
+
+ # Set MY_LANG for this function only since UPDATE_zh and README_zh
+ # don't exist
+ [[ ${LINGUAS} == *zh* ]] && MY_INST_LANG="zh" || MY_INST_LANG="${MY_LANG}"
+
+ insinto $installdir
+ doins -r .
+
+ fperms 0755 ${installdir}/bin/eagle
+
+ # Install wrapper (suppressing leading tabs)
+ # see bug #188368 or http://www.cadsoftusa.com/training/faq/#3
+ exeinto /opt/bin
+ newexe "${FILESDIR}/eagle_wrapper_script" eagle
+ # Finally, append the path of the eagle binary respecting $installdir and any
+ # arguments passed to the script (thanks Denilson)
+ echo "${installdir}/bin/eagle" '"$@"' >> "${D}/opt/bin/eagle"
+
+ # Install the documentation
+ cd doc
+ dodoc README_${MY_LANG} UPDATE_${MY_LANG} library_${MY_LANG}.txt
+ doman eagle.1
+
+ # Install extra documentation if requested
+ if use doc; then
+ dodoc {connect-device-split-symbol-${MY_INST_LANG},elektro-tutorial,manual_${MY_INST_LANG},tutorial_${MY_INST_LANG},layer-setup_designrules}.pdf
+ fi
+ # Remove docs left in $installdir
+ rm -rf "${D}${installdir}/doc"
+ cd "${S}"
+
+ echo -e "ROOTPATH=${installdir}/bin\nPRELINK_PATH_MASK=${installdir}" > "${S}/90eagle-${PV}"
+ doenvd "${S}/90eagle-${PV}"
+
+ # Create desktop entry
+ newicon bin/${PN}icon50.png ${PF}-icon50.png
+ make_desktop_entry "${ROOT}/opt/bin/eagle" "CadSoft EAGLE Layout Editor" ${PF}-icon50 "Graphics;Electronics"
+}
+
+pkg_postinst() {
+ elog "Run \`env-update && source /etc/profile\` from within \${ROOT}"
+ elog "now to set up the correct paths."
+ elog "You must first run eagle as root to invoke product registration."
+ echo
+ ewarn "Due to some necessary changes in the data structure, once you edit"
+ ewarn "a file with version 7.x you will no longer be able to edit it"
+ ewarn "with versions prior to 7.0!"
+ ewarn
+ ewarn "Please read /usr/share/doc/${PF}/UPDATE_${MY_LANG} if you are upgrading from 6.x/5.x/4.x."
+}