summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2010-10-22 18:37:25 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2010-10-22 18:37:25 +0000
commit5f7fb8bf5806e29347e3416e12de4a204558a719 (patch)
tree73bc6bd6ea1f72cc42f4b57cc10a2dfc521c2a9c /sci-electronics
parentppc64 stable wrt #340023 (diff)
downloadgentoo-2-5f7fb8bf5806e29347e3416e12de4a204558a719.tar.gz
gentoo-2-5f7fb8bf5806e29347e3416e12de4a204558a719.tar.bz2
gentoo-2-5f7fb8bf5806e29347e3416e12de4a204558a719.zip
Version bump (bug #341489)
(Portage version: 2.1.9.21/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/pcb/ChangeLog8
-rw-r--r--sci-electronics/pcb/metadata.xml1
-rw-r--r--sci-electronics/pcb/pcb-20100929.ebuild120
3 files changed, 128 insertions, 1 deletions
diff --git a/sci-electronics/pcb/ChangeLog b/sci-electronics/pcb/ChangeLog
index cc6250a300ba..987aec03a669 100644
--- a/sci-electronics/pcb/ChangeLog
+++ b/sci-electronics/pcb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-electronics/pcb
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/pcb/ChangeLog,v 1.54 2010/10/10 21:36:08 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/pcb/ChangeLog,v 1.55 2010/10/22 18:37:25 tomjbe Exp $
+
+*pcb-20100929 (22 Oct 2010)
+
+ 22 Oct 2010; Thomas Beierlein <tomjbe@gentoo.org> +pcb-20100929.ebuild,
+ metadata.xml:
+ Version bump (bug #341489)
10 Oct 2010; Ulrich Mueller <ulm@gentoo.org> pcb-20081128-r1.ebuild,
pcb-20091103.ebuild:
diff --git a/sci-electronics/pcb/metadata.xml b/sci-electronics/pcb/metadata.xml
index 6f54d581493c..9213198f33b1 100644
--- a/sci-electronics/pcb/metadata.xml
+++ b/sci-electronics/pcb/metadata.xml
@@ -11,6 +11,7 @@
<flag name='jpeg'>JPEG graphics export</flag>
<flag name='nelma'>NELMA file export</flag>
<flag name='png'>PNG graphics export</flag>
+ <flag name='gcode'>gcode file export</flag>
<flag name='tk'>Build tcl/tk graphical QFP footprint generator</flag>
<flag name='xrender'>Translucent PCB display for Motif/Lesstif GUI</flag>
<flag name='m4lib-png'>Enable creating png previews for the m4 library</flag>
diff --git a/sci-electronics/pcb/pcb-20100929.ebuild b/sci-electronics/pcb/pcb-20100929.ebuild
new file mode 100644
index 000000000000..88f52327727b
--- /dev/null
+++ b/sci-electronics/pcb/pcb-20100929.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/pcb/pcb-20100929.ebuild,v 1.1 2010/10/22 18:37:25 tomjbe Exp $
+
+EAPI="2"
+
+inherit fdo-mime gnome2-utils
+
+DESCRIPTION="GPL Electronic Design Automation: Printed Circuit Board editor"
+HOMEPAGE="http://www.gpleda.org/"
+SRC_URI="mirror://sourceforge/pcb/pcb/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-macos"
+IUSE="dbus doc gif gtk jpeg m4lib-png motif nelma gcode nls png xrender test tk toporouter debug"
+# toporouter-output USE flag removed, there seems to be no result
+
+CDEPEND="gif? ( >=media-libs/gd-2.0.23 )
+ gtk? ( >=x11-libs/gtk+-2.4 x11-libs/pango
+ dbus? ( sys-apps/dbus ) )
+ jpeg? ( >=media-libs/gd-2.0.23[jpeg] )
+ motif? ( !gtk? (
+ >=x11-libs/openmotif-2.3:0
+ dbus? ( sys-apps/dbus )
+ xrender? ( >=x11-libs/libXrender-0.9 ) ) )
+ nelma? ( >=media-libs/gd-2.0.23 )
+ gcode? ( >=media-libs/gd-2.0.23 )
+ nls? ( virtual/libintl )
+ png? ( >=media-libs/gd-2.0.23[png] )
+ m4lib-png? ( >=media-libs/gd-2.0.23[png] )
+ test? (
+ || ( media-gfx/graphicsmagick[imagemagick] media-gfx/imagemagick )
+ sci-electronics/gerbv
+ )
+ tk? ( >=dev-lang/tk-8 )"
+#toporouter-output? ( x11-libs/cairo )
+
+DEPEND="${CDEPEND}
+ >=dev-util/intltool-0.35
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="${CDEPEND}
+ sci-electronics/electronics-menu"
+
+pkg_setup() {
+ if use gtk && use motif; then
+ elog "Can only build for GTK+ or Motif/Lesstif GUI. GTK+ has priority."
+ fi
+ if !(use gtk || use motif); then
+ elog "Building without GUI, make sure you know what you are doing."
+ fi
+ if use dbus && !(use gtk || use motif); then
+ elog "dbus needs GTK or Motif/Lesstif GUI. Try USE=-dbus or USE=gtk or USE=motif."
+ fi
+ if (use gtk || (! use gtk && ! use motif)) && (use xrender); then
+ elog "The XRender extension is only usable with the Motif/Lesstif GUI."
+ fi
+}
+
+src_configure() {
+ local myconf
+ if use gtk ; then
+ myconf="--with-gui=gtk $(use_enable dbus) --disable-xrender"
+ elif use motif ; then
+ myconf="--with-gui=lesstif $(use_enable dbus) $(use_enable xrender)"
+ else
+ myconf="--with-gui=batch --disable-xrender --disable-dbus"
+ fi
+
+ local exporters="bom gerber ps"
+ if (use png || use jpeg || use gif) ; then
+ exporters="${exporters} png"
+ fi
+ use nelma && exporters="${exporters} nelma"
+ use gcode && exporters="${exporters} gcode"
+ use tk || export WISH="/bin/true"
+
+ econf \
+ ${myconf} \
+ $(use_enable doc) \
+ $(use_enable gif) \
+ $(use_enable jpeg) \
+ $(use_enable nls) \
+ $(use_enable png) \
+ $(use_enable m4lib-png) \
+ $(use_enable toporouter) \
+ $(use_enable debug) \
+ --disable-toporouter-output \
+ --with-exporters="${exporters}" \
+ --disable-dependency-tracking \
+ --disable-rpath \
+ --disable-update-mime-database \
+ --disable-update-desktop-database \
+ --docdir="/usr/share/doc/${PF}"
+}
+# toporouter-output USE flag removed, there seems to be no result
+# $(use_enable toporouter-output) \
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS README NEWS ChangeLog
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}