summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2008-02-09 19:00:26 +0000
committerDenis Dupeyron <calchan@gentoo.org>2008-02-09 19:00:26 +0000
commit3fbc387e8b88a7c829efc3b023717dba1b1a2f33 (patch)
tree7b3dd47ecaae953a5308e925f158f3e50ab7bb28 /sci-electronics
parentRe-add ~alpha/~ia64 (diff)
downloadgentoo-2-3fbc387e8b88a7c829efc3b023717dba1b1a2f33.tar.gz
gentoo-2-3fbc387e8b88a7c829efc3b023717dba1b1a2f33.tar.bz2
gentoo-2-3fbc387e8b88a7c829efc3b023717dba1b1a2f33.zip
Fixed compilation on amd64, bug #203721.
(Portage version: 2.1.4.1)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/ghdl/ChangeLog7
-rw-r--r--sci-electronics/ghdl/ghdl-0.26.ebuild18
2 files changed, 20 insertions, 5 deletions
diff --git a/sci-electronics/ghdl/ChangeLog b/sci-electronics/ghdl/ChangeLog
index 4d55680fae94..14f97a2e13a7 100644
--- a/sci-electronics/ghdl/ChangeLog
+++ b/sci-electronics/ghdl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-electronics/ghdl
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ghdl/ChangeLog,v 1.3 2007/12/31 21:27:10 josejx Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ghdl/ChangeLog,v 1.4 2008/02/09 19:00:26 calchan Exp $
+
+ 09 Feb 2008; Denis Dupeyron <calchan@gentoo.org> ghdl-0.26.ebuild:
+ Fixed compilation on amd64, bug #203721.
31 Dec 2007; Joseph Jezak <josejx@gentoo.org> ghdl-0.26.ebuild:
Marked ~ppc for bug #196439.
diff --git a/sci-electronics/ghdl/ghdl-0.26.ebuild b/sci-electronics/ghdl/ghdl-0.26.ebuild
index 9ad153d448e6..d21c352630d0 100644
--- a/sci-electronics/ghdl/ghdl-0.26.ebuild
+++ b/sci-electronics/ghdl/ghdl-0.26.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ghdl/ghdl-0.26.ebuild,v 1.3 2007/12/31 21:27:10 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ghdl/ghdl-0.26.ebuild,v 1.4 2008/02/09 19:00:26 calchan Exp $
inherit multilib
@@ -12,7 +12,7 @@ SRC_URI="http://ghdl.free.fr/${P}.tar.bz2
mirror://gnu/gcc/releases/gcc-${GCC_VERSION}/gcc-core-${GCC_VERSION}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~ppc ~x86"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
DEPEND=">=sys-apps/portage-2.1.2.10
virtual/gnat"
@@ -37,6 +37,18 @@ src_unpack() {
# Fix atan2 bug in math_complex-body.vhdl
sed -i -e 's/atan2(z.re,z.im)/atan2(z.im,z.re)/' \
gcc/vhdl/libraries/ieee/math_complex-body.vhdl || die "sed failed"
+
+ # For multilib profile arch, see bug #203721
+ if (has_multilib_profile || use multilib ) ; then
+ for T_LINUX64 in `find "${S}/gcc/config" -name t-linux64` ;
+ do
+ einfo "sed for ${T_LINUX64} for multilib. :)"
+ sed -i \
+ -e "s:\(MULTILIB_OSDIRNAMES = \).*:\1../lib64 ../lib32:" \
+ "${T_LINUX64}" \
+ || die "sed for ${T_LINUX64} failed. :("
+ done
+ fi
}
src_compile() {