summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2014-11-29 12:57:05 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2014-11-29 12:57:05 +0000
commit053126539449445f6120c4bac89b98b971e71eb0 (patch)
tree321af65753760cc9dd6417db0974a1d725b2f879 /sci-electronics
parentMarked ~hppa (bug #530672). (diff)
downloadgentoo-2-053126539449445f6120c4bac89b98b971e71eb0.tar.gz
gentoo-2-053126539449445f6120c4bac89b98b971e71eb0.tar.bz2
gentoo-2-053126539449445f6120c4bac89b98b971e71eb0.zip
Allow building of high resolution tool rfsplat-hd (bug #482476). Thanks for reporting
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x762053D5)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/splat/ChangeLog9
-rw-r--r--sci-electronics/splat/metadata.xml4
-rw-r--r--sci-electronics/splat/splat-1.4.1-r1.ebuild92
3 files changed, 104 insertions, 1 deletions
diff --git a/sci-electronics/splat/ChangeLog b/sci-electronics/splat/ChangeLog
index 250d70e55966..7524d1c40b30 100644
--- a/sci-electronics/splat/ChangeLog
+++ b/sci-electronics/splat/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-electronics/splat
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/splat/ChangeLog,v 1.16 2014/11/29 12:03:56 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/splat/ChangeLog,v 1.17 2014/11/29 12:57:05 tomjbe Exp $
+
+*splat-1.4.1-r1 (29 Nov 2014)
+
+ 29 Nov 2014; Thomas Beierlein <tomjbe@gentoo.org> +splat-1.4.1-r1.ebuild,
+ metadata.xml:
+ Allow building of high resolution tool rfsplat-hd (bug #482476). Thanks for
+ reporting
29 Nov 2014; Thomas Beierlein <tomjbe@gentoo.org> splat-1.4.1.ebuild:
Fix missing src_configure()
diff --git a/sci-electronics/splat/metadata.xml b/sci-electronics/splat/metadata.xml
index e6e9dfbd17b2..e8f8307a22af 100644
--- a/sci-electronics/splat/metadata.xml
+++ b/sci-electronics/splat/metadata.xml
@@ -9,4 +9,8 @@
coordination, communication system design, and terrestrial television and radio
broadcasting.
</longdescription>
+ <use>
+ <flag name = 'hires'>Builds additional high resolution application
+ 'rfsplat-hd'. </flag>
+ </use>
</pkgmetadata>
diff --git a/sci-electronics/splat/splat-1.4.1-r1.ebuild b/sci-electronics/splat/splat-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..f9298b4fd8ed
--- /dev/null
+++ b/sci-electronics/splat/splat-1.4.1-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/splat/splat-1.4.1-r1.ebuild,v 1.1 2014/11/29 12:57:05 tomjbe Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="RF Signal Propagation, Loss, And Terrain analysis tool for the spectrum between 20 MHz and 20 GHz"
+HOMEPAGE="http://www.qsl.net/kd2bd/splat.html"
+SRC_URI="http://www.qsl.net/kd2bd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc hires linguas_es"
+
+DEPEND="sys-libs/zlib
+ app-arch/bzip2"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.2.2-gcc43.patch"
+}
+
+src_configure() {
+ # fake resulting file from interactive configuration script
+ # using default resolution
+ cat <<- EOF > "${S}/splat.h"
+ /* Parameters for 3 arc-second standard resolution mode of operation */
+ #define MAXPAGES 9
+ #define HD_MODE 0
+ EOF
+ if use hires; then
+ # fake resulting file from interactive configuration script
+ # using default resolution
+ cat <<- EOF > "${S}/hires.h"
+ /* Parameters for 3 arc-second hires resolution mode of operation */
+ #define MAXPAGES 9
+ #define HD_MODE 1
+ EOF
+ fi
+}
+
+src_compile() {
+
+ local CC=$(tc-getCC) CXX=$(tc-getCXX)
+
+ ${CXX} -Wall ${CXXFLAGS} ${LDFLAGS} itwom3.0.cpp splat.cpp -o rfsplat -lm -lbz2 || die
+ if use hires; then
+ cp "${S}/hires.h" "${S}/splat.h"
+ ${CXX} -Wall ${CXXFLAGS} ${LDFLAGS} itwom3.0.cpp splat.cpp -o rfsplat-hd -lm -lbz2 || die
+ fi
+
+ cd utils
+ ${CC} -Wall ${CFLAGS} ${LDFLAGS} citydecoder.c -o citydecoder
+ ${CC} -Wall ${CFLAGS} ${LDFLAGS} usgs2sdf.c -o usgs2sdf
+ ${CC} -Wall ${CFLAGS} ${LDFLAGS} srtm2sdf.c -o srtm2sdf -lbz2
+ #${CC} -Wall ${CFLAGS} ${LDFLAGS} fontdata.c -o fontdata -lz
+ ${CC} -Wall ${CFLAGS} ${LDFLAGS} bearing.c -o bearing -lm
+}
+
+src_install() {
+ local SPLAT_LANG="english"
+ use linguas_es && SPLAT_LANG="spanish"
+ # splat binary
+ dobin rfsplat
+ if use hires; then
+ dobin rfsplat-hd
+ fi
+
+ # utilities
+ dobin utils/{citydecoder,usgs2sdf,srtm2sdf,postdownload,bearing}
+ newman docs/${SPLAT_LANG}/man/splat.man rfsplat.1
+
+ dodoc CHANGES README utils/fips.txt
+ newdoc utils/README README.UTILS
+
+ if use doc; then
+ dodoc docs/${SPLAT_LANG}/{pdf/splat.pdf,postscript/splat.ps}
+ fi
+ #sample data
+ docinto sample_data
+ dodoc sample_data/*
+}
+
+pkg_postinst() {
+ elog "The original SPLAT! command got renamed to 'rfsplat' to avoid"
+ elog "filename collission with app-portage/splat."
+ elog ""
+ elog "Be aware that it is still referenced as 'splat' in the documentation."
+}