summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2007-03-12 18:21:20 +0000
committerDenis Dupeyron <calchan@gentoo.org>2007-03-12 18:21:20 +0000
commit357a68be4a40f5937bdb36feb7ffabc871b759bc (patch)
tree42c9d444ab69bff11c403e84e43dbe56112e8ba6 /sci-electronics/spice
parentReplacing einfo with elog (diff)
downloadgentoo-2-357a68be4a40f5937bdb36feb7ffabc871b759bc.tar.gz
gentoo-2-357a68be4a40f5937bdb36feb7ffabc871b759bc.tar.bz2
gentoo-2-357a68be4a40f5937bdb36feb7ffabc871b759bc.zip
Fixed bug #166897, thanks David Watzke. Fixed mtime issue forcing WORKDIR to be recreated each time.
(Portage version: 2.1.2.2)
Diffstat (limited to 'sci-electronics/spice')
-rw-r--r--sci-electronics/spice/ChangeLog6
-rw-r--r--sci-electronics/spice/spice-3.5.5.ebuild18
2 files changed, 15 insertions, 9 deletions
diff --git a/sci-electronics/spice/ChangeLog b/sci-electronics/spice/ChangeLog
index 122f01e08067..b869e65961d9 100644
--- a/sci-electronics/spice/ChangeLog
+++ b/sci-electronics/spice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-electronics/spice
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/spice/ChangeLog,v 1.7 2007/02/21 18:50:11 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/spice/ChangeLog,v 1.8 2007/03/12 18:21:20 calchan Exp $
+
+ 12 Mar 2007; Denis Dupeyron <calchan@gentoo.org> spice-3.5.5.ebuild:
+ Fixed bug #166897, thanks David Watzke. Fixed mtime issue forcing WORKDIR to
+ be recreated each time.
21 Feb 2007; Denis Dupeyron <calchan@gentoo.org> files/digest-spice-3.5.5,
Manifest:
diff --git a/sci-electronics/spice/spice-3.5.5.ebuild b/sci-electronics/spice/spice-3.5.5.ebuild
index 06cdd57cf6cc..3395852ebeb1 100644
--- a/sci-electronics/spice/spice-3.5.5.ebuild
+++ b/sci-electronics/spice/spice-3.5.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/spice/spice-3.5.5.ebuild,v 1.4 2006/05/21 22:20:52 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/spice/spice-3.5.5.ebuild,v 1.5 2007/03/12 18:21:20 calchan Exp $
inherit eutils flag-o-matic
@@ -28,16 +28,18 @@ src_unpack() {
replace-flags -O* -O1
unpack ${A}
- cd ${S}/conf
+ cd ${S}
+ # Avoid re-creating WORKDIR due to stupid mtime
+ touch ..
+
[ -z $EDITOR ] || EDITOR="vim"
-# cp linux{,.orig}
- sed -e "s:termcap:ncurses:g" \
+ sed -i -e "s:termcap:ncurses:g" \
-e "s:joe:${EDITOR}:g" \
-e "s:-O2 -s:${CFLAGS}:g" \
-e "s:SPICE_DIR)/lib:SPICE_DIR)/lib/spice:g" \
-e "s:/usr/local/spice:/usr:g" \
- -i.orig linux
- cd ${S}
+ conf/linux
+ sed -i -e "s:head -1:head -n 1:" util/build
epatch ${FILESDIR}/${P}-gcc-4.1.patch
}
@@ -49,7 +51,7 @@ src_compile() {
src_install() {
cd ${S}
# install binaries
- dobin obj/bin/{spice3,nutmeg,sconvert,multidec,proc2mod}
+ dobin obj/bin/{spice3,nutmeg,sconvert,multidec,proc2mod} || die
newbin obj/bin/help spice.help
dosym /usr/bin/spice3 /usr/bin/spice
# install runtime stuff