summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2010-08-22 09:32:50 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2010-08-22 09:32:50 +0000
commit815d8b33b6ea1e09fad6017bb32b08b8cb063225 (patch)
tree224788ef04bc3f9d514dcc212d1139f3d8d88c79 /sci-electronics/oregano/oregano-0.69.0-r1.ebuild
parentRespect LDFLAGS wrt bug 333873. Thanks to Diego for report. Remove old. (diff)
downloadgentoo-2-815d8b33b6ea1e09fad6017bb32b08b8cb063225.tar.gz
gentoo-2-815d8b33b6ea1e09fad6017bb32b08b8cb063225.tar.bz2
gentoo-2-815d8b33b6ea1e09fad6017bb32b08b8cb063225.zip
Fix for bug #333869 wrt respecting LDFLAGS
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics/oregano/oregano-0.69.0-r1.ebuild')
-rw-r--r--sci-electronics/oregano/oregano-0.69.0-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sci-electronics/oregano/oregano-0.69.0-r1.ebuild b/sci-electronics/oregano/oregano-0.69.0-r1.ebuild
new file mode 100644
index 000000000000..5b91a213a014
--- /dev/null
+++ b/sci-electronics/oregano/oregano-0.69.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/oregano/oregano-0.69.0-r1.ebuild,v 1.1 2010/08/22 09:32:50 tomjbe Exp $
+
+inherit eutils fdo-mime
+
+DESCRIPTION="Oregano is an application for schematic capture and simulation of electrical circuits."
+SRC_URI="http://gforge.lug.fi.uba.ar/frs/download.php/86/${P}.tar.gz"
+HOMEPAGE="http://oregano.gforge.lug.fi.uba.ar/"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+IUSE=""
+
+RDEPEND=">=dev-libs/libxml2-2.6
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/libglade-2.5
+ >=gnome-base/libgnome-2.12
+ >=gnome-base/libgnomeui-2.12
+ >=gnome-base/libgnomecanvas-2.12
+ >=gnome-base/libgnomeprint-2.12
+ >=x11-libs/cairo-1.2
+ =x11-libs/gtksourceview-1*"
+DEPEND="${RDEPEND}
+ >=dev-util/scons-0.96.1
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.60.0-dont-run-update-mime-database.patch \
+ "${FILESDIR}"/${P}-ldflags.diff
+}
+
+src_compile() {
+ scons --cache-disable \
+ PREFIX=/usr \
+ || die "scons make failed"
+}
+
+src_install() {
+ scons --cache-disable DESTDIR="${D}" PREFIX=/usr install \
+ || die "scons install failed"
+ dodoc AUTHORS INSTALL NEWS README
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ elog "You'll need to emerge your prefered simulation backend"
+ elog "such as spice, ng-spice-rework or gnucap for simulation"
+ elog "to work."
+}