summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2006-09-27 10:08:11 +0000
committerDenis Dupeyron <calchan@gentoo.org>2006-09-27 10:08:11 +0000
commit363f69bd29cd4218b04d74a2350e3bdc6460401a (patch)
tree02a409d0b2149a48b47431428c977a6143fdfc60 /sci-electronics/gnucap/gnucap-0.35.ebuild
parentAdd missing dependency over imagemagick for the LaTeX plugin. Thanks to Erdro... (diff)
downloadgentoo-2-363f69bd29cd4218b04d74a2350e3bdc6460401a.tar.gz
gentoo-2-363f69bd29cd4218b04d74a2350e3bdc6460401a.tar.bz2
gentoo-2-363f69bd29cd4218b04d74a2350e3bdc6460401a.zip
Version bump.
(Portage version: 2.1.2_pre1-r2)
Diffstat (limited to 'sci-electronics/gnucap/gnucap-0.35.ebuild')
-rw-r--r--sci-electronics/gnucap/gnucap-0.35.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-electronics/gnucap/gnucap-0.35.ebuild b/sci-electronics/gnucap/gnucap-0.35.ebuild
new file mode 100644
index 000000000000..c3dbad0990d4
--- /dev/null
+++ b/sci-electronics/gnucap/gnucap-0.35.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gnucap/gnucap-0.35.ebuild,v 1.1 2006/09/27 10:08:11 calchan Exp $
+
+DESCRIPTION="GNUCap is the GNU Circuit Analysis Package"
+SRC_URI="http://www.gnucap.org/dist/${P}.tar.gz"
+HOMEPAGE="http://www.gnucap.org/"
+
+IUSE="doc examples"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="doc? ( app-text/tetex )"
+
+src_unpack() {
+ unpack ${A} || die "Failed to unpack!"
+ cd ${S}
+
+ # No need to install COPYING and INSTALL
+ sed -i \
+ -e 's: COPYING INSTALL::' \
+ -e 's:COPYING history INSTALL:history:' \
+ doc/Makefile.in || die "sed failed"
+
+ if ! use doc ; then
+ sed -i \
+ -e 's:SUBDIRS = doc examples man:SUBDIRS = doc examples:' \
+ Makefile.in || die "sed failed"
+ fi
+
+ if ! use examples ; then
+ sed -i \
+ -e 's:SUBDIRS = doc examples:SUBDIRS = doc:' \
+ Makefile.in || die "sed failed"
+ fi
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "Installation failed"
+}