summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2009-06-20 03:36:43 +0000
committerDenis Dupeyron <calchan@gentoo.org>2009-06-20 03:36:43 +0000
commit3fddc1091f1c9bfc48bfb2365946c0809fd44db7 (patch)
treef2be39444d56899ba56c407ac265d6d0a903479d /sci-electronics/ghdl
parentLatest version, thanks to lumbrius in bug #274199 and Reinis Danne for the... (diff)
downloadgentoo-2-3fddc1091f1c9bfc48bfb2365946c0809fd44db7.tar.gz
gentoo-2-3fddc1091f1c9bfc48bfb2365946c0809fd44db7.tar.bz2
gentoo-2-3fddc1091f1c9bfc48bfb2365946c0809fd44db7.zip
Fixed bugs #248352, #273142 and #273252.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'sci-electronics/ghdl')
-rw-r--r--sci-electronics/ghdl/ChangeLog5
-rw-r--r--sci-electronics/ghdl/ghdl-0.27.ebuild20
2 files changed, 18 insertions, 7 deletions
diff --git a/sci-electronics/ghdl/ChangeLog b/sci-electronics/ghdl/ChangeLog
index 4479d7298363..f308c4b3f559 100644
--- a/sci-electronics/ghdl/ChangeLog
+++ b/sci-electronics/ghdl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-electronics/ghdl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ghdl/ChangeLog,v 1.7 2009/06/06 17:07:53 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ghdl/ChangeLog,v 1.8 2009/06/20 03:36:43 calchan Exp $
+
+ 20 Jun 2009; Denis Dupeyron <calchan@gentoo.org> ghdl-0.27.ebuild:
+ Fixed bugs #248352, #273142 and #273252.
*ghdl-0.27 (06 Jun 2009)
diff --git a/sci-electronics/ghdl/ghdl-0.27.ebuild b/sci-electronics/ghdl/ghdl-0.27.ebuild
index 060d4994b7c7..c828ef75dcd2 100644
--- a/sci-electronics/ghdl/ghdl-0.27.ebuild
+++ b/sci-electronics/ghdl/ghdl-0.27.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ghdl/ghdl-0.27.ebuild,v 1.1 2009/06/06 17:07:53 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ghdl/ghdl-0.27.ebuild,v 1.2 2009/06/20 03:36:43 calchan Exp $
EAPI="2"
inherit multilib
GCC_VERSION="4.2.4"
+GNATGCC_SLOT="4.2"
DESCRIPTION="Complete VHDL simulator using the GCC technology"
HOMEPAGE="http://ghdl.free.fr"
@@ -17,14 +18,21 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
DEPEND=">=sys-apps/portage-2.1.2.10
- >=dev-lang/gnat-gcc-4.2"
+ dev-lang/gnat-gcc:${GNATGCC_SLOT}"
RDEPEND=""
S="${WORKDIR}/gcc-${GCC_VERSION}"
+ADA_INCLUDE_PATH="${ROOT}/usr/lib/gnat-gcc/${CHOST}/${GNATGCC_SLOT}/adainclude"
+ADA_OBJECTS_PATH="${ROOT}/usr/lib/gnat-gcc/${CHOST}/${GNATGCC_SLOT}/adalib"
+GNATGCC_PATH="${ROOT}/usr/${CHOST}/gnat-gcc-bin/${GNATGCC_SLOT}:${ROOT}/usr/libexec/gnat-gcc/${CHOST}/${GNATGCC_SLOT}"
+
src_prepare() {
mv "${WORKDIR}/${P}"/vhdl gcc
sed -i -e 's/ADAC = \$(CC)/ADAC = gnatgcc/' gcc/vhdl/Makefile.in || die "sed failed"
- sed -i -e 's/AGCC_CFLAGS=-g/AGCC_CFLAGS=$(CFLAGS)/' gcc/vhdl/Make-lang.in || die "sed failed"
+ sed -i \
+ -e 's/AGCC_CFLAGS=-g/AGCC_CFLAGS=$(CFLAGS)/' \
+ -e 's/rm -rf $(infodir)/rm -rf $(DESTDIR)$(infodir)/' \
+ gcc/vhdl/Make-lang.in || die "sed failed"
# Fix issue similar to bug #195074, ported from vapier's fix for binutils
sed -i -e "s:egrep.*texinfo.*dev/null:egrep 'texinfo[^0-9]*(4\.([4-9]|[1-9][0-9])|[5-9]|[1-9][0-9])' >/dev/null:" \
@@ -44,15 +52,15 @@ src_prepare() {
}
src_configure() {
- econf --enable-languages=vhdl
+ PATH="${GNATGCC_PATH}:${PATH}" econf --enable-languages=vhdl
}
src_compile() {
- emake -j1 || die "Compilation failed"
+ PATH="${GNATGCC_PATH}:${PATH}" emake -j1 || die "Compilation failed"
}
src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
+ PATH="${GNATGCC_PATH}:${PATH}" emake DESTDIR="${D}" install || die "Installation failed"
cd "${D}"/usr/bin ; rm `ls --ignore=ghdl`
rm -rf "${D}"/usr/include