summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2009-11-17 18:20:22 +0000
committerDenis Dupeyron <calchan@gentoo.org>2009-11-17 18:20:22 +0000
commitbff51666765223aedb4a17f80a8d9509eb8737a1 (patch)
treeae7d854ef023149e25bc3d1bdddb2695c31dafe4 /sci-electronics/geda
parentVersion bump, various bugfixes. (diff)
downloadgentoo-2-bff51666765223aedb4a17f80a8d9509eb8737a1.tar.gz
gentoo-2-bff51666765223aedb4a17f80a8d9509eb8737a1.tar.bz2
gentoo-2-bff51666765223aedb4a17f80a8d9509eb8737a1.zip
Removed debug USE flag as upstream says it doesn't work in this release and will be fixed for the next one. Fixed icon cache updates. Added dependency to electronics-menu.
(Portage version: 2.1.7.1/cvs/Linux i686)
Diffstat (limited to 'sci-electronics/geda')
-rw-r--r--sci-electronics/geda/ChangeLog10
-rw-r--r--sci-electronics/geda/geda-1.6.0-r1.ebuild (renamed from sci-electronics/geda/geda-1.6.0.ebuild)26
2 files changed, 28 insertions, 8 deletions
diff --git a/sci-electronics/geda/ChangeLog b/sci-electronics/geda/ChangeLog
index 10b2943c4edd..5c801b8eb491 100644
--- a/sci-electronics/geda/ChangeLog
+++ b/sci-electronics/geda/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-electronics/geda
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/geda/ChangeLog,v 1.51 2009/11/05 23:49:11 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/geda/ChangeLog,v 1.52 2009/11/17 18:20:22 calchan Exp $
+
+*geda-1.6.0-r1 (17 Nov 2009)
+
+ 17 Nov 2009; Denis Dupeyron <calchan@gentoo.org> -geda-1.6.0.ebuild,
+ +geda-1.6.0-r1.ebuild:
+ Removed debug USE flag as upstream says it doesn't work in this release
+ and will be fixed for the next one. Fixed icon cache updates. Added
+ dependency to electronics-menu.
*geda-1.6.0 (05 Nov 2009)
diff --git a/sci-electronics/geda/geda-1.6.0.ebuild b/sci-electronics/geda/geda-1.6.0-r1.ebuild
index d97800674958..e7f5f0151404 100644
--- a/sci-electronics/geda/geda-1.6.0.ebuild
+++ b/sci-electronics/geda/geda-1.6.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/geda/geda-1.6.0.ebuild,v 1.1 2009/11/05 23:49:11 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/geda/geda-1.6.0-r1.ebuild,v 1.1 2009/11/17 18:20:22 calchan Exp $
EAPI="2"
-inherit fdo-mime versionator
+inherit fdo-mime versionator gnome2-utils
MY_P="${PN}-gaf-${PV}"
DESCRIPTION="GPL Electronic Design Automation (gEDA):gaf core package"
@@ -14,9 +14,12 @@ SRC_URI="http://geda.seul.org/release/v$(get_version_component_range 1-2)/${PV}/
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="debug doc examples nls stroke threads"
+# Do not stabilize 1.6.0, upstream says it's suboptimal. Calchan, 20091117.
+IUSE="doc examples nls stroke threads"
+# Removed the debug USE flag from above because it's currently broken. Make sure
+# to add it back when upstream fixes it. Calchan, 20091117.
-RDEPEND="
+CDEPEND="
>=dev-libs/glib-2.12
>=x11-libs/gtk+-2.10
>=x11-libs/cairo-1.2.0
@@ -24,7 +27,7 @@ RDEPEND="
nls? ( virtual/libintl )
stroke? ( >=dev-libs/libstroke-0.5.1 )"
-DEPEND="${RDEPEND}
+DEPEND="${CDEPEND}
!sci-libs/libgeda
!sci-electronics/geda-gschem
!sci-electronics/geda-symbols
@@ -38,6 +41,9 @@ DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.15.0
nls? ( >=sys-devel/gettext-0.16 )"
+RDEPEND="${RDEPEND}
+ sci-electronics/electronics-menu"
+
S="${WORKDIR}/${MY_P}"
src_prepare() {
@@ -67,12 +73,18 @@ src_install() {
dodoc AUTHORS NEWS README
}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
pkg_postinst() {
- fdo-mime_mime_database_update
fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
}
pkg_postrm() {
- fdo-mime_mime_database_update
fdo-mime_desktop_database_update
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
}