summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-22 08:33:08 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-22 08:33:08 +0000
commitdc8437f65430a626cc28eda66d3e15e0af7497d2 (patch)
tree10c77adc270270bfc4c493915ca4c4a2e0307f53 /sci-chemistry
parentx86 stable per bug 348634 (diff)
downloadgentoo-2-dc8437f65430a626cc28eda66d3e15e0af7497d2.tar.gz
gentoo-2-dc8437f65430a626cc28eda66d3e15e0af7497d2.tar.bz2
gentoo-2-dc8437f65430a626cc28eda66d3e15e0af7497d2.zip
New Addition
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/pymol-plugins-msms/ChangeLog10
-rw-r--r--sci-chemistry/pymol-plugins-msms/files/100415-msms.patch33
-rw-r--r--sci-chemistry/pymol-plugins-msms/metadata.xml17
-rw-r--r--sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415.ebuild46
4 files changed, 106 insertions, 0 deletions
diff --git a/sci-chemistry/pymol-plugins-msms/ChangeLog b/sci-chemistry/pymol-plugins-msms/ChangeLog
new file mode 100644
index 000000000000..bf553a656b7a
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-msms/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/pymol-plugins-msms
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-msms/ChangeLog,v 1.1 2011/03/22 08:33:08 jlec Exp $
+
+*pymol-plugins-msms-100415 (22 Mar 2011)
+
+ 22 Mar 2011; Justin Lecher <jlec@gentoo.org> +files/100415-msms.patch,
+ +pymol-plugins-msms-100415.ebuild, +metadata.xml:
+ New Addition
+
diff --git a/sci-chemistry/pymol-plugins-msms/files/100415-msms.patch b/sci-chemistry/pymol-plugins-msms/files/100415-msms.patch
new file mode 100644
index 000000000000..0d26fb31c5f1
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-msms/files/100415-msms.patch
@@ -0,0 +1,33 @@
+ pymol-plugins-msms-100415.py | 18 ++++++++++--------
+ 1 files changed, 10 insertions(+), 8 deletions(-)
+
+diff --git a/pymol-plugins-msms-100415.py b/pymol-plugins-msms-100415.py
+index 725934d..7ea00bf 100644
+--- a/pymol-plugins-msms-100415.py
++++ b/pymol-plugins-msms-100415.py
+@@ -99,15 +99,17 @@ class MSMSPlugin:
+ self.cleanup_saved_pymol_sel.set(True) # by default, clean up
+
+ self.pdb_fn.set('')
+- if 'MSMS_BIN' in os.environ:
+- if VERBOSE: print 'Found MSMS_BIN in environmental variables', os.environ['MSMS_BIN']
+- self.msms_bin.set(os.environ['MSMS_BIN'])
+- else:
+- if VERBOSE: print 'MSMS_BIN not found in environmental variables.'
+- self.msms_bin.set('')
++ self.msms_bin.set('GENTOOMSMS')
++## if 'MSMS_BIN' in os.environ:
++## if VERBOSE: print 'Found MSMS_BIN in environmental variables', os.environ['MSMS_BIN']
++## self.msms_bin.set(os.environ['MSMS_BIN'])
++## else:
++## if VERBOSE: print 'MSMS_BIN not found in environmental variables.'
++## self.msms_bin.set('')
+ ## self.pdb2xyzr_bin.set('')
+- if 'PDB2XYZRN' in os.environ: self.pdb2xyzrn_bin.set(os.environ['PDB2XYZRN'])
+- else: self.pdb2xyzrn_bin.set('')
++ self.pdb2xyzrn_bin.set('GENTOOXYZRN')
++## if 'PDB2XYZRN' in os.environ: self.pdb2xyzrn_bin.set(os.environ['PDB2XYZRN'])
++## else: self.pdb2xyzrn_bin.set('')
+ self.tmp_dir.set('/tmp')
+ self.cleanup_msms_output = Tkinter.BooleanVar()
+ self.cleanup_msms_output.set(True) # by default, clean up msms output
diff --git a/sci-chemistry/pymol-plugins-msms/metadata.xml b/sci-chemistry/pymol-plugins-msms/metadata.xml
new file mode 100644
index 000000000000..53db03dc2118
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-msms/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+<longdescription>
+MSMS is an excellent tool for computing protein solvent excluded surface (SES).
+MSMS Plugin for PyMOL provides a graphical user interface for running MSMS and
+displaying its results in PyMOL.
+
+1. Citation for this plugin:
+ Hongbo Zhu. MSMS plugin for PyMOL, 2010, Biotechnology Center (BIOTEC), TU Dresden.
+2. Citation for PyMOL can be found at: http://pymol.sourceforge.net/faq.html#CITE
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415.ebuild b/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415.ebuild
new file mode 100644
index 000000000000..cc5c5a579b71
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415.ebuild,v 1.1 2011/03/22 08:33:08 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils python
+
+DESCRIPTION="GUI for MSMS and displaying its results in PyMOL"
+HOMEPAGE="http://www.biotec.tu-dresden.de/~hongboz/msms_pymol/msms_pymol.html"
+SRC_URI="http://www.biotec.tu-dresden.de/~hongboz/msms_pymol/pymol_script/msms_pymol.py -> ${P}.py"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="BSD pymol"
+IUSE=""
+
+RDEPEND="
+ sci-chemistry/msms-bin
+ sci-chemistry/pymol"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ mkdir "${S}"
+ cp "${DISTDIR}"/${A} "${S}/"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-msms.patch
+ sed \
+ -e "s:GENTOOMSMS:${EPREFIX}/opt/bin/msms:g" \
+ -e "s:GENTOOXYZRN:${EPREFIX}/usr/bin/pdb_to_xyzrn:g" \
+ -i ${A} || die
+ python_copy_sources
+}
+
+src_install() {
+ installation() {
+ insinto $(python_get_sitedir)/pmg_tk/startup/
+ doins ${P}.py || die
+ }
+ python_execute_function -s installation
+}