summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-10-28 20:04:40 +0000
committerJustin Lecher <jlec@gentoo.org>2010-10-28 20:04:40 +0000
commitd2f01266137bd389b7c7a4501280a64c9d64bbf6 (patch)
tree8d7a42fe8f21691b72fe49534f48353b3004563a /sci-chemistry
parentimportant fix and Support for Python ABIs (diff)
downloadgentoo-2-d2f01266137bd389b7c7a4501280a64c9d64bbf6.tar.gz
gentoo-2-d2f01266137bd389b7c7a4501280a64c9d64bbf6.tar.bz2
gentoo-2-d2f01266137bd389b7c7a4501280a64c9d64bbf6.zip
New addition
(Portage version: 2.2.0_alpha2/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/hollow/ChangeLog10
-rw-r--r--sci-chemistry/hollow/hollow-1.1.ebuild52
-rw-r--r--sci-chemistry/hollow/metadata.xml8
3 files changed, 70 insertions, 0 deletions
diff --git a/sci-chemistry/hollow/ChangeLog b/sci-chemistry/hollow/ChangeLog
new file mode 100644
index 000000000000..6eac0f72791a
--- /dev/null
+++ b/sci-chemistry/hollow/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/hollow
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/hollow/ChangeLog,v 1.1 2010/10/28 20:04:40 jlec Exp $
+
+*hollow-1.1 (28 Oct 2010)
+
+ 28 Oct 2010; Justin Lecher <jlec@gentoo.org> +hollow-1.1.ebuild,
+ +metadata.xml:
+ New addition
+
diff --git a/sci-chemistry/hollow/hollow-1.1.ebuild b/sci-chemistry/hollow/hollow-1.1.ebuild
new file mode 100644
index 000000000000..f441d3ed3f56
--- /dev/null
+++ b/sci-chemistry/hollow/hollow-1.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/hollow/hollow-1.1.ebuild,v 1.1 2010/10/28 20:04:40 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit python
+
+DESCRIPTION="Production of surface images of proteins"
+HOMEPAGE="http://hollow.sourceforge.net/"
+#SRC_URI="mirror://sourceforge/${P}.zip"
+SRC_URI="http://hollow.sourceforge.net/${P}.zip"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+IUSE=""
+
+RDEPEND="sci-chemistry/pymol"
+DEPEND="app-arch/unzip"
+
+src_install() {
+ rm -rf pdbstruct/.svn || die
+ installation() {
+ insinto $(python_get_sitedir)
+ doins -r pdbstruct || die
+
+ insinto $(python_get_sitedir)/${PN}
+ doins *.py hollow.txt || die
+
+ cat >> ${PN} <<- EOF
+ $(PYTHON) -O "${EPREFIX}$(python_get_sitedir)/${PN}/${PN}.py" \$@
+ EOF
+
+ dobin ${PN}
+ }
+ python_execute_function installation
+
+ dodoc README || die
+}
+
+pkg_postinst() {
+ python_mod_optimize ${PN} pdbstruct
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${PN} pdbstruct
+}
diff --git a/sci-chemistry/hollow/metadata.xml b/sci-chemistry/hollow/metadata.xml
new file mode 100644
index 000000000000..043cc7527474
--- /dev/null
+++ b/sci-chemistry/hollow/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>