summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-20 08:44:08 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-20 08:44:08 +0000
commitbafe62c267b0944c6b6039ec602940fec01f2f2a (patch)
tree325d55f96cdd8b5ee1a6763b2eabde414d0a6350 /sci-chemistry
parentFix installation problem due to wrong detection of binary nameing (diff)
downloadgentoo-2-bafe62c267b0944c6b6039ec602940fec01f2f2a.tar.gz
gentoo-2-bafe62c267b0944c6b6039ec602940fec01f2f2a.tar.bz2
gentoo-2-bafe62c267b0944c6b6039ec602940fec01f2f2a.zip
Add missing src_compile
(Portage version: 2.2.0_alpha9/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/pdb2pqr/ChangeLog6
-rw-r--r--sci-chemistry/pdb2pqr/pdb2pqr-1.5.0-r2.ebuild16
-rw-r--r--sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r1.ebuild18
-rw-r--r--sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild16
4 files changed, 39 insertions, 17 deletions
diff --git a/sci-chemistry/pdb2pqr/ChangeLog b/sci-chemistry/pdb2pqr/ChangeLog
index 7d8e5fa49b96..586e400e281a 100644
--- a/sci-chemistry/pdb2pqr/ChangeLog
+++ b/sci-chemistry/pdb2pqr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/pdb2pqr
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/ChangeLog,v 1.31 2010/12/17 17:56:47 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/ChangeLog,v 1.32 2010/12/20 08:44:08 jlec Exp $
+
+ 20 Dec 2010; Justin Lecher <jlec@gentoo.org> pdb2pqr-1.5.0-r2.ebuild,
+ pdb2pqr-1.7.0.ebuild, pdb2pqr-1.7.0-r1.ebuild:
+ Add missing src_compile
17 Dec 2010; Justin Lecher <jlec@gentoo.org> pdb2pqr-1.5.0-r2.ebuild,
pdb2pqr-1.7.0.ebuild, pdb2pqr-1.7.0-r1.ebuild:
diff --git a/sci-chemistry/pdb2pqr/pdb2pqr-1.5.0-r2.ebuild b/sci-chemistry/pdb2pqr/pdb2pqr-1.5.0-r2.ebuild
index 36d077eb3767..7f3ef8f3640a 100644
--- a/sci-chemistry/pdb2pqr/pdb2pqr-1.5.0-r2.ebuild
+++ b/sci-chemistry/pdb2pqr/pdb2pqr-1.5.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.5.0-r2.ebuild,v 1.6 2010/12/17 17:56:47 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.5.0-r2.ebuild,v 1.7 2010/12/20 08:44:08 jlec Exp $
EAPI="3"
@@ -22,11 +22,11 @@ SLOT="0"
IUSE="doc examples opal"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
-DEPEND="
+RDEPEND="
dev-python/numpy
sci-chemistry/openbabel
opal? ( dev-python/zsi )"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -53,12 +53,18 @@ src_configure() {
NUMPY="${EPREFIX}/$(python_get_sitedir)" \
F77="$(tc-getFC)" \
econf \
- $(use_with opal) || \
- die "econf failed"
+ $(use_with opal)
}
python_execute_function -s configuration
}
+src_compile() {
+ compilation() {
+ emake || die
+ }
+ python_execute_function -s compilation
+}
+
src_test() {
testing() {
emake -j1 test \
diff --git a/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r1.ebuild b/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r1.ebuild
index 128e59179b8e..9a7a41445178 100644
--- a/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r1.ebuild
+++ b/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r1.ebuild,v 1.3 2010/12/17 17:56:47 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r1.ebuild,v 1.4 2010/12/20 08:44:08 jlec Exp $
EAPI="3"
@@ -62,18 +62,24 @@ src_configure() {
configuration() {
# Avoid automagic to numeric
- NUMPY="${EPREFIX}/$(python_get_sitedir)" \
- F77="$(tc-getFC)" \
- econf \
+ econf \
--enable-propka \
--with-max-atoms=${MAXATOMS:-10000} \
$(use_enable pdb2pka) \
- $(use_with opal) || \
- die "econf failed"
+ $(use_with opal) \
+ NUMPY="${EPREFIX}/$(python_get_sitedir)" \
+ F77="$(tc-getFC)"
}
python_execute_function -s configuration
}
+src_compile() {
+ compilation() {
+ emake || die
+ }
+ python_execute_function -s compilation
+}
+
src_test() {
testing() {
emake -j1 test \
diff --git a/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild b/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild
index a57b09d7ff94..ecf92df7d9d9 100644
--- a/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild
+++ b/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild,v 1.4 2010/12/17 17:56:47 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild,v 1.5 2010/12/20 08:44:08 jlec Exp $
EAPI="3"
@@ -22,11 +22,11 @@ SLOT="0"
IUSE="doc examples opal"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-DEPEND="
+RDEPEND="
dev-python/numpy
sci-chemistry/openbabel
opal? ( dev-python/zsi )"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -53,12 +53,18 @@ src_configure() {
NUMPY="${EPREFIX}/$(python_get_sitedir)" \
F77="$(tc-getFC)" \
econf \
- $(use_with opal) || \
- die "econf failed"
+ $(use_with opal)
}
python_execute_function -s configuration
}
+src_compile() {
+ compilation() {
+ emake || die
+ }
+ python_execute_function -s compilation
+}
+
src_test() {
testing() {
emake -j1 test \