summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-11 20:38:49 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-11 20:38:49 +0000
commitab22f1eeff17d6127b3171c121b2ca9b0f7c976f (patch)
treed7b80696b587c62f33d7e82919be6101639f85ab /sci-chemistry
parentUpdated metadata to reflect taking over maintenance of package. (diff)
downloadgentoo-2-ab22f1eeff17d6127b3171c121b2ca9b0f7c976f.tar.gz
gentoo-2-ab22f1eeff17d6127b3171c121b2ca9b0f7c976f.tar.bz2
gentoo-2-ab22f1eeff17d6127b3171c121b2ca9b0f7c976f.zip
sci-chemistry/coot: Version Bump, fixes compilation with gcc-4.7, #425836
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/coot/ChangeLog10
-rw-r--r--sci-chemistry/coot/coot-0.7_pre4266.ebuild171
-rw-r--r--sci-chemistry/coot/files/coot-0.7_pre4266-clipper-config.patch17
-rw-r--r--sci-chemistry/coot/files/coot-0.7_pre4266-goocanvas.patch25
-rw-r--r--sci-chemistry/coot/files/coot-0.7_pre4266-mmdb-config.patch18
-rw-r--r--sci-chemistry/coot/files/coot-0.7_pre4266-ssm.patch56
6 files changed, 296 insertions, 1 deletions
diff --git a/sci-chemistry/coot/ChangeLog b/sci-chemistry/coot/ChangeLog
index 4bda510b5d15..9af9cc16646a 100644
--- a/sci-chemistry/coot/ChangeLog
+++ b/sci-chemistry/coot/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-chemistry/coot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/ChangeLog,v 1.52 2012/03/07 19:33:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/ChangeLog,v 1.53 2012/07/11 20:38:49 jlec Exp $
+
+*coot-0.7_pre4266 (11 Jul 2012)
+
+ 11 Jul 2012; Justin Lecher <jlec@gentoo.org> +coot-0.7_pre4266.ebuild,
+ +files/coot-0.7_pre4266-clipper-config.patch,
+ +files/coot-0.7_pre4266-goocanvas.patch,
+ +files/coot-0.7_pre4266-mmdb-config.patch, +files/coot-0.7_pre4266-ssm.patch:
+ Version Bump, fixes compilation with gcc-4.7, #425836
07 Mar 2012; Justin Lecher <jlec@gentoo.org> coot-0.6.2.ebuild,
coot-0.6.2-r1.ebuild, coot-0.7_pre4040.ebuild:
diff --git a/sci-chemistry/coot/coot-0.7_pre4266.ebuild b/sci-chemistry/coot/coot-0.7_pre4266.ebuild
new file mode 100644
index 000000000000..6d331ba735e8
--- /dev/null
+++ b/sci-chemistry/coot/coot-0.7_pre4266.ebuild
@@ -0,0 +1,171 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.7_pre4266.ebuild,v 1.1 2012/07/11 20:38:49 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+AUTOTOOLS_AUTORECONF="true"
+
+inherit autotools-utils python toolchain-funcs versionator
+
+MY_S2_PV=$(replace_version_separator 2 - ${PV})
+MY_S2_P=${PN}-${MY_S2_PV/pre1/pre-1}
+MY_S_P=${MY_S2_P}-${PR/r/revision-}
+MY_PV=${PV}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Crystallographic Object-Oriented Toolkit for model building, completion and validation"
+HOMEPAGE="http://www.biop.ox.ac.uk/coot/"
+SRC_URI="
+ http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz
+ test? ( http://dev.gentoo.org/~jlec/distfiles/greg-data-${PV}.tar.gz )"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+openmp static-libs test"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+SCIDEPS="
+ >=sci-libs/ccp4-libs-6.1
+ >=sci-libs/clipper-20090520
+ >=sci-libs/coot-data-2
+ >=sci-libs/gsl-1.3
+ >=sci-libs/mmdb-1.23
+ sci-libs/ssm
+ <sci-libs/monomer-db-1
+ sci-chemistry/reduce
+ <sci-chemistry/refmac-5.6
+ sci-chemistry/probe"
+
+XDEPS="
+ gnome-base/libgnomecanvas
+ gnome-base/librsvg:2
+ media-libs/libpng
+ media-libs/freeglut
+ x11-libs/gtk+:2
+ x11-libs/goocanvas:0
+ x11-libs/gtkglext"
+
+SCHEMEDEPS="
+ dev-scheme/net-http
+ dev-scheme/guile-gui
+ >=dev-scheme/guile-lib-0.1.6
+ dev-scheme/guile-www
+ >=x11-libs/guile-gtk-2.1"
+
+RDEPEND="
+ ${SCIDEPS}
+ ${XDEPS}
+ ${SCHEMEDEPS}
+ dev-python/pygtk:2
+ >=dev-libs/gmp-4.2.2-r2
+ >=net-misc/curl-7.19.6
+ net-dns/libidn"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.4-r2
+ dev-lang/swig
+ sys-devel/bc
+ test? ( dev-scheme/greg )"
+
+pkg_setup() {
+ if use openmp; then
+ tc-has-openmp || die "Please use an OPENMP capable compiler"
+ fi
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-clipper-config.patch
+ "${FILESDIR}"/${P}-goocanvas.patch
+ "${FILESDIR}"/${P}-mmdb-config.patch
+ "${FILESDIR}"/${P}-ssm.patch
+ )
+
+src_prepare() {
+ sed \
+ -e "s:AM_COOT_SYS_BUILD_TYPE:COOT_SYS_BUILD_TYPE=Gentoo-Linux-$(PYTHON)-gtk2 ; AC_MSG_RESULT([\$COOT_SYS_BUILD_TYPE]); AC_SUBST(COOT_SYS_BUILD_TYPE):g" \
+ -i configure.in || die
+
+ autotools-utils_src_prepare
+
+ cat >> src/svn-revision.cc <<- EOF
+ extern "C" {
+ int svn_revision() {
+ return ${ESVN_WC_REVISION:-0};
+ }
+ }
+ EOF
+}
+
+src_configure() {
+ # All the --with's are used to activate various parts.
+ # Yes, this is broken behavior.
+ local myeconfargs=(
+ --includedir='${prefix}/include/coot'
+ --with-goocanvas-prefix="${EPREFIX}/usr"
+ --with-guile
+ --with-python="${EPREFIX}/usr"
+ --with-guile-gtk
+ --with-gtk2
+ --with-pygtk
+ $(use_enable openmp)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ python_convert_shebangs $(python_get_version) "${S}"/src/coot_gtk2.py
+ cp "${S}"/src/coot_gtk2.py python/coot.py || die
+}
+
+src_test() {
+ source "${EPREFIX}/etc/profile.d/40ccp4.setup.sh"
+ mkdir "${T}"/coot_test
+
+ export COOT_STANDARD_RESIDUES="${S}/standard-residues.pdb"
+ export COOT_SCHEME_DIR="${S}/scheme/"
+ export COOT_RESOURCES_FILE="${S}/cootrc"
+ export COOT_PIXMAPS_DIR="${S}/pixmaps/"
+ export COOT_DATA_DIR="${S}/"
+ export COOT_PYTHON_DIR="${S}/python/"
+ export PYTHONPATH="${COOT_PYTHON_DIR}:${PYTHONPATH}"
+ export PYTHONHOME="${EPREFIX}"/usr/
+ export CCP4_SCR="${T}"/coot_test/
+ export CLIBD_MON="${EPREFIX}/usr/share/ccp4/data/monomers/"
+ export SYMINFO="${S}/syminfo.lib"
+
+ export COOT_TEST_DATA_DIR="${WORKDIR}"/data/greg-data
+
+ cat > command-line-greg.scm <<- EOF
+ (use-modules (ice-9 greg))
+ (set! greg-tools (list "greg-tests"))
+ (set! greg-debug #t)
+ (set! greg-verbose 5)
+ (let ((r (greg-test-run)))
+ (if r
+ (coot-real-exit 0)
+ (coot-real-exit 1)))
+ EOF
+
+ einfo "Running test with following paths ..."
+ einfo "COOT_STANDARD_RESIDUES $COOT_STANDARD_RESIDUES"
+ einfo "COOT_SCHEME_DIR $COOT_SCHEME_DIR"
+ einfo "COOT_RESOURCES_FILE $COOT_RESOURCES_FILE"
+ einfo "COOT_PIXMAPS_DIR $COOT_PIXMAPS_DIR"
+ einfo "COOT_DATA_DIR $COOT_DATA_DIR"
+ einfo "COOT_PYTHON_DIR $COOT_PYTHON_DIR"
+ einfo "PYTHONPATH $PYTHONPATH"
+ einfo "PYTHONHOME $PYTHONHOME"
+ einfo "CCP4_SCR ${CCP4_SCR}"
+ einfo "CLIBD_MON ${CLIBD_MON}"
+ einfo "SYMINFO ${SYMINFO}"
+
+ "${S}"/src/coot-real --no-graphics --script command-line-greg.scm || die
+ "${S}"/src/coot-real --no-graphics --script python-tests/coot_unittest.py || die
+}
diff --git a/sci-chemistry/coot/files/coot-0.7_pre4266-clipper-config.patch b/sci-chemistry/coot/files/coot-0.7_pre4266-clipper-config.patch
new file mode 100644
index 000000000000..311b5e88d84e
--- /dev/null
+++ b/sci-chemistry/coot/files/coot-0.7_pre4266-clipper-config.patch
@@ -0,0 +1,17 @@
+ macros/clipper.m4 | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/macros/clipper.m4 b/macros/clipper.m4
+index 0bf087a..d0e8b6b 100644
+--- a/macros/clipper.m4
++++ b/macros/clipper.m4
+@@ -98,6 +98,9 @@ case $ac_cv_build_alias in
+ ;;
+ esac
+
++CLIPPER_CXXFLAGS=`clipper-config --cflags`
++CLIPPER_LDOPTS=`clipper-config --libs`
++
+ AC_MSG_CHECKING([for Clipper])
+
+ LIBS="$save_LIBS $CLIPPER_LDOPTS"
diff --git a/sci-chemistry/coot/files/coot-0.7_pre4266-goocanvas.patch b/sci-chemistry/coot/files/coot-0.7_pre4266-goocanvas.patch
new file mode 100644
index 000000000000..ce0d4a00abba
--- /dev/null
+++ b/sci-chemistry/coot/files/coot-0.7_pre4266-goocanvas.patch
@@ -0,0 +1,25 @@
+Index: macros/goo-canvas.m4
+===================================================================
+--- macros/goo-canvas.m4 (revision 3307)
++++ macros/goo-canvas.m4 (working copy)
+@@ -56,9 +56,9 @@
+ fi
+ fi
+
+-AC_MSG_CHECKING([for Goocanvas])
++PKG_CHECK_MODULES(GOOCANVAS, goocanvas)
+
+-LIBS="$saved_LIBS $GOOCANVAS_LDOPTS $GTK_LIBS"
++LIBS="$saved_LIBS $GOOCANVAS_LIBS $GTK_LIBS"
+ CXXFLAGS="$saved_CXXFLAGS $GOOCANVAS_CFLAGS $GTK_CFLAGS"
+ #
+ # AC_TRY_LINK uses the c compiler (set by AC_LANG), so we will
+@@ -76,7 +76,7 @@
+ if test x$have_goocanvas = xyes; then
+
+ GOOCANVAS_CFLAGS="$GOOCANVAS_CFLAGS"
+- GOOCANVAS_LIBS="$GOOCANVAS_LDOPTS"
++ GOOCANVAS_LIBS="$GOOCANVAS_LIBS"
+
+ ifelse([$1], , :, [$1])
+
diff --git a/sci-chemistry/coot/files/coot-0.7_pre4266-mmdb-config.patch b/sci-chemistry/coot/files/coot-0.7_pre4266-mmdb-config.patch
new file mode 100644
index 000000000000..b3b66ab65786
--- /dev/null
+++ b/sci-chemistry/coot/files/coot-0.7_pre4266-mmdb-config.patch
@@ -0,0 +1,18 @@
+Index: macros/mmdb.m4
+===================================================================
+--- macros/mmdb.m4 (revision 3579)
++++ macros/mmdb.m4 (working copy)
+@@ -86,8 +86,12 @@
+ ac_MMDB_LDOPTS="-lmmdb -lm"
+ fi
+
+-AC_MSG_CHECKING([for MMDB])
++PKG_CHECK_MODULES([MMDB],[mmdb >= 1.2])
++ac_MMDB_LDOPTS="${MMDB_LIBS}"
++ac_MMDB_CXXFLAGS="${MMDB_CFLAGS}"
+
++AC_MSG_CHECKING([for CISPEP in MMDB])
++
+ LIBS="$save_LIBS $ac_MMDB_LDOPTS"
+ CXXFLAGS="$save_CXXFLAGS $ac_MMDB_CXXFLAGS"
+ #
diff --git a/sci-chemistry/coot/files/coot-0.7_pre4266-ssm.patch b/sci-chemistry/coot/files/coot-0.7_pre4266-ssm.patch
new file mode 100644
index 000000000000..c801da72410a
--- /dev/null
+++ b/sci-chemistry/coot/files/coot-0.7_pre4266-ssm.patch
@@ -0,0 +1,56 @@
+ macros/mmdb-ssm.m4 | 42 +-----------------------------------------
+ 1 files changed, 1 insertions(+), 41 deletions(-)
+
+diff --git a/macros/mmdb-ssm.m4 b/macros/mmdb-ssm.m4
+index 1937a16..6ef547c 100644
+--- a/macros/mmdb-ssm.m4
++++ b/macros/mmdb-ssm.m4
+@@ -22,47 +22,7 @@
+ AC_DEFUN([AM_WITH_MMDBSSM],
+ [AC_PROVIDE([AM_USE_MMDBSSM])
+
+-
+-AC_ARG_WITH(ssmlib-prefix,
+- AC_HELP_STRING( [--with-ssmlib-prefix=PFX], [Prefix where SSMLib has been installed] ),
+- [ with_ssmlib_prefix="$withval" ],
+- with_ssmlib_prefix="")
+-
+-AC_MSG_CHECKING([for SSMLib])
+-
+-if test x$with_ssmlib_prefix != x; then
+-
+- MMDBSSM_CXXFLAGS="-DHAVE_SSMLIB"
+- MMDBSSM_LIBS="-L$with_ssmlib_prefix/$acl_libdirstem -lssm"
+-
+-ac_mmdb_dirs='
+-.
+-include
+-include/ssm
+-include/mmdb
+-lib
+-src
+-lib/src
+-lib/src/mmdb'
+-
+- for ac_dir in $ac_mmdb_dirs; do
+- if test -r "$with_ssmlib_prefix/$ac_dir/ssm_superpose.h"; then
+- ac_MMDBSSM_CXXFLAGS="-I$with_ssmlib_prefix/$ac_dir"
+- break
+- fi
+- done
+-
+- MMDBSSM_CXXFLAGS="$MMDBSSM_CXXFLAGS $ac_MMDBSSM_CXXFLAGS"
+-
+-else
+-
+- MMDBSSM_CXXFLAGS=""
+- MMDBSSM_LIBS=""
+- with_ssmlib_prefix=no
+-
+-fi
+-
+-AC_MSG_RESULT([$with_ssmlib_prefix])
++PKG_CHECK_MODULES([MMDBSSM],[ssm])
+
+ AC_SUBST(MMDBSSM_CXXFLAGS)
+ AC_SUBST(MMDBSSM_LIBS)