summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-06 13:46:51 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-06 13:46:51 +0000
commita9f0cd7ebf861fba3a36cf041254973b38b325bc (patch)
tree37e1d546944f8147f30bb06dfb5a900d7f323723 /sci-chemistry
parentRestrict Jython ABIs. (diff)
downloadgentoo-2-a9f0cd7ebf861fba3a36cf041254973b38b325bc.tar.gz
gentoo-2-a9f0cd7ebf861fba3a36cf041254973b38b325bc.tar.bz2
gentoo-2-a9f0cd7ebf861fba3a36cf041254973b38b325bc.zip
Using xiar instead of ar
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/cyana/ChangeLog6
-rw-r--r--sci-chemistry/cyana/cyana-2.1.ebuild17
-rw-r--r--sci-chemistry/cyana/files/2.1-xiar.patch16
3 files changed, 31 insertions, 8 deletions
diff --git a/sci-chemistry/cyana/ChangeLog b/sci-chemistry/cyana/ChangeLog
index 1ddb4fde5615..f1fbc2532c67 100644
--- a/sci-chemistry/cyana/ChangeLog
+++ b/sci-chemistry/cyana/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/cyana
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cyana/ChangeLog,v 1.8 2011/01/05 14:14:58 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cyana/ChangeLog,v 1.9 2011/04/06 13:46:51 jlec Exp $
+
+ 06 Apr 2011; Justin Lecher <jlec@gentoo.org> +files/2.1-xiar.patch,
+ cyana-2.1.ebuild:
+ Using xiar instead of ar
05 Jan 2011; Justin Lecher <jlec@gentoo.org> files/2.1-expire.patch:
Let cyana run forever, thanks xarthisius for the patch
diff --git a/sci-chemistry/cyana/cyana-2.1.ebuild b/sci-chemistry/cyana/cyana-2.1.ebuild
index 8bc49e90f8ba..726f8e4c77bf 100644
--- a/sci-chemistry/cyana/cyana-2.1.ebuild
+++ b/sci-chemistry/cyana/cyana-2.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cyana/cyana-2.1.ebuild,v 1.6 2010/12/20 08:19:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cyana/cyana-2.1.ebuild,v 1.7 2011/04/06 13:46:51 jlec Exp $
EAPI="3"
@@ -32,18 +32,21 @@ src_prepare() {
epatch \
"${FILESDIR}"/${PV}-typo.patch \
"${FILESDIR}"/${PV}-exec.patch \
- "${FILESDIR}"/${PV}-expire.patch
+ "${FILESDIR}"/${PV}-expire.patch \
+ "${FILESDIR}"/${PV}-xiar.patch
cat >> etc/config <<- EOF
VERSION=${PV}
SHELL=${EPREFIX}/bin/sh
FC=ifort
- FFLAGS=${FFLAGS}
- FFLAGS2=${FFLAGS}
+ FFLAGS=${FFLAGS} -openmp -threads
+ FFLAGS2=${FFLAGS} -openmp -threads
CC=$(tc-getCC)
+ AR=xiar
+ RANLIB=ranlib
FORK=g77fork.o
- LDFLAGS=${LDFLAGS}
- LIBS=-pthread -lpthread -liomp5
+ LDFLAGS=${LDFLAGS} -reentrancy threaded -openmp
+ LIBS=
EOF
if [[ $(tc-getFC) =~ gfortran ]]; then
diff --git a/sci-chemistry/cyana/files/2.1-xiar.patch b/sci-chemistry/cyana/files/2.1-xiar.patch
new file mode 100644
index 000000000000..e8393253d7f6
--- /dev/null
+++ b/sci-chemistry/cyana/files/2.1-xiar.patch
@@ -0,0 +1,16 @@
+ src/inclan/Makefile | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/inclan/Makefile b/src/inclan/Makefile
+index fc5a8bf..482d48f 100644
+--- a/src/inclan/Makefile
++++ b/src/inclan/Makefile
+@@ -35,7 +35,7 @@ clean:
+
+ inclan.a: $(OBJS)
+ rm -f $@
+- ar rc $@ $(OBJS)
++ $(AR) rc $@ $(OBJS)
+ if [ "$(RANLIB)" ]; then $(RANLIB) $@; fi
+
+ inclan.o: inclan.for