summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-05-13 10:25:00 +0000
committerJustin Lecher <jlec@gentoo.org>2014-05-13 10:25:00 +0000
commit987477c905ec81c07209b3994bfd3f22790266f1 (patch)
treef2dcda432fde2ba6446a58814f3aa8554fc064c3 /sci-chemistry
parentStable for amd64 wrt bug #506290 (diff)
downloadgentoo-2-987477c905ec81c07209b3994bfd3f22790266f1.tar.gz
gentoo-2-987477c905ec81c07209b3994bfd3f22790266f1.tar.bz2
gentoo-2-987477c905ec81c07209b3994bfd3f22790266f1.zip
sci-chemistry/GromacsWrapper: Version Bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/GromacsWrapper/ChangeLog9
-rw-r--r--sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.2.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/sci-chemistry/GromacsWrapper/ChangeLog b/sci-chemistry/GromacsWrapper/ChangeLog
index 19d0f8615102..428a529caaf5 100644
--- a/sci-chemistry/GromacsWrapper/ChangeLog
+++ b/sci-chemistry/GromacsWrapper/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/GromacsWrapper
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/GromacsWrapper/ChangeLog,v 1.3 2013/06/19 03:50:54 bicatali Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/GromacsWrapper/ChangeLog,v 1.4 2014/05/13 10:25:00 jlec Exp $
+
+*GromacsWrapper-0.3.2 (13 May 2014)
+
+ 13 May 2014; Justin Lecher <jlec@gentoo.org> +GromacsWrapper-0.3.2.ebuild:
+ Version Bump
19 Jun 2013; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml:
Changed herd to sci-chemistry
diff --git a/sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.2.ebuild b/sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.2.ebuild
new file mode 100644
index 000000000000..a58afd382323
--- /dev/null
+++ b/sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.2.ebuild,v 1.1 2014/05/13 10:25:00 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+if [[ $PV = *9999* ]]; then
+ scm_eclass=git-2
+ EGIT_REPO_URI="
+ git://github.com/orbeckst/${PN}.git
+ https://github.com/orbeckst/${PN}.git"
+ EGIT_BRANCH="develop"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ scm_eclass=vcs-snapshot
+ SRC_URI="https://github.com/orbeckst/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit eutils distutils-r1 ${scm_eclass}
+
+DESCRIPTION="Python framework for Gromacs"
+HOMEPAGE="http://orbeckst.github.com/GromacsWrapper/"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=dev-python/matplotlib-0.91.3[${PYTHON_USEDEP}]
+ >=dev-python/RecSQL-0.3[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.9[${PYTHON_USEDEP}]
+ "
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/0001-Drop-chmod-hack.patch"
+)