summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-12-27 17:12:39 +0000
committerJustin Lecher <jlec@gentoo.org>2011-12-27 17:12:39 +0000
commit929ec56ab56325e2909b33fcf188715b47deda78 (patch)
tree2c1186d92b6ce2df8d0a75e1555109805ddbd656 /sci-chemistry
parentRevbump to actually use swt-3.7 instead of 3.6, bug #390921. (diff)
downloadgentoo-2-929ec56ab56325e2909b33fcf188715b47deda78.tar.gz
gentoo-2-929ec56ab56325e2909b33fcf188715b47deda78.tar.bz2
gentoo-2-929ec56ab56325e2909b33fcf188715b47deda78.zip
Version Bump
(Portage version: 2.2.0_alpha83/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/scala/ChangeLog7
-rw-r--r--sci-chemistry/scala/scala-3.3.20.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/sci-chemistry/scala/ChangeLog b/sci-chemistry/scala/ChangeLog
index b2f6f19e4e4c..c3e2871389d0 100644
--- a/sci-chemistry/scala/ChangeLog
+++ b/sci-chemistry/scala/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/scala
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/scala/ChangeLog,v 1.10 2011/06/21 15:57:08 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/scala/ChangeLog,v 1.11 2011/12/27 17:12:39 jlec Exp $
+
+*scala-3.3.20 (27 Dec 2011)
+
+ 27 Dec 2011; Justin Lecher <jlec@gentoo.org> +scala-3.3.20.ebuild:
+ Version Bump
21 Jun 2011; Justin Lecher <jlec@gentoo.org> scala-3.3.18-r1.ebuild,
scala-3.3.18-r2.ebuild:
diff --git a/sci-chemistry/scala/scala-3.3.20.ebuild b/sci-chemistry/scala/scala-3.3.20.ebuild
new file mode 100644
index 000000000000..c2e971b750f3
--- /dev/null
+++ b/sci-chemistry/scala/scala-3.3.20.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/scala/scala-3.3.20.ebuild,v 1.1 2011/12/27 17:12:39 jlec Exp $
+
+EAPI=4
+
+inherit autotools fortran-2
+
+DESCRIPTION="Scale together multiple observations of reflections"
+HOMEPAGE="http://www.ccp4.ac.uk/dist/html/scala.html"
+SRC_URI="ftp://ftp.mrc-lmb.cam.ac.uk/pub/pre/${P}.tar.gz"
+
+LICENSE="ccp4"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ !<sci-chemistry/ccp4-6.1.2
+ sci-libs/ccp4-libs
+ virtual/fortran
+ virtual/lapack"
+DEPEND="
+ ${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ cp "${FILESDIR}"/{configure.ac,Makefile.am} "${S}"
+ eautoreconf
+}
+
+src_install() {
+ exeinto /usr/libexec/ccp4/bin/
+ doexe ${PN}
+ dosym ../libexec/ccp4/bin/${PN} /usr/bin/${PN}
+ dodoc ${PN}.doc
+ dohtml ${PN}.html
+}