summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-08-17 03:19:07 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-08-17 03:19:07 +0000
commit76625873af5f7dd89cb9483d7dbbe16b620c2e39 (patch)
tree99282f457f43e9e8bfa5983bc9e6cef95c035c32 /sci-chemistry
parentversion bump (diff)
downloadgentoo-2-76625873af5f7dd89cb9483d7dbbe16b620c2e39.tar.gz
gentoo-2-76625873af5f7dd89cb9483d7dbbe16b620c2e39.tar.bz2
gentoo-2-76625873af5f7dd89cb9483d7dbbe16b620c2e39.zip
version bump
(Portage version: 2.2.0_alpha121/cvs/Linux i686)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/votca-csg/ChangeLog8
-rw-r--r--sci-chemistry/votca-csg/votca-csg-1.2.3.ebuild94
2 files changed, 100 insertions, 2 deletions
diff --git a/sci-chemistry/votca-csg/ChangeLog b/sci-chemistry/votca-csg/ChangeLog
index b1b72d954844..2f0b18561d4d 100644
--- a/sci-chemistry/votca-csg/ChangeLog
+++ b/sci-chemistry/votca-csg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/votca-csg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/votca-csg/ChangeLog,v 1.19 2012/05/04 07:02:33 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/votca-csg/ChangeLog,v 1.20 2012/08/17 03:19:07 ottxor Exp $
+
+*votca-csg-1.2.3 (17 Aug 2012)
+
+ 17 Aug 2012; Christoph Junghans <ottxor@gentoo.org> +votca-csg-1.2.3.ebuild:
+ version bump
04 May 2012; Jeff Horelick <jdhore@gentoo.org> votca-csg-1.2.2.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -76,4 +81,3 @@
12 Feb 2011; Christoph Junghans <ottxor@gentoo.org> +votca-csg-1.0.1.ebuild,
+metadata.xml:
Initial commit (bug #296707)
-
diff --git a/sci-chemistry/votca-csg/votca-csg-1.2.3.ebuild b/sci-chemistry/votca-csg/votca-csg-1.2.3.ebuild
new file mode 100644
index 000000000000..207009dffd76
--- /dev/null
+++ b/sci-chemistry/votca-csg/votca-csg-1.2.3.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/votca-csg/votca-csg-1.2.3.ebuild,v 1.1 2012/08/17 03:19:07 ottxor Exp $
+
+EAPI=4
+
+inherit bash-completion-r1 cmake-utils multilib
+
+IUSE="doc examples extras +gromacs +system-boost"
+PDEPEND="extras? ( =sci-chemistry/votca-csgapps-${PV} )"
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="http://votca.googlecode.com/files/${PF}.tar.gz
+ doc? ( http://votca.googlecode.com/files/${PN}-manual-${PV}.pdf )
+ examples? ( http://votca.googlecode.com/files/${PN}-tutorials-${PV}.tar.gz )"
+ RESTRICT="primaryuri"
+else
+ SRC_URI=""
+ inherit mercurial
+ EHG_REPO_URI="https://csg.votca.googlecode.com/hg"
+ EHG_REVISION="default"
+ S="${WORKDIR}/${EHG_REPO_URI##*/}"
+ PDEPEND="${PDEPEND} doc? ( =app-doc/${PN}-manual-${PV} )
+ examples? ( =sci-chemistry/${PN}-tutorials-${PV} )"
+fi
+
+DESCRIPTION="Votca coarse-graining engine"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+
+RDEPEND="=sci-libs/votca-tools-${PV}[system-boost=]
+ gromacs? ( sci-chemistry/gromacs )
+ dev-lang/perl
+ app-shells/bash"
+
+DEPEND="${RDEPEND}
+ doc? ( || ( <app-doc/doxygen-1.7.6.1[-nodot] >=app-doc/doxygen-1.7.6.1[dot] ) )
+ >=app-text/txt2tags-2.5
+ virtual/pkgconfig"
+
+DOCS=(README NOTICE ChangeLog)
+
+src_configure() {
+ local GMX_DEV="OFF" GMX_DOUBLE="OFF" extra
+
+ if use gromacs; then
+ has_version =sci-chemistry/gromacs-9999 && GMX_DEV="ON"
+ has_version sci-chemistry/gromacs[double-precision] && GMX_DOUBLE="ON"
+ fi
+
+ #to create man pages, build tree binaries are executed (bug #398437)
+ [[ ${CHOST} = *-darwin* ]] && \
+ extra+=" -DCMAKE_BUILD_WITH_INSTALL_RPATH=OFF"
+
+ mycmakeargs=(
+ $(cmake-utils_use system-boost EXTERNAL_BOOST)
+ $(cmake-utils_use_with gromacs GMX)
+ -DWITH_GMX_DEVEL="${GMX_DEV}"
+ -DGMX_DOUBLE="${GMX_DOUBLE}"
+ ${extra}
+ -DWITH_RC_FILES=OFF
+ -DLIB=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ newbashcomp scripts/csg-completion.bash ${PN}
+ cmake-utils_src_install
+ if use doc; then
+ if [ -n "${PV##*9999}" ]; then
+ dodoc "${DISTDIR}/${PN}-manual-${PV}.pdf"
+ fi
+ cd "${CMAKE_BUILD_DIR}" || die
+ cd share/doc || die
+ doxygen || die
+ dohtml -r html/*
+ fi
+ if use examples && [ -n "${PV##*9999}" ]; then
+ insinto "/usr/share/doc/${PF}/tutorials"
+ docompress -x "/usr/share/doc/${PF}/tutorials"
+ doins -r "${WORKDIR}/${PN}-tutorials-${PV}"/*
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please read and cite:"
+ einfo "VOTCA, J. Chem. Theory Comput. 5, 3211 (2009). "
+ einfo "http://dx.doi.org/10.1021/ct900369w"
+ einfo
+}