summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-08-07 03:42:00 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-08-07 03:42:00 +0000
commit5f13586cda0a201359967b83c0dca9966aec71e3 (patch)
tree3417c90d63925b0e12414b08941c3f96d9f2ab4f /sci-chemistry
parentVersion bump with fix from Fedora for security issue #139325. (diff)
downloadgentoo-2-5f13586cda0a201359967b83c0dca9966aec71e3.tar.gz
gentoo-2-5f13586cda0a201359967b83c0dca9966aec71e3.tar.bz2
gentoo-2-5f13586cda0a201359967b83c0dca9966aec71e3.zip
Add upstream patches. The build system won't accept LDFLAGS, so unset them. (#142183) Source the setup script again in src_install() to make sure CBIN and CCP4_LIB get set. Not doing this breaks USE=X because the Imakefiles use them. Stop changing the value of CCP4_LIB, that was only necessary for the bindir=/usr/bin, libdir=/usr/libdir install, which was too much work.
(Portage version: 2.1.1_pre4-r2)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/ccp4/ChangeLog12
-rw-r--r--sci-chemistry/ccp4/ccp4-6.0.1-r1.ebuild453
-rw-r--r--sci-chemistry/ccp4/files/digest-ccp4-6.0.1-r139
3 files changed, 503 insertions, 1 deletions
diff --git a/sci-chemistry/ccp4/ChangeLog b/sci-chemistry/ccp4/ChangeLog
index 5696511daf85..4b3519f47530 100644
--- a/sci-chemistry/ccp4/ChangeLog
+++ b/sci-chemistry/ccp4/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sci-chemistry/ccp4
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4/ChangeLog,v 1.3 2006/08/05 05:06:08 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4/ChangeLog,v 1.4 2006/08/07 03:42:00 dberkholz Exp $
+
+*ccp4-6.0.1-r1 (07 Aug 2006)
+
+ 07 Aug 2006; Donnie Berkholz <dberkholz@gentoo.org>;
+ +ccp4-6.0.1-r1.ebuild:
+ Add upstream patches. The build system won't accept LDFLAGS, so unset them.
+ (#142183) Source the setup script again in src_install() to make sure CBIN
+ and CCP4_LIB get set. Not doing this breaks USE=X because the Imakefiles use
+ them. Stop changing the value of CCP4_LIB, that was only necessary for the
+ bindir=/usr/bin, libdir=/usr/libdir install, which was too much work.
05 Aug 2006; Donnie Berkholz <dberkholz@gentoo.org>; metadata.xml:
Remove myself as maintainer, anyone feel free to work on this, although I'll
diff --git a/sci-chemistry/ccp4/ccp4-6.0.1-r1.ebuild b/sci-chemistry/ccp4/ccp4-6.0.1-r1.ebuild
new file mode 100644
index 000000000000..997e42a76d66
--- /dev/null
+++ b/sci-chemistry/ccp4/ccp4-6.0.1-r1.ebuild
@@ -0,0 +1,453 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4/ccp4-6.0.1-r1.ebuild,v 1.1 2006/08/07 03:42:00 dberkholz Exp $
+
+inherit fortran eutils gnuconfig toolchain-funcs
+
+FORTRAN="g77 gfortran ifc"
+
+SRC="ftp://ftp.ccp4.ac.uk/ccp4"
+
+PATCH_TOT="12"
+PATCH1=( src/mmdb_app_
+ chainsaw.cpp-11May2006.diff )
+PATCH2=( src
+ anisoanl.f-r1.22-r1.24.diff )
+PATCH3=( src/sc_
+ sc.f-r1.9-r1.9.2.1.diff )
+PATCH4=( src/sc_
+ setup.fh-r1.5-r1.5.2.1.diff )
+PATCH5=( src
+ contact.f-12June2006.diff )
+PATCH6=( ccp4i/tasks
+ refmac5.tcl-r1.39.2.3-r1.42.diff )
+PATCH7=( src
+ act.f-6July2006.diff )
+PATCH8=( src
+ rotmat.f-17July2006.diff )
+PATCH9=( src/molrep_
+ molrep.f-r1.28-r1.28.2.1.diff )
+PATCH10=( src
+ cad.f-r1.70-r1.72.diff )
+PATCH11=( src
+ mtztona4.f-r1.23-r1.24.diff )
+PATCH12=( src
+ omit.f-r1.12-r1.13.diff )
+
+DESCRIPTION="Protein X-ray crystallography toolkit"
+HOMEPAGE="http://www.ccp4.ac.uk/"
+RESTRICT="mirror stricter"
+SRC_URI="${SRC}/${PV}/packed/${P}-core-src.tar.gz"
+for i in $(seq $PATCH_TOT); do
+ NAME="PATCH${i}[1]"
+ SRC_URI="${SRC_URI}
+ ${SRC}/${PV}/patches/${!NAME}"
+done
+LICENSE="ccp4"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="X"
+# app-office/sc overlaps sc binary and man page
+# We can't rename ours since the automated ccp4i interface expects it there,
+# as do many scripts. app-office/sc can't rename its because that's the name
+# of the package.
+RDEPEND="X? (
+ || (
+ (
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXaw
+ )
+ virtual/x11
+ )
+ )
+ >=dev-lang/tcl-8.3
+ >=dev-lang/tk-8.3
+ >=dev-tcltk/blt-2.4
+ virtual/lapack
+ virtual/blas
+ =sci-libs/fftw-2*
+ sci-chemistry/pdb-extract
+ sci-chemistry/rasmol
+ sci-libs/mccp4
+ || ( app-shells/tcsh app-shells/csh )
+ !app-office/sc"
+# >=sys-apps/portage-2.1.1_pre1 for RESTRICT=stricter
+# Otherwise portage dies instead of fixing RPATHs
+DEPEND="${RDEPEND}
+ X? (
+ || (
+ (
+ x11-misc/imake
+ x11-proto/inputproto
+ x11-proto/xextproto
+ )
+ virtual/x11
+ )
+ )
+ >=sys-apps/portage-2.1.1_pre1"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ einfo "Applying upstream patches ..."
+ for patch in $(seq $PATCH_TOT); do
+ base="PATCH${patch}"
+ dir=$(eval echo \${${base}[0]})
+ p=$(eval echo \${${base}[1]})
+ pushd ${dir} >& /dev/null
+ ccp_patch ${DISTDIR}/${p}
+ popd >& /dev/null
+ done
+ einfo "Done."
+ echo
+
+ einfo "Applying Gentoo patches ..."
+ # These two only needed when attempting to install outside build dir via
+ # --bindir and --libdir instead of straight copying after build
+
+ # it attempts to install some libraries during the build
+ #ccp_patch ${FILESDIR}/${P}-install-libs-at-install-time.patch
+ # hklview/ipdisp.exe/xdlmapman/ipmosflm can't find libxdl_view
+ # without this patch when --libdir is set
+ # Rotgen still needs more patching to find it
+ #ccp_patch ${FILESDIR}/add-xdl-libdir.patch
+
+ # it tries to create libdir, bindir etc on live system in configure
+ ccp_patch ${FILESDIR}/${PV}-dont-make-dirs-in-configure.patch
+
+ # We already have sci-chemistry/rasmol
+ ccp_patch ${FILESDIR}/dont-build-rasmol.patch
+
+ # We already have sci-chemistry/pdb-extract
+# Use configure option instead
+# ccp_patch ${FILESDIR}/dont-build-pdb-extract.patch
+
+ ccp_patch ${FILESDIR}/create-mosflm-bindir.patch
+ ccp_patch ${FILESDIR}/make-mosflm-libdir.patch
+ ccp_patch ${FILESDIR}/make-mosflm-index-libdir.patch
+ ccp_patch ${FILESDIR}/make-mosflm-cbf-libdir.patch
+ ccp_patch ${FILESDIR}/make-ipmosflm-dir.patch
+
+# Don't use these when we aren't building phaser
+# ccp_patch ${FILESDIR}/make-phaser-bindir.patch
+# ccp_patch ${FILESDIR}/no-phaser-ld-assume-kernel.patch
+# # scons config.py tries to chmod python on live system
+# ccp_patch ${FILESDIR}/dont-chmod-python-binary.patch
+
+ # Don't use this when we aren't building clipper
+ # For some reason clipper check for $enableval even when --enable is passed
+ ccp_patch ${FILESDIR}/pass-clipper-enablevals.patch
+ ccp_patch ${FILESDIR}/clipper-find-mccp4-includes.patch
+
+ # Default to firefox browser, not 'netscape'
+ ccp_patch ${FILESDIR}/ccp4i-default-to-firefox.patch
+
+ # Also use -lpthread when linking blas and lapack
+ # We may need more fixing to use libcblas for the C files
+ ccp_patch ${FILESDIR}/check-blas-lapack-pthread.patch
+
+ # gerror_ gets defined twice on ppc if you're using gfortran/g95
+ ccp_patch ${FILESDIR}/${PV}-ppc-double-define-gerror.patch
+
+ einfo "Done." # done applying Gentoo patches
+ echo
+
+ gnuconfig_update
+}
+
+src_compile() {
+ # Build system is broken if we set LDFLAGS
+ unset LDFLAGS
+
+ # GENTOO_OSNAME can be one of:
+ # irix irix64 sunos sunos64 aix hpux osf1 linux freebsd
+ # linux_compaq_compilers linux_intel_compilers generic Darwin
+ # ia64_linux_intel Darwin_ibm_compilers linux_ibm_compilers
+ if [[ "${FORTRANC}" = "ifc" ]]; then
+ if use ia64; then
+ GENTOO_OSNAME="ia64_linux_intel"
+ else
+ # Should be valid for x86, maybe amd64
+ GENTOO_OSNAME="linux_intel_compilers"
+ fi
+ else
+ # Should be valid for x86 and amd64, at least
+ GENTOO_OSNAME="linux"
+ fi
+
+ # Sets up env
+ ln -s \
+ ccp4.setup-bash \
+ ${S}/include/ccp4.setup
+
+ # We agree to the license by emerging this, set in LICENSE
+ sed -i \
+ -e "s~^\(^agreed=\).*~\1yes~g" \
+ ${S}/configure
+
+ # Fix up variables -- need to reset CCP4_MASTER at install-time
+ sed -i \
+ -e "s~^\(setenv CCP4_MASTER.*\)/.*~\1${WORKDIR}~g" \
+ -e "s~^\(setenv CCP4I_TCLTK.*\)/usr/local/bin~\1/usr/bin~g" \
+ ${S}/include/ccp4.setup*
+
+ # Set up variables for build
+ source ${S}/include/ccp4.setup
+
+ export CC=$(tc-getCC)
+ export CXX=$(tc-getCXX)
+ export COPTIM=${CFLAGS}
+ export CXXOPTIM=${CXXFLAGS}
+ # Default to -O2 if FFLAGS is unset
+ export FC=${FORTRANC}
+ export FOPTIM=${FFLAGS:- -O2}
+
+ # Can't use econf, configure rejects unknown options like --prefix
+ ./configure \
+ $(use_enable X x) \
+ --with-shared-libs \
+ --with-fftw=/usr \
+ --with-warnings \
+ --disable-pdb_extract \
+ --disable-cctbx \
+ --disable-phaser \
+ --tmpdir="${TMPDIR}" \
+ ${GENTOO_OSNAME} || die "econf failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ # Set up variables for build
+ source ${S}/include/ccp4.setup
+
+# Only needed when using --bindir and --libdir
+ # Needed to avoid errors. Originally tried to make lib and bin
+ # in configure script, now patched out by dont-make-dirs-in-configure.patch
+# dodir /usr/include /usr/$(get_libdir) /usr/bin
+
+# make install || die "install failed"
+ einstall || die "install failed"
+
+ # Fix env
+ sed -i \
+ -e "s~^\(setenv CCP4_MASTER.*\)${WORKDIR}~\1/usr~g" \
+ -e "s~^\(setenv CCP4.*\$CCP4_MASTER\).*~\1~g" \
+ -e "s~^\(setenv CCP4I_TOP\).*~\1 \$CCP4/$(get_libdir)/ccp4/ccp4i~g" \
+ -e "s~^\(.*setenv CINCL.*\$CCP4\).*~\1/share/ccp4/include~g" \
+ -e "s~^\(.*setenv CLIBD .*\$CCP4\).*~\1/share/ccp4/data~g" \
+ -e "s~^\(.*setenv CLIBD_MON .*\)\$CCP4.*~\1\$CLIBD/monomers/~g" \
+ -e "s~^\(.*setenv MOLREPLIB .*\)\$CCP4.*~\1\$CLIBD/monomers/~g" \
+ -e "s~^\(.*setenv CCP4_BROWSER.*\).*~\1 firefox~g" \
+ ${S}/include/ccp4.setup*
+
+ # Get rid of S instances
+ # Also the main clipper library is built as libclipper-core, not libclipper
+ sed -i \
+ -e "s:${S}:${ROOT}usr:g" \
+ -e "s:lclipper :lclipper-core :g" \
+ ${S}/bin/clipper-config
+# sed -i \
+# -e "s:${S}:${ROOT}usr:g" \
+# ${S}/$(get_libdir)/cctbx/cctbx_build/setpaths*
+
+ # Bins
+ EXEDESTTREE="/usr/bin" doexe ${S}/bin/*
+
+ # Libs
+ for file in ${S}/lib/*; do
+ if [[ -d ${file} ]]; then
+ continue
+ elif [[ -x ${file} ]]; then
+ dolib.so ${file}
+ else
+ INSDESTTREE="/usr/$(get_libdir)" doins ${file}
+ fi
+ done
+
+ # Fix libdir in all *.la files
+ sed -i \
+ -e "s:^\(libdir=\).*:\1\'/usr/$(get_libdir)\':g" \
+ ${D}/usr/$(get_libdir)/*.la
+
+ # Library symlinks
+ local LIBNAMES="libclipper-ccp4.so.0.0.0
+ libclipper-cif.so.0.0.0
+ libclipper-contrib.so.0.0.0
+ libclipper-core.so.0.0.0
+ libclipper-minimol.so.0.0.0
+ libclipper-mmdbold.so.0.0.0
+ libclipper-mmdb.so.0.0.0
+ libclipper-mtz.so.1.0.0
+ libclipper-phs.so.0.0.0
+ libjwc_c.so.0.1.1
+ libjwc_f.so.0.1.1
+ libssm.so.0.0.0
+ libxdl_viewextra.so.0.0.0
+ libxdl_view.so.2.0.0"
+
+ for LIBNAME in ${LIBNAMES}; do
+ library_dosym ${LIBNAME}
+ done
+
+# dosym libclipper-ccp4.so.0.0.0 /usr/$(get_libdir)/libclipper-ccp4.so
+# dosym libclipper-ccp4.so.0.0.0 /usr/$(get_libdir)/libclipper-ccp4.so.0
+# dosym libclipper-ccp4.so.0.0.0 /usr/$(get_libdir)/libclipper-ccp4.so.0.0
+#
+# dosym libclipper-cif.so.0.0.0 /usr/$(get_libdir)/libclipper-cif.so
+# dosym libclipper-cif.so.0.0.0 /usr/$(get_libdir)/libclipper-cif.so.0
+# dosym libclipper-cif.so.0.0.0 /usr/$(get_libdir)/libclipper-cif.so.0.0
+#
+# dosym libclipper-contrib.so.0.0.0 /usr/$(get_libdir)/libclipper-contrib.so
+# dosym libclipper-contrib.so.0.0.0 /usr/$(get_libdir)/libclipper-contrib.so.0
+# dosym libclipper-contrib.so.0.0.0 /usr/$(get_libdir)/libclipper-contrib.so.0.0
+#
+# dosym libclipper-core.so.0.0.0 /usr/$(get_libdir)/libclipper-core.so
+# dosym libclipper-core.so.0.0.0 /usr/$(get_libdir)/libclipper-core.so.0
+# dosym libclipper-core.so.0.0.0 /usr/$(get_libdir)/libclipper-core.so.0.0
+#
+# dosym libclipper-minimol.so.0.0.0 /usr/$(get_libdir)/libclipper-minimol.so
+# dosym libclipper-minimol.so.0.0.0 /usr/$(get_libdir)/libclipper-minimol.so.0
+# dosym libclipper-minimol.so.0.0.0 /usr/$(get_libdir)/libclipper-minimol.so.0.0
+#
+# dosym libclipper-mmdbold.so.0.0.0 /usr/$(get_libdir)/libclipper-mmdbold.so
+# dosym libclipper-mmdbold.so.0.0.0 /usr/$(get_libdir)/libclipper-mmdbold.so.0
+# dosym libclipper-mmdbold.so.0.0.0 /usr/$(get_libdir)/libclipper-mmdbold.so.0.0
+#
+# dosym libclipper-mmdb.so.0.0.0 /usr/$(get_libdir)/libclipper-mmdb.so
+# dosym libclipper-mmdb.so.0.0.0 /usr/$(get_libdir)/libclipper-mmdb.so.0
+# dosym libclipper-mmdb.so.0.0.0 /usr/$(get_libdir)/libclipper-mmdb.so.0.0
+#
+# dosym libclipper-mtz.so.1.0.0 /usr/$(get_libdir)/libclipper-mtz.so
+# dosym libclipper-mtz.so.1.0.0 /usr/$(get_libdir)/libclipper-mtz.so.1
+# dosym libclipper-mtz.so.1.0.0 /usr/$(get_libdir)/libclipper-mtz.so.1.0
+#
+# dosym libclipper-phs.so.0.0.0 /usr/$(get_libdir)/libclipper-phs.so
+# dosym libclipper-phs.so.0.0.0 /usr/$(get_libdir)/libclipper-phs.so.0
+# dosym libclipper-phs.so.0.0.0 /usr/$(get_libdir)/libclipper-phs.so.0.0
+#
+# dosym libjwc_c.so.0.1.1 /usr/$(get_libdir)/libjwc_c.so
+# dosym libjwc_c.so.0.1.1 /usr/$(get_libdir)/libjwc_c.so.0
+# dosym libjwc_c.so.0.1.1 /usr/$(get_libdir)/libjwc_c.so.0.1
+#
+# dosym libjwc_f.so.0.1.1 /usr/$(get_libdir)/libjwc_f.so
+# dosym libjwc_f.so.0.1.1 /usr/$(get_libdir)/libjwc_f.so.0
+# dosym libjwc_f.so.0.1.1 /usr/$(get_libdir)/libjwc_f.so.0.1
+#
+# dosym libssm.so.0.0.0 /usr/$(get_libdir)/libssm.so
+# dosym libssm.so.0.0.0 /usr/$(get_libdir)/libssm.so.0
+# dosym libssm.so.0.0.0 /usr/$(get_libdir)/libssm.so.0.0
+#
+# dosym libxdl_viewextra.so.0.0.0 /usr/$(get_libdir)/libxdl_viewextra.so
+# dosym libxdl_viewextra.so.0.0.0 /usr/$(get_libdir)/libxdl_viewextra.so.0
+# dosym libxdl_viewextra.so.0.0.0 /usr/$(get_libdir)/libxdl_viewextra.so.0.0
+#
+# dosym libxdl_view.so.2.0.0 /usr/$(get_libdir)/libxdl_view.so
+# dosym libxdl_view.so.2.0.0 /usr/$(get_libdir)/libxdl_view.so.2
+# dosym libxdl_view.so.2.0.0 /usr/$(get_libdir)/libxdl_view.so.2.0
+
+ # Environment files, setup scripts, etc.
+ INSDESTTREE="/usr/share/ccp4/include" doins ${S}/include/*
+
+ # CCP4Interface - GUI
+ INSDESTTREE="/usr/$(get_libdir)/ccp4" doins -r ${S}/ccp4i
+ EXEDESTTREE="/usr/$(get_libdir)/ccp4/ccp4i/bin" doexe ${S}/ccp4i/bin/*
+
+ # Data
+ INSDESTTREE="/usr/share/ccp4" doins -r ${S}/lib/data
+
+ # Include files
+ for i in ccp4 clipper mmdb ssm; do
+ INSDESTTREE="/usr/include" doins -r ${S}/include/${i}
+ done
+
+ # Install docs and examples
+
+ doman ${S}/man/cat1/*
+
+ mv ${S}/manual/README ${S}/manual/README-manual
+ dodoc ${S}/manual/*
+
+ dodoc ${S}/README ${S}/CHANGES
+
+ dodoc ${S}/doc/*
+ rm ${D}/usr/share/doc/${PF}/GNUmakefile.gz
+ rm ${D}/usr/share/doc/${PF}/COPYING.gz
+
+ dohtml -r ${S}/html/*
+ dodoc ${S}/examples/README
+
+ # Fix wrongly installed HTML pages from clipper
+ dohtml "${D}"/usr/html/*
+ rm -rf "${D}"/usr/html
+
+ for i in data rnase toxd; do
+ DOCDESTTREE="examples/${i}" dodoc ${S}/examples/${i}/*
+ done
+
+ DOCDESTTREE="examples/tutorial" dohtml -r ${S}/examples/tutorial/html
+ DOCDESTTREE="examples/tutorial" dohtml examples/tutorial/tut.css
+ for i in data results; do
+ DOCDESTTREE="examples/tutorial/${i}" dodoc ${S}/examples/tutorial/${i}/*
+ done
+
+ for i in non-runnable runnable; do
+ DOCDESTTREE="examples/unix/${i}" dodoc ${S}/examples/unix/${i}
+ done
+
+ # Needed for ccp4i docs to work
+ dosym ../../share/doc/${PF}/examples /usr/$(get_libdir)/ccp4/examples
+ dosym ../../share/doc/${PF}/html /usr/$(get_libdir)/ccp4/html
+
+ # Fix overlaps with other packages
+ rm ${D}/usr/share/man/man1/rasmol.1.gz
+}
+
+pkg_postinst() {
+ einfo "The Web browser defaults to firefox. Change CCP4_BROWSER"
+ einfo "in /usr/share/ccp4/include/ccp4.setup* to modify this."
+
+ ewarn "Set your .bashrc or other shell login file to source"
+ ewarn "one of the ccp4.setup* files in ${ROOT}usr/share/ccp4/include."
+ ewarn "CCP4 will not work without this."
+}
+
+# Epatch wrapper for bulk patching
+ccp_patch() {
+ EPATCH_SINGLE_MSG=" ${1##*/} ..." epatch ${1}
+}
+
+# Links libname.so, libname.so.major and libname.so.major.minor
+# to libname.so.major.minor.micro
+library_dosym() {
+ local LIBNAME LIBDIR SUFFIX CORE_LIBNAME LIB_MAJOR LIB_MINOR LIB_VERSIONS
+
+ LIBNAME=${1}
+ LIBDIR=${2:-/usr/$(get_libdir)}
+
+ # Tag / on the end of libdir if needed
+ if [[ ${LIBDIR:$((${#LIBDIR}-1)):1} != "/" ]]; then
+ LIBDIR="${LIBDIR}/"
+ fi
+
+ if [[ "${LIBNAME}" != *.so.* ]]; then
+ msg="library_dosym() requires a shared, versioned library as an argument"
+ eerror "$msg"
+ die "$msg"
+ fi
+
+ SUFFIX=${LIBNAME##*so.}
+ CORE_LIBNAME=${LIBNAME%.so.*}
+ CORE_LIBNAME="${CORE_LIBNAME}.so"
+ LIB_MAJOR=${SUFFIX%%.*}
+ LIB_MINOR=${SUFFIX#*.}
+ LIB_MINOR=${SUFFIX%%.*}
+ LIB_VERSIONS="${LIB_MAJOR} ${LIB_MAJOR}.${LIB_MINOR}"
+ for LIB_SUFFIX in .${LIB_MAJOR} .${LIB_MAJOR}.${LIB_MINOR} ""; do
+ einfo "Calling dosym ${LIBNAME} ${LIBDIR} ${CORE_LIBNAME} ${LIB_SUFFIX}"
+ dosym ${LIBNAME} ${LIBDIR}${CORE_LIBNAME}${LIB_SUFFIX}
+ done
+}
diff --git a/sci-chemistry/ccp4/files/digest-ccp4-6.0.1-r1 b/sci-chemistry/ccp4/files/digest-ccp4-6.0.1-r1
new file mode 100644
index 000000000000..e83d992ca239
--- /dev/null
+++ b/sci-chemistry/ccp4/files/digest-ccp4-6.0.1-r1
@@ -0,0 +1,39 @@
+MD5 21f240d6cf7c743b8062f3765105031c act.f-6July2006.diff 16544
+RMD160 24f48e95ec3363a2409da122bd0eb7ef5a91da36 act.f-6July2006.diff 16544
+SHA256 ba807b19b834d68ff121e34bbfbb113ae528db1aeebfeb7e98cbb90c64c2c3c4 act.f-6July2006.diff 16544
+MD5 31d485acdd0c5e83a4d3d637aa83f808 anisoanl.f-r1.22-r1.24.diff 9452
+RMD160 02f9561362892cbbeed24592b5ed4e3eb51ace2c anisoanl.f-r1.22-r1.24.diff 9452
+SHA256 1308ef91c63efd1c11287f68f386a62678d1ab48ddfe6e94cefdef1c92173940 anisoanl.f-r1.22-r1.24.diff 9452
+MD5 d48a142e1417f848fa512a1aa45e3b10 cad.f-r1.70-r1.72.diff 12196
+RMD160 a18c339223c8a6a66fda4cb210f2e533fea0d240 cad.f-r1.70-r1.72.diff 12196
+SHA256 ba10591643f93fb310d451aacce286d8ec9386f2e781d631f794076d1021539f cad.f-r1.70-r1.72.diff 12196
+MD5 bd3ff43388b58841de79bcc23ebf81e3 ccp4-6.0.1-core-src.tar.gz 59311291
+RMD160 0f514fe30f22a4f6eb2e05c8bab567d2132e8fae ccp4-6.0.1-core-src.tar.gz 59311291
+SHA256 26a5704d707c3bc2fbe4c1d0804abccc1c50255005d26a8ec3a03fcba63335f2 ccp4-6.0.1-core-src.tar.gz 59311291
+MD5 99247535ed72ddd60f715388a8bb9cc6 chainsaw.cpp-11May2006.diff 4720
+RMD160 62c3b3a3da0d36aa8f0c67a55c068508858eeb17 chainsaw.cpp-11May2006.diff 4720
+SHA256 de2d2ccd365f2992e1ba9a385f1a2fcd9e52da5ff96bcbc4fa7b4404cf0bac6e chainsaw.cpp-11May2006.diff 4720
+MD5 dcb1dea5587990b19d5ad5b095919905 contact.f-12June2006.diff 43051
+RMD160 577b454ed229be8c9b79e8c4622c870d589e2cca contact.f-12June2006.diff 43051
+SHA256 1336ea01da83aad21669b82cd3895f724db6db8d17d78acfec53154ea7ce690e contact.f-12June2006.diff 43051
+MD5 193b367d9b0e5567ce59f5c4b0118ec4 molrep.f-r1.28-r1.28.2.1.diff 755
+RMD160 96a37ea54606583647ff9cdc9da728ce05d30849 molrep.f-r1.28-r1.28.2.1.diff 755
+SHA256 0bb22cb2f8e1486ec5cc6037427e9ec66189684d74b5939757b4ebe771a61084 molrep.f-r1.28-r1.28.2.1.diff 755
+MD5 7007d645629a666e16161bfe9ce45cfc mtztona4.f-r1.23-r1.24.diff 882
+RMD160 1b34c6caaf5356574f65f2d092196cdd788cb720 mtztona4.f-r1.23-r1.24.diff 882
+SHA256 d7cf1b6ab2015b18c6b4b310e25b706a1f420d623383c17d0b51acfb00ae679a mtztona4.f-r1.23-r1.24.diff 882
+MD5 35e064c2e674abf496cda9546858218b omit.f-r1.12-r1.13.diff 2303
+RMD160 5dda121b69fdc3b4e138e0b88012df1d46398d3a omit.f-r1.12-r1.13.diff 2303
+SHA256 14a8128809f78d2d08b81cde5f91b51a694d99b56215477a62571344024a6748 omit.f-r1.12-r1.13.diff 2303
+MD5 7a3cb3be5eb751c26d524d6e6b7d3afa refmac5.tcl-r1.39.2.3-r1.42.diff 2464
+RMD160 fca236184597ab86fc9ac7333834e68eab641dac refmac5.tcl-r1.39.2.3-r1.42.diff 2464
+SHA256 8418181bae8799d2fa5a004e84cb1c66391d0cb768df5d40b34e053aced6fd4c refmac5.tcl-r1.39.2.3-r1.42.diff 2464
+MD5 de8c82181951b3579a160932ae8ddedd rotmat.f-17July2006.diff 1002
+RMD160 59cc822edbdc73b24e51cff013c71e4d68927979 rotmat.f-17July2006.diff 1002
+SHA256 1ee4f3288dba6404d59f51b9f9e1b4475413f7e40991204ab39474ee559605b1 rotmat.f-17July2006.diff 1002
+MD5 b966473250ed75716cc88cf0aee67348 sc.f-r1.9-r1.9.2.1.diff 8783
+RMD160 815d25cff0fa76f73dc43da9757ad753ec392f9c sc.f-r1.9-r1.9.2.1.diff 8783
+SHA256 418feea2ccf0014c3c2c83ab9460873114057480fd2a1dcabe305a1b956ad86b sc.f-r1.9-r1.9.2.1.diff 8783
+MD5 fb9252300a46f3d81776661b39c00d4e setup.fh-r1.5-r1.5.2.1.diff 1317
+RMD160 45a16b00792706553e7bf23a2f54415cd5ee1b43 setup.fh-r1.5-r1.5.2.1.diff 1317
+SHA256 637564c5723fb7de04d3a06817eec704ac708b74264716905690250e42aed146 setup.fh-r1.5-r1.5.2.1.diff 1317