summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-09 10:34:14 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-09 10:34:14 +0000
commit5904c20f094b9d00dd4e126472384b74891cd75b (patch)
treef5a0e03fb9ef1106a6245771d0a6b4c5965c1fbb /sci-chemistry
parentAdded kdelibs-4.4.5-r3 to address security bug 358025. Without keywords so fa... (diff)
downloadgentoo-2-5904c20f094b9d00dd4e126472384b74891cd75b.tar.gz
gentoo-2-5904c20f094b9d00dd4e126472384b74891cd75b.tar.bz2
gentoo-2-5904c20f094b9d00dd4e126472384b74891cd75b.zip
New addition, written by me
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/p3d/ChangeLog11
-rw-r--r--sci-chemistry/p3d/metadata.xml21
-rw-r--r--sci-chemistry/p3d/p3d-0.4.3.0.ebuild35
-rw-r--r--sci-chemistry/p3d/p3d-9999.ebuild33
4 files changed, 100 insertions, 0 deletions
diff --git a/sci-chemistry/p3d/ChangeLog b/sci-chemistry/p3d/ChangeLog
new file mode 100644
index 000000000000..81026442e648
--- /dev/null
+++ b/sci-chemistry/p3d/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-chemistry/p3d
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/p3d/ChangeLog,v 1.1 2011/03/09 10:34:14 jlec Exp $
+
+*p3d-9999 (09 Mar 2011)
+*p3d-0.4.3.0 (09 Mar 2011)
+
+ 09 Mar 2011; Justin Lecher <jlec@gentoo.org> +p3d-0.4.3.0.ebuild,
+ +p3d-9999.ebuild, +metadata.xml:
+ New addition, written by me
+
diff --git a/sci-chemistry/p3d/metadata.xml b/sci-chemistry/p3d/metadata.xml
new file mode 100644
index 000000000000..9a0f5eff3224
--- /dev/null
+++ b/sci-chemistry/p3d/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+<longdescription>
+p3d was developed in order to offer a Python module that is powerful and fast,
+yet intuitive to use. The simplicity of p3d is due to the usage of object
+oriented programming (i.e. atoms are treated as vectors), the implementation
+of a query parser that translates queries readable by humans into a combination
+of algebra set operations the fact that no additional Python packages are
+necessary. The speed is due to the usage of a binary space partitioning (BSP)
+tree which allows very fast queries in 3D (Henry et al. 1980). The additional
+synergy is obtained by the flexible combination of both speed and complexity in
+the queries to the structural data. The combination of these factors makes p3d
+the optimal module to rapidly develop new and powerful bioinformatic tools that
+follow the Python philosophy of making the source code readable.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/p3d/p3d-0.4.3.0.ebuild b/sci-chemistry/p3d/p3d-0.4.3.0.ebuild
new file mode 100644
index 000000000000..97fd92c82958
--- /dev/null
+++ b/sci-chemistry/p3d/p3d-0.4.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/p3d/p3d-0.4.3.0.ebuild,v 1.1 2011/03/09 10:34:14 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils versionator
+
+MY_P="${PN}-$(replace_version_separator 3 -)"
+GITHUB_ID="gb8b9a75"
+
+DESCRIPTION="Python module for structural bioinformatics"
+HOMEPAGE="http://p3d.fufezan.net"
+SRC_URI="https://download.github.com/fu-${MY_P}-${GITHUB_ID}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+IUSE="examples"
+
+src_prepare() {
+ mv fu* ${P}
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r pdbs exampleScripts
+ fi
+}
diff --git a/sci-chemistry/p3d/p3d-9999.ebuild b/sci-chemistry/p3d/p3d-9999.ebuild
new file mode 100644
index 000000000000..6675a9d46995
--- /dev/null
+++ b/sci-chemistry/p3d/p3d-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/p3d/p3d-9999.ebuild,v 1.1 2011/03/09 10:34:14 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit git distutils versionator
+
+MY_P="${PN}-$(replace_version_separator 3 -)"
+GITHUB_ID="gb8b9a75"
+
+DESCRIPTION="Python module for structural bioinformatics"
+HOMEPAGE="http://p3d.fufezan.net"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/fu/p3d.git"
+
+SLOT="0"
+KEYWORDS=""
+LICENSE="GPL-3"
+IUSE="examples"
+
+S="${WORKDIR}"/${PN}
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r pdbs exampleScripts
+ fi
+}