summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-07-04 15:51:59 +0000
committerJustin Lecher <jlec@gentoo.org>2013-07-04 15:51:59 +0000
commit4f8040b0a51b0331effb9988e63abf1cb85a3ea1 (patch)
tree61225133080f18759c8966ee398523f84b6dafd3 /sci-chemistry
parentOld. (diff)
downloadgentoo-2-4f8040b0a51b0331effb9988e63abf1cb85a3ea1.tar.gz
gentoo-2-4f8040b0a51b0331effb9988e63abf1cb85a3ea1.tar.bz2
gentoo-2-4f8040b0a51b0331effb9988e63abf1cb85a3ea1.zip
sci-chemistry/gopenmol: Bump to EAPI=5 and new python eclass, fix for tcl8.6; fix implicit declarations; restrict license, #470782
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/gopenmol/ChangeLog12
-rw-r--r--sci-chemistry/gopenmol/files/3.00-impl-dec.patch80
-rw-r--r--sci-chemistry/gopenmol/files/3.00-tcl8.6.patch32
-rw-r--r--sci-chemistry/gopenmol/gopenmol-3.00-r2.ebuild10
-rw-r--r--sci-chemistry/gopenmol/gopenmol-3.00-r3.ebuild91
-rw-r--r--sci-chemistry/gopenmol/metadata.xml2
6 files changed, 220 insertions, 7 deletions
diff --git a/sci-chemistry/gopenmol/ChangeLog b/sci-chemistry/gopenmol/ChangeLog
index bbba41fd68f1..f1c8e356c0aa 100644
--- a/sci-chemistry/gopenmol/ChangeLog
+++ b/sci-chemistry/gopenmol/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-chemistry/gopenmol
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gopenmol/ChangeLog,v 1.12 2012/04/02 06:06:41 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gopenmol/ChangeLog,v 1.13 2013/07/04 15:51:59 jlec Exp $
+
+*gopenmol-3.00-r3 (04 Jul 2013)
+
+ 04 Jul 2013; Justin Lecher <jlec@gentoo.org> gopenmol-3.00-r2.ebuild,
+ +gopenmol-3.00-r3.ebuild, +files/3.00-impl-dec.patch,
+ +files/3.00-tcl8.6.patch, metadata.xml:
+ Bump to EAPI=5 and new python eclass, fix for tcl8.6; fix implicit
+ declarations; restrict license, #470782
02 Apr 2012; Justin Lecher <jlec@gentoo.org> gopenmol-3.00-r2.ebuild,
metadata.xml:
diff --git a/sci-chemistry/gopenmol/files/3.00-impl-dec.patch b/sci-chemistry/gopenmol/files/3.00-impl-dec.patch
new file mode 100644
index 000000000000..e1d66c7aaa5d
--- /dev/null
+++ b/sci-chemistry/gopenmol/files/3.00-impl-dec.patch
@@ -0,0 +1,80 @@
+ density/density.c | 1 +
+ utility/g94cub2pl.c | 1 +
+ utility/gamess2plt.c | 1 +
+ utility/gcube2plt.c | 1 +
+ utility/jaguar2plt.c | 1 +
+ vss/vssmod.c | 1 +
+ 6 files changed, 6 insertions(+)
+
+diff --git a/density/density.c b/density/density.c
+index 130a48e..ee218c5 100755
+--- a/density/density.c
++++ b/density/density.c
+@@ -13,6 +13,7 @@
+ #include <string.h>
+ #include <sys/types.h>
+ #include <malloc.h>
++#include <stdlib.h>
+
+ #define VERBOSE 0
+ #define BUFF_LEN 500
+diff --git a/utility/g94cub2pl.c b/utility/g94cub2pl.c
+index e773ab2..94fbcfd 100755
+--- a/utility/g94cub2pl.c
++++ b/utility/g94cub2pl.c
+@@ -315,6 +315,7 @@ which can be read by gOpenMol or SCARECROW.
+ #include <sys/types.h>
+ #include <malloc.h>
+ #include <string.h>
++#include <stdlib.h>
+
+ #define BUFF_LEN 256
+ #define BOHR_RADIUS 0.52917715 /* conversion constant */
+diff --git a/utility/gamess2plt.c b/utility/gamess2plt.c
+index 3f6108e..5da481d 100755
+--- a/utility/gamess2plt.c
++++ b/utility/gamess2plt.c
+@@ -86,6 +86,7 @@ which can be read by gOpenMol or SCARECROW.
+ #include <sys/types.h>
+ #include <malloc.h>
+ #include <string.h>
++#include <stdlib.h>
+
+ #define BUFF_LEN 256
+ #define BOHR_RADIUS 0.52917715 /* conversion constant */
+diff --git a/utility/gcube2plt.c b/utility/gcube2plt.c
+index c5f7b5e..711bad3 100755
+--- a/utility/gcube2plt.c
++++ b/utility/gcube2plt.c
+@@ -306,6 +306,7 @@ which can be read by gOpenMol or SCARECROW.
+ #include <sys/types.h>
+ #include <malloc.h>
+ #include <string.h>
++#include <stdlib.h>
+
+ #define BUFF_LEN 256
+ #define BOHR_RADIUS 0.52917715 /* conversion constant */
+diff --git a/utility/jaguar2plt.c b/utility/jaguar2plt.c
+index 657128c..96d6ac1 100755
+--- a/utility/jaguar2plt.c
++++ b/utility/jaguar2plt.c
+@@ -26,6 +26,7 @@ fastes running coordinate.
+ #include <sys/types.h>
+ #include <malloc.h>
+ #include <string.h>
++#include <stdlib.h>
+
+ #define BUFF_LEN 256
+ #define BOHR_RADIUS 0.52917715 /* conversion constant */
+diff --git a/vss/vssmod.c b/vss/vssmod.c
+index 957d2e5..9d73978 100755
+--- a/vss/vssmod.c
++++ b/vss/vssmod.c
+@@ -20,6 +20,7 @@ C- for the potentials
+ #include <math.h>
+ #include <string.h>
+ #include <malloc.h>
++#include <stdlib.h>
+
+ #define LINE_LEN 80
+ #define BUFF_LEN 500
diff --git a/sci-chemistry/gopenmol/files/3.00-tcl8.6.patch b/sci-chemistry/gopenmol/files/3.00-tcl8.6.patch
new file mode 100644
index 000000000000..a4c3bce12468
--- /dev/null
+++ b/sci-chemistry/gopenmol/files/3.00-tcl8.6.patch
@@ -0,0 +1,32 @@
+ src/graphics/g_Mmain.c | 2 +-
+ src/parser/p_parser.c | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/graphics/g_Mmain.c b/src/graphics/g_Mmain.c
+index b9bb340..f044568 100755
+--- a/src/graphics/g_Mmain.c
++++ b/src/graphics/g_Mmain.c
+@@ -487,7 +487,7 @@ int gomp_Mmain(int argc, const char *argv[])
+ {
+ Tcl_Interp *interp;
+ interp = gomp_GetTclInterp();
+- sprintf(Temp,"'%s' problems creating the Tk window",interp->result);
++ sprintf(Temp,"'%s' problems creating the Tk window",Tcl_GetStringResult(interp));
+ gomp_PrintERROR(Temp);
+ return(1);
+ }
+diff --git a/src/parser/p_parser.c b/src/parser/p_parser.c
+index c9fd8ce..62eb05c 100755
+--- a/src/parser/p_parser.c
++++ b/src/parser/p_parser.c
+@@ -809,8 +809,8 @@ int gomp_TclRunScript()
+ if(value != (const char *)NULL) {
+ code = Tcl_EvalFile(interp , value);
+ if(code != TCL_OK) {
+- if(*interp->result != (char)NULL) {
+- gomp_PrintERROR(interp->result);
++ if(*Tcl_GetStringResult(interp) != (char)NULL) {
++ gomp_PrintERROR(Tcl_GetStringResult(interp));
+ return(1);
+ }
+ }
diff --git a/sci-chemistry/gopenmol/gopenmol-3.00-r2.ebuild b/sci-chemistry/gopenmol/gopenmol-3.00-r2.ebuild
index 7f5e4913bd89..d06498e19957 100644
--- a/sci-chemistry/gopenmol/gopenmol-3.00-r2.ebuild
+++ b/sci-chemistry/gopenmol/gopenmol-3.00-r2.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gopenmol/gopenmol-3.00-r2.ebuild,v 1.5 2012/04/02 06:06:41 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gopenmol/gopenmol-3.00-r2.ebuild,v 1.6 2013/07/04 15:51:59 jlec Exp $
EAPI=4
PYTHON_DEPEND="2"
-inherit eutils multilib prefix python
+inherit eutils multilib python
DESCRIPTION="Tool for the visualization and analysis of molecular structures"
HOMEPAGE="http://www.csc.fi/gopenmol/"
SRC_URI="${HOMEPAGE}/distribute/${P}-linux.tar.gz"
-LICENSE="as-is"
+LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE=""
@@ -31,6 +31,8 @@ RDEPEND="
x11-libs/libXxf86vm"
DEPEND="${RDEPEND}"
+RESTRICT="mirror"
+
S="${WORKDIR}/gOpenMol-${PV}/src"
pkg_setup() {
diff --git a/sci-chemistry/gopenmol/gopenmol-3.00-r3.ebuild b/sci-chemistry/gopenmol/gopenmol-3.00-r3.ebuild
new file mode 100644
index 000000000000..fb0fdff6da5b
--- /dev/null
+++ b/sci-chemistry/gopenmol/gopenmol-3.00-r3.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gopenmol/gopenmol-3.00-r3.ebuild,v 1.1 2013/07/04 15:51:59 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils multilib python-single-r1
+
+DESCRIPTION="Tool for the visualization and analysis of molecular structures"
+HOMEPAGE="http://www.csc.fi/gopenmol/"
+SRC_URI="${HOMEPAGE}/distribute/${P}-linux.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-lang/tk
+ dev-tcltk/bwidget
+ media-libs/freeglut
+ virtual/jpeg
+ virtual/opengl
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86vm"
+DEPEND="${RDEPEND}"
+
+RESTRICT="mirror"
+S="${WORKDIR}/gOpenMol-${PV}/src"
+
+src_prepare() {
+ cd ..
+ epatch \
+ "${FILESDIR}"/${PV}-include-config-for-plugins.patch \
+ "${FILESDIR}"/${PV}-multilib.patch \
+ "${FILESDIR}"/${PV}-tcl8.6.patch \
+ "${FILESDIR}"/${PV}-impl-dec.patch
+
+ sed \
+ -e "s:GENTOOLIBDIR:$(get_libdir):g" \
+ -i src/{config.mk.ac,plugins/config.mk.ac} || die
+ sed "/GOM_TEMP/s:^.*$:GOM_TEMP=\"${EPREFIX}/tmp/:g" -i environment.txt || die
+}
+
+src_compile() {
+ default
+
+ # Plugins and Utilities are not built by default
+ cd "${S}"/plugins && emake
+ cd "${S}"/utility && emake
+}
+
+src_install() {
+ einstall
+
+ cd "${S}"/plugins && einstall
+ cd "${S}"/utility && einstall
+
+ dosym ../$(get_libdir)/gOpenMol-${PV}/bin/${PN} /usr/bin/${PN}
+
+ dodoc "${ED}"/usr/share/gOpenMol-${PV}/{docs/*,README*} || die
+
+ dodir /usr/share/doc/${PF}/html
+ mv -T "${ED}"/usr/share/gOpenMol-${PV}/help "${ED}"/usr/share/doc/${PF}/html || die
+ mv "${ED}"/usr/share/gOpenMol-${PV}/utility "${ED}"/usr/share/doc/${PF}/html || die
+
+ rm -rf \
+ "${ED}"/usr/$(get_libdir)/gOpenMol-${PV}/{src,install} \
+ "${ED}"/usr/share/gOpenMol-${PV}/{docs,README*,COPYRIGHT} || die
+
+ cat >> "${T}"/20${PN} <<- EOF
+ GOM_ROOT="${EPREFIX}"/usr/$(get_libdir)/gOpenMol-${PV}/
+ GOM_DATA="${EPREFIX}"/usr/share/gOpenMol-${PV}/data
+ GOM_HELP="${EPREFIX}"/usr/share/doc/${PVR}/html
+ GOM_DEMO="${EPREFIX}"/usr/share/gOpenMol-${PV}/demo
+ EOF
+
+ doenvd "${T}"/20${PN}
+}
+
+pkg_postinst() {
+ einfo "Run gOpenMol using the rungOpenMol script."
+}
diff --git a/sci-chemistry/gopenmol/metadata.xml b/sci-chemistry/gopenmol/metadata.xml
index e42d0af60f42..51fdedab1b38 100644
--- a/sci-chemistry/gopenmol/metadata.xml
+++ b/sci-chemistry/gopenmol/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-chemistry</herd>
+ <herd>sci-chemistry</herd>
</pkgmetadata>