summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-09-20 06:57:54 +0000
committerJustin Lecher <jlec@gentoo.org>2010-09-20 06:57:54 +0000
commit4c30384cabc5b4a16ce6bce20b348a596fb47843 (patch)
tree75c911d3683fbc594aa8b7836abb5eebf96c2f57 /sci-chemistry
parentVersion bump (diff)
downloadgentoo-2-4c30384cabc5b4a16ce6bce20b348a596fb47843.tar.gz
gentoo-2-4c30384cabc5b4a16ce6bce20b348a596fb47843.tar.bz2
gentoo-2-4c30384cabc5b4a16ce6bce20b348a596fb47843.zip
Respect CFLAGS, removed old patches
(Portage version: 2.2_rc84/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/reduce/ChangeLog8
-rw-r--r--sci-chemistry/reduce/files/2.21.030604-gcc4.patch100
-rw-r--r--sci-chemistry/reduce/files/3.02.060709-remove-extra-qualification.patch12
-rw-r--r--sci-chemistry/reduce/files/3.13.080428-CFLAGS.patch22
-rw-r--r--sci-chemistry/reduce/reduce-3.13.080428-r1.ebuild3
5 files changed, 31 insertions, 114 deletions
diff --git a/sci-chemistry/reduce/ChangeLog b/sci-chemistry/reduce/ChangeLog
index 5c15c9d2bd9c..c05552f39e1a 100644
--- a/sci-chemistry/reduce/ChangeLog
+++ b/sci-chemistry/reduce/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/reduce
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/reduce/ChangeLog,v 1.17 2010/07/15 20:08:33 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/reduce/ChangeLog,v 1.18 2010/09/20 06:57:54 jlec Exp $
+
+ 20 Sep 2010; Justin Lecher <jlec@gentoo.org>
+ -files/2.21.030604-gcc4.patch,
+ -files/3.02.060709-remove-extra-qualification.patch,
+ +files/3.13.080428-CFLAGS.patch, reduce-3.13.080428-r1.ebuild:
+ Respect CFLAGS, removed old patches
15 Jul 2010; Markus Meier <maekke@gentoo.org>
reduce-3.13.080428-r1.ebuild:
diff --git a/sci-chemistry/reduce/files/2.21.030604-gcc4.patch b/sci-chemistry/reduce/files/2.21.030604-gcc4.patch
deleted file mode 100644
index 67b36ab476a7..000000000000
--- a/sci-chemistry/reduce/files/2.21.030604-gcc4.patch
+++ /dev/null
@@ -1,100 +0,0 @@
-Files reduce.2.21.030604.source.orig/libpdb/libpdb++.a and reduce.2.21.030604.source/libpdb/libpdb++.a differ
-diff -urN -x '*Makefile*' reduce.2.21.030604.source.orig/reduce_src/PDBrec.h reduce.2.21.030604.source/reduce_src/PDBrec.h
---- reduce.2.21.030604.source.orig/reduce_src/PDBrec.h 2003-06-04 16:32:12.000000000 -0700
-+++ reduce.2.21.030604.source/reduce_src/PDBrec.h 2006-06-01 15:50:07.000000000 -0700
-@@ -233,7 +233,7 @@
-
- friend ostream& operator << (ostream& s, const PDBrecNAMEout& p);
- private:
-- PDBrecNAMEout(const PDBrecNAMEout& p); // can't copy or assign
-+// PDBrecNAMEout(const PDBrecNAMEout& p); // can't copy or assign
- PDBrecNAMEout& operator=(const PDBrecNAMEout& p);
-
- const PDBrec& _r;
-Files reduce.2.21.030604.source.orig/reduce_src/reduce and reduce.2.21.030604.source/reduce_src/reduce differ
-diff -urN -x '*Makefile*' reduce.2.21.030604.source.orig/toolclasses/Dict.C reduce.2.21.030604.source/toolclasses/Dict.C
---- reduce.2.21.030604.source.orig/toolclasses/Dict.C 1999-03-15 08:42:34.000000000 -0800
-+++ reduce.2.21.030604.source/toolclasses/Dict.C 2006-06-01 15:51:58.000000000 -0700
-@@ -13,6 +13,7 @@
- // Copyright (C) 1999 J. Michael Word
- // **************************************************************
-
-+using std::endl;
- #include "Dict.h"
-
- // ---------------------------------------------------
-Files reduce.2.21.030604.source.orig/toolclasses/libtoolclasses.a and reduce.2.21.030604.source/toolclasses/libtoolclasses.a differ
-diff -urN -x '*Makefile*' reduce.2.21.030604.source.orig/toolclasses/List.h reduce.2.21.030604.source/toolclasses/List.h
---- reduce.2.21.030604.source.orig/toolclasses/List.h 2003-06-04 16:48:51.000000000 -0700
-+++ reduce.2.21.030604.source/toolclasses/List.h 2006-06-01 16:31:43.000000000 -0700
-@@ -9,6 +9,8 @@
- #ifndef LIST_H
- #define LIST_H 1
-
-+#include "utility.h"
-+
- #ifdef OLD_STD_HDRS
- #include <iostream.h>
- #include <limits.h>
-diff -urN -x '*Makefile*' reduce.2.21.030604.source.orig/toolclasses/ListIter.C reduce.2.21.030604.source/toolclasses/ListIter.C
---- reduce.2.21.030604.source.orig/toolclasses/ListIter.C 1999-01-13 09:58:42.000000000 -0800
-+++ reduce.2.21.030604.source/toolclasses/ListIter.C 2006-06-01 15:32:13.000000000 -0700
-@@ -58,29 +58,29 @@
-
- template <class T>
- bool NonConstListIter<T>::drop() {
-- bool rc = (_node != NULL);
-+ bool rc = (this->_node != NULL);
- if (rc) {
-- DblLnkLstNode<T>* prev = _NClist.linkPrev(_node);
-- _NClist.drop(_node);
-- _node = prev;
-+ DblLnkLstNode<T>* prev = _NClist.linkPrev(this->_node);
-+ _NClist.drop(this->_node);
-+ this->_node = prev;
- }
- return rc;
- }
-
- template <class T>
- bool NonConstListIter<T>::insertBefore(const T& e) {
-- bool rc = (_node != NULL);
-+ bool rc = (this->_node != NULL);
- if (rc) {
-- _NClist.insertBefore(e, _node);
-+ _NClist.insertBefore(e, this->_node);
- }
- return rc;
- }
-
- template <class T>
- bool NonConstListIter<T>::insertAfter(const T& e) {
-- bool rc = (_node != NULL);
-+ bool rc = (this->_node != NULL);
- if (rc) {
-- _NClist.insertAfter(e, _node);
-+ _NClist.insertAfter(e, this->_node);
- }
- return rc;
- }
-diff -urN -x '*Makefile*' reduce.2.21.030604.source.orig/toolclasses/ListIter.h reduce.2.21.030604.source/toolclasses/ListIter.h
---- reduce.2.21.030604.source.orig/toolclasses/ListIter.h 1999-01-13 09:58:42.000000000 -0800
-+++ reduce.2.21.030604.source/toolclasses/ListIter.h 2006-06-01 15:07:29.000000000 -0700
-@@ -63,13 +63,13 @@
- : ListIter<T>(li), _NClist(li._NClist) {}
-
- T& data() const {
-- assert(_node);
-- return _NClist.linkData(_node);
-+ assert(this->_node);
-+ return _NClist.linkData(this->_node);
- }
-
- void update(const T& e) const {
-- assert(_node);
-- _NClist.linkData(_node) = e;
-+ assert(this->_node);
-+ _NClist.linkData(this->_node) = e;
- }
-
- bool drop(); // remove the current element
diff --git a/sci-chemistry/reduce/files/3.02.060709-remove-extra-qualification.patch b/sci-chemistry/reduce/files/3.02.060709-remove-extra-qualification.patch
deleted file mode 100644
index 46745213b15c..000000000000
--- a/sci-chemistry/reduce/files/3.02.060709-remove-extra-qualification.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur reduce.3.02.060709.orig/reduce_src/GraphToHoldScores.h reduce.3.02.060709/reduce_src/GraphToHoldScores.h
---- reduce.3.02.060709.orig/reduce_src/GraphToHoldScores.h 2006-07-10 08:12:40.000000000 -0700
-+++ reduce.3.02.060709/reduce_src/GraphToHoldScores.h 2006-07-10 10:31:40.000000000 -0700
-@@ -290,7 +290,7 @@
- int whichVertex( int vertex ) const;
-
- void
-- DegreeThreeEdge_ths::lookForSharedDots(
-+ lookForSharedDots(
- DegreeThreeEdge_ths const * other,
- int vertex_this,
- int vertex_other
diff --git a/sci-chemistry/reduce/files/3.13.080428-CFLAGS.patch b/sci-chemistry/reduce/files/3.13.080428-CFLAGS.patch
new file mode 100644
index 000000000000..7daa5336f689
--- /dev/null
+++ b/sci-chemistry/reduce/files/3.13.080428-CFLAGS.patch
@@ -0,0 +1,22 @@
+diff --git a/reduce_src/Makefile b/reduce_src/Makefile
+index 598e367..067ace4 100644
+--- a/reduce_src/Makefile
++++ b/reduce_src/Makefile
+@@ -12,7 +12,7 @@ PROG_FLGS = -DAROMATICS_ACCEPT_HBONDS \
+ # -DDEBUGMOVABLENODE -DDEBUGDOTCOUNTS
+ # -DMINPREDEFINED -DMAXPREDEFINED\
+
+-CFLAGS = $(OPT) $(DEBUG) $(PROG_FLGS) $(DICT_LOC)\
++CXXFLAGS = $(OPT) $(DEBUG) $(PROG_FLGS) $(DICT_LOC)\
+ -I$(PDBHOME) -I$(TOOLHOME)
+ # -Wall
+
+@@ -26,7 +26,7 @@ OBJLIST = GraphToHoldScores.o reduce.o CTab.o ElementInfo.o StdResH.o ResBlk.o A
+ CXX = g++
+
+ .cpp.o:
+- $(CXX) -c $*.cpp $(CFLAGS)
++ $(CXX) -c $*.cpp $(CXXFLAGS)
+
+ OPT = -O3
+ DEBUG = $(CXXDEBUGFLAGS)
diff --git a/sci-chemistry/reduce/reduce-3.13.080428-r1.ebuild b/sci-chemistry/reduce/reduce-3.13.080428-r1.ebuild
index 43bba59a63e3..0f8296764a91 100644
--- a/sci-chemistry/reduce/reduce-3.13.080428-r1.ebuild
+++ b/sci-chemistry/reduce/reduce-3.13.080428-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/reduce/reduce-3.13.080428-r1.ebuild,v 1.5 2010/07/15 20:08:33 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/reduce/reduce-3.13.080428-r1.ebuild,v 1.6 2010/09/20 06:57:54 jlec Exp $
EAPI="3"
@@ -25,6 +25,7 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
epatch "${FILESDIR}"/${PV}-LDFLAGS.patch
+ epatch "${FILESDIR}"/${PV}-CFLAGS.patch
}
src_compile() {