summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-08-11 16:46:14 +0000
committerJustin Lecher <jlec@gentoo.org>2010-08-11 16:46:14 +0000
commit2fa096edc792e6ceb0d48ccc70ae58a201ff2ed1 (patch)
treed97988081bad45824c05573a7f6920bdb19a7647 /sci-chemistry
parentMarked ~ppc for bug #313563. (diff)
downloadgentoo-2-2fa096edc792e6ceb0d48ccc70ae58a201ff2ed1.tar.gz
gentoo-2-2fa096edc792e6ceb0d48ccc70ae58a201ff2ed1.tar.bz2
gentoo-2-2fa096edc792e6ceb0d48ccc70ae58a201ff2ed1.zip
Stop mixing CFLAGS and CXXFLAGS, stop using upstream flags, thanks dberkholz pointing this out
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/autodock_vina/ChangeLog9
-rw-r--r--sci-chemistry/autodock_vina/autodock_vina-1.1.1-r1.ebuild (renamed from sci-chemistry/autodock_vina/autodock_vina-1.1.1.ebuild)2
-rw-r--r--sci-chemistry/autodock_vina/files/1.1.1-gentoo.patch25
3 files changed, 31 insertions, 5 deletions
diff --git a/sci-chemistry/autodock_vina/ChangeLog b/sci-chemistry/autodock_vina/ChangeLog
index d406ca5ace75..f6d94a7937b6 100644
--- a/sci-chemistry/autodock_vina/ChangeLog
+++ b/sci-chemistry/autodock_vina/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/autodock_vina
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/autodock_vina/ChangeLog,v 1.1 2010/05/18 11:43:46 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/autodock_vina/ChangeLog,v 1.2 2010/08/11 16:46:14 jlec Exp $
+
+*autodock_vina-1.1.1-r1 (11 Aug 2010)
+
+ 11 Aug 2010; Justin Lecher <jlec@gentoo.org> files/1.1.1-gentoo.patch,
+ -autodock_vina-1.1.1.ebuild, +autodock_vina-1.1.1-r1.ebuild:
+ Stop mixing CFLAGS and CXXFLAGS, stop using upstream flags, thanks
+ dberkholz pointing this out
*autodock_vina-1.1.1 (18 May 2010)
diff --git a/sci-chemistry/autodock_vina/autodock_vina-1.1.1.ebuild b/sci-chemistry/autodock_vina/autodock_vina-1.1.1-r1.ebuild
index dfc1fa98263c..eb1a848790f4 100644
--- a/sci-chemistry/autodock_vina/autodock_vina-1.1.1.ebuild
+++ b/sci-chemistry/autodock_vina/autodock_vina-1.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/autodock_vina/autodock_vina-1.1.1.ebuild,v 1.1 2010/05/18 11:43:46 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/autodock_vina/autodock_vina-1.1.1-r1.ebuild,v 1.1 2010/08/11 16:46:14 jlec Exp $
EAPI="3"
diff --git a/sci-chemistry/autodock_vina/files/1.1.1-gentoo.patch b/sci-chemistry/autodock_vina/files/1.1.1-gentoo.patch
index 5b24b4cbc488..356ae2ee547d 100644
--- a/sci-chemistry/autodock_vina/files/1.1.1-gentoo.patch
+++ b/sci-chemistry/autodock_vina/files/1.1.1-gentoo.patch
@@ -23,10 +23,10 @@ index bfbcc1e..c9fd630 100644
C_OPTIONS= -O3 -DNDEBUG
BOOST_LIB_VERSION=
diff --git a/build/makefile_common b/build/makefile_common
-index 885935c..4d5eb0f 100644
+index 885935c..e72142d 100644
--- a/build/makefile_common
+++ b/build/makefile_common
-@@ -1,16 +1,16 @@
+@@ -1,30 +1,30 @@
-BOOST_INCLUDE = $(BASE)/include/boost-${BOOST_VERSION}
+BOOST_INCLUDE = $(BASE)/include/boost
@@ -37,7 +37,8 @@ index 885935c..4d5eb0f 100644
-INCFLAGS = -I $(BOOST_INCLUDE)
+INCFLAGS = -I$(BOOST_INCLUDE)
- CC = ${GPP} ${C_PLATFORM} -ansi -pedantic -Wno-long-long ${C_OPTIONS} $(INCFLAGS)
+-CC = ${GPP} ${C_PLATFORM} -ansi -pedantic -Wno-long-long ${C_OPTIONS} $(INCFLAGS)
++CC = ${GPP} ${C_PLATFORM} ${C_OPTIONS} $(INCFLAGS)
-LDFLAGS = -L$(BASE)/lib -L.
+LDFLAGS += -L.
@@ -47,3 +48,21 @@ index 885935c..4d5eb0f 100644
.SUFFIXES: .cpp .o
+ %.o : ../../../src/lib/%.cpp
+- $(CC) $(CFLAGS) -o $@ -c $<
++ $(CC) $(CXXFLAGS) -o $@ -c $<
+
+ %.o : ../../../src/design/%.cpp
+- $(CC) $(CFLAGS) -I ../../../src/lib -o $@ -c $<
++ $(CC) $(CXXFLAGS) -I ../../../src/lib -o $@ -c $<
+
+ %.o : ../../../src/main/%.cpp
+- $(CC) $(CFLAGS) -I ../../../src/lib -o $@ -c $<
++ $(CC) $(CXXFLAGS) -I ../../../src/lib -o $@ -c $<
+
+ %.o : ../../../src/split/%.cpp
+- $(CC) $(CFLAGS) -I ../../../src/lib -o $@ -c $<
++ $(CC) $(CXXFLAGS) -I ../../../src/lib -o $@ -c $<
+
+ all: vina vina_split
+