summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-08-04 14:52:26 +0000
committerJustin Lecher <jlec@gentoo.org>2010-08-04 14:52:26 +0000
commit2e90e34c86f36fead1944108d283bcbfd8f3b084 (patch)
tree29af6ea029bd3c84d069b06211264e654a0c4e4b /sci-chemistry
parentarm stable, bug #297299 (diff)
downloadgentoo-2-2e90e34c86f36fead1944108d283bcbfd8f3b084.tar.gz
gentoo-2-2e90e34c86f36fead1944108d283bcbfd8f3b084.tar.bz2
gentoo-2-2e90e34c86f36fead1944108d283bcbfd8f3b084.zip
Version bump and prll make fixes
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/azara/ChangeLog10
-rw-r--r--sci-chemistry/azara/azara-2.7.ebuild12
-rw-r--r--sci-chemistry/azara/azara-2.8.ebuild79
-rw-r--r--sci-chemistry/azara/files/2.7-impl-dec.patch24
-rw-r--r--sci-chemistry/azara/files/2.7-prll.patch (renamed from sci-chemistry/azara/files/help-makefile.patch)195
-rw-r--r--sci-chemistry/azara/files/2.8-impl-dec.patch12
-rw-r--r--sci-chemistry/azara/files/2.8-prll.patch312
7 files changed, 594 insertions, 50 deletions
diff --git a/sci-chemistry/azara/ChangeLog b/sci-chemistry/azara/ChangeLog
index 57b62adc10bd..58f8c903574e 100644
--- a/sci-chemistry/azara/ChangeLog
+++ b/sci-chemistry/azara/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-chemistry/azara
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/azara/ChangeLog,v 1.3 2010/04/11 18:24:13 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/azara/ChangeLog,v 1.4 2010/08/04 14:52:26 jlec Exp $
+
+*azara-2.8 (04 Aug 2010)
+
+ 04 Aug 2010; Justin Lecher <jlec@gentoo.org> +files/2.7-impl-dec.patch,
+ azara-2.7.ebuild, +files/2.7-prll.patch, +azara-2.8.ebuild,
+ +files/2.8-impl-dec.patch, +files/2.8-prll.patch,
+ -files/help-makefile.patch:
+ Version bump and prll make fixes
11 Apr 2010; Justin Lecher <jlec@gentoo.org> azara-2.7.ebuild:
Do not try to install not builded bins, fixed 314491
diff --git a/sci-chemistry/azara/azara-2.7.ebuild b/sci-chemistry/azara/azara-2.7.ebuild
index ce266f94a958..ebb0b2b0415c 100644
--- a/sci-chemistry/azara/azara-2.7.ebuild
+++ b/sci-chemistry/azara/azara-2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/azara/azara-2.7.ebuild,v 1.3 2010/04/11 18:24:13 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/azara/azara-2.7.ebuild,v 1.4 2010/08/04 14:52:26 jlec Exp $
EAPI="3"
@@ -23,19 +23,23 @@ DEPEND="${RDEPEND}"
src_prepare() {
echo "" > ENVIRONMENT
- epatch "${FILESDIR}"/help-makefile.patch
+# epatch "${FILESDIR}"/help-makefile.patch
+ epatch "${FILESDIR}"/${PV}-prll.patch
+ epatch "${FILESDIR}"/${PV}-impl-dec.patch
}
src_compile() {
local mymake
local xpmuse
+ local makeflags
mymake="${mymake} help nongui"
use X && mymake="${mymake} gui"
use opengl && mymake="${mymake} gl"
use xpm && XPMUSE="XPM_FLAG=-DUSE_XPM XPM_LIB=-lXpm"
- emake -j1 CC=$(tc-getCC) \
+ emake \
+ CC=$(tc-getCC) \
CFLAGS="${CFLAGS}" \
LFLAGS="${LDFLAGS}" \
MATH_LIB="-lm" \
@@ -64,7 +68,7 @@ src_install() {
dobin "${bin}" || die "failed to install ${bin}"
done
- mv "${D}"/usr/bin/{,azara-}extract || die "failed to fix extract collision"
+ mv "${ED}"/usr/bin/{,azara-}extract || die "failed to fix extract collision"
dodoc CHANGES* README* || die
dohtml -r html/* || die
diff --git a/sci-chemistry/azara/azara-2.8.ebuild b/sci-chemistry/azara/azara-2.8.ebuild
new file mode 100644
index 000000000000..a9c511532db7
--- /dev/null
+++ b/sci-chemistry/azara/azara-2.8.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/azara/azara-2.8.ebuild,v 1.1 2010/08/04 14:52:26 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+
+inherit eutils python toolchain-funcs
+
+DESCRIPTION="A suite of programmes to process and view NMR data"
+HOMEPAGE="http://www.bio.cam.ac.uk/azara/"
+SRC_URI="http://www.bio.cam.ac.uk/ccpn/download/${PN}/${P}-src.tgz"
+
+LICENSE="AZARA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="X xpm"
+
+RDEPEND="
+ xpm? ( x11-libs/libXpm )
+ X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ cat > ENVIRONMENT <<- EOF
+ CC=$(tc-getCC)
+ CFLAGS=${CFLAGS}
+ LFLAGS=${LDFLAGS}
+ MATH_LIB=-lm
+ X11_INCLUDE_DIR=-I${EPREFIX}/usr/X11R6/include
+ MOTIF_INCLUDE_DIR=-I${EPREFIX}/usr/include
+ X11_LIB_DIR=-L${EPREFIX}/usr/$(get_libdir)
+ MOTIF_LIB_DIR=-L${EPREFIX}/usr/$(get_libdir)
+ X11_LIB=-lX11
+ MOTIF_LIB=-lXm -lXt
+ PYTHON_INCLUDE_DIR=$(python_get_includedir)
+ SHARED_FLAGS = -shared
+ ENDIAN_FLAG=-DLITTLE_ENDIAN_DATA
+ EOF
+
+ use xpm && echo "XPMUSE=\"XPM_FLAG=-DUSE_XPM XPM_LIB=-lXpm\"" >> ENVIRONMENT
+
+ epatch "${FILESDIR}"/${PV}-prll.patch
+ epatch "${FILESDIR}"/${PV}-impl-dec.patch
+}
+
+src_compile() {
+ local mymake
+ local makeflags
+
+ mymake="${mymake} help nongui DataRows"
+ use X && mymake="${mymake} gui"
+
+ emake ${mymake} || die
+}
+
+src_install() {
+ rm bin/pythonAzara || die
+ if ! use X; then
+ rm bin/plot* || die
+ fi
+ for bin in bin/*; do
+ dobin "${bin}" || die "failed to install ${bin}"
+ done
+
+ mv "${ED}"/usr/bin/{,azara-}extract || die "failed to fix extract collision"
+
+ dodoc CHANGES* README* || die
+ dohtml -r html/* || die
+}
+
+pkg_postinst() {
+ einfo "Due to collision we moved the extract binary to azara-extract"
+}
diff --git a/sci-chemistry/azara/files/2.7-impl-dec.patch b/sci-chemistry/azara/files/2.7-impl-dec.patch
new file mode 100644
index 000000000000..b491ec7691ec
--- /dev/null
+++ b/sci-chemistry/azara/files/2.7-impl-dec.patch
@@ -0,0 +1,24 @@
+diff --git a/global/macros.h b/global/macros.h
+index ddeaffa..2bcc433 100644
+--- a/global/macros.h
++++ b/global/macros.h
+@@ -6,6 +6,7 @@
+ #include <math.h>
+ #include <string.h>
+ #include <stdlib.h>
++#include <ctype.h>
+
+ #ifdef WIN32
+ #include <ctype.h>
+diff --git a/plot2/script.c b/plot2/script.c
+index 2f55182..ef219cc 100644
+--- a/plot2/script.c
++++ b/plot2/script.c
+@@ -4,6 +4,7 @@
+ #include "stack.h"
+ #include "utility.h"
+
++
+ #define SCRIPT_COMMENT '!'
+
+ #define LOOP_KEY "loop"
diff --git a/sci-chemistry/azara/files/help-makefile.patch b/sci-chemistry/azara/files/2.7-prll.patch
index 5a42034734da..ced64d1760e1 100644
--- a/sci-chemistry/azara/files/help-makefile.patch
+++ b/sci-chemistry/azara/files/2.7-prll.patch
@@ -1,9 +1,12 @@
---- help/makefile 2002-11-01 13:27:27.000000000 +0100
-+++ help/makefile.new 2008-12-24 14:45:56.141225333 +0100
-@@ -37,102 +37,102 @@
+diff --git a/help/makefile b/help/makefile
+index aa9274f..d349286 100644
+--- a/help/makefile
++++ b/help/makefile
+@@ -36,103 +36,103 @@ globals:
+
.c.o:; $(CC) -c $(CFLAGS) $<
- hlp:
+-hlp:
- txt2hlp azara
- txt2hlp combine
- txt2hlp components
@@ -43,47 +46,8 @@
- txt2hlp plot1/region
- txt2hlp plot1/slider
- txt2hlp plot1/text
-+ ./txt2hlp azara
-+ ./txt2hlp combine
-+ ./txt2hlp components
-+ ./txt2hlp connect
-+ ./txt2hlp contours
-+ ./txt2hlp deflate
-+ ./txt2hlp extract
-+ ./txt2hlp peak_find
-+ ./txt2hlp peak_fit
-+ ./txt2hlp plot1
-+ ./txt2hlp plot2
-+ ./txt2hlp process
-+ ./txt2hlp project
-+ ./txt2hlp slides
-+ ./txt2hlp reflate
-+ ./txt2hlp unblock
-+ ./txt2hlp viewer
-+ ./txt2hlp plot2/baseline
-+ ./txt2hlp plot2/data
-+ ./txt2hlp plot2/extract
-+ ./txt2hlp plot2/levels
-+ ./txt2hlp plot2/object
-+ ./txt2hlp plot2/output
-+ ./txt2hlp plot2/peak
-+ ./txt2hlp plot2/peaks
-+ ./txt2hlp plot2/phase
-+ ./txt2hlp plot2/property
-+ ./txt2hlp plot2/region
-+ ./txt2hlp plot2/rowcol
-+ ./txt2hlp plot2/save
-+ ./txt2hlp plot2/tracking
-+ ./txt2hlp plot1/button
-+ ./txt2hlp plot1/data
-+ ./txt2hlp plot1/object
-+ ./txt2hlp plot1/output
-+ ./txt2hlp plot1/property
-+ ./txt2hlp plot1/region
-+ ./txt2hlp plot1/slider
-+ ./txt2hlp plot1/text
-
- html:
+-
+-html:
- txt2html azara
- txt2html combine
- txt2html components
@@ -134,6 +98,48 @@
- txt2html CHANGES-2.6-0
- txt2html CHANGES-2.7-0
- txt2html LICENSE
++hlp: txt2hlp
++ ./txt2hlp azara
++ ./txt2hlp combine
++ ./txt2hlp components
++ ./txt2hlp connect
++ ./txt2hlp contours
++ ./txt2hlp deflate
++ ./txt2hlp extract
++ ./txt2hlp peak_find
++ ./txt2hlp peak_fit
++ ./txt2hlp plot1
++ ./txt2hlp plot2
++ ./txt2hlp process
++ ./txt2hlp project
++ ./txt2hlp slides
++ ./txt2hlp reflate
++ ./txt2hlp unblock
++ ./txt2hlp viewer
++ ./txt2hlp plot2/baseline
++ ./txt2hlp plot2/data
++ ./txt2hlp plot2/extract
++ ./txt2hlp plot2/levels
++ ./txt2hlp plot2/object
++ ./txt2hlp plot2/output
++ ./txt2hlp plot2/peak
++ ./txt2hlp plot2/peaks
++ ./txt2hlp plot2/phase
++ ./txt2hlp plot2/property
++ ./txt2hlp plot2/region
++ ./txt2hlp plot2/rowcol
++ ./txt2hlp plot2/save
++ ./txt2hlp plot2/tracking
++ ./txt2hlp plot1/button
++ ./txt2hlp plot1/data
++ ./txt2hlp plot1/object
++ ./txt2hlp plot1/output
++ ./txt2hlp plot1/property
++ ./txt2hlp plot1/region
++ ./txt2hlp plot1/slider
++ ./txt2hlp plot1/text
++
++html: txt2html
+ ./txt2html azara
+ ./txt2html combine
+ ./txt2html components
@@ -194,3 +200,102 @@
- rm txt2html
+ rm ./txt2hlp
+ rm ./txt2html
+diff --git a/makefile b/makefile
+index 752f31d..e12f9c4 100644
+--- a/makefile
++++ b/makefile
+@@ -14,7 +14,7 @@ all: help nongui gui gl
+ help: \
+ help_program
+
+-nongui: \
++nongui: help \
+ process_program \
+ peak_program \
+ extract_program \
+@@ -30,66 +30,66 @@ nongui: \
+ components_program \
+ azara_program
+
+-gui: \
++gui: help \
+ plot2_program \
+ plot1_program
+
+-gl: \
++gl: help \
+ viewer_program
+
+ process_program:
+- cd process; $(MAKE)
++ $(MAKE) -C process
+
+ plot2_program:
+- cd plot2; $(MAKE)
++ $(MAKE) -C plot2
+
+ plot1_program:
+- cd plot1; $(MAKE)
++ $(MAKE) -C plot1
+
+ peak_program:
+- cd peak; $(MAKE)
++ $(MAKE) -C peak
+
+ extract_program:
+- cd extract; $(MAKE)
++ $(MAKE) -C extract
+
+ project_program:
+- cd project; $(MAKE)
++ $(MAKE) -C project
+
+ unblock_program:
+- cd unblock; $(MAKE)
++ $(MAKE) -C unblock
+
+ contours_program:
+- cd contours; $(MAKE)
++ $(MAKE) -C contours
+
+ combine_program:
+- cd combine; $(MAKE)
++ $(MAKE) -C combine
+
+ deflate_program:
+- cd deflate; $(MAKE)
++ $(MAKE) -C deflate
+
+ reflate_program:
+- cd reflate; $(MAKE)
++ $(MAKE) -C reflate
+
+ slides_program:
+- cd slides; $(MAKE)
++ $(MAKE) -C slides
+
+ components_program:
+- cd components; $(MAKE)
++ $(MAKE) -C components
+
+ utility_program:
+- cd utility; $(MAKE)
++ $(MAKE) -C utility
+
+ connect_program:
+- cd connect; $(MAKE)
++ $(MAKE) -C connect
+
+ viewer_program:
+- cd viewer; $(MAKE)
++ $(MAKE) -C viewer
+
+ help_program:
+ cd help; $(MAKE)
+
+ azara_program:
+- cd azara; $(MAKE)
++ $(MAKE) -C azara
+
+ clean: \
+ global_clean \
diff --git a/sci-chemistry/azara/files/2.8-impl-dec.patch b/sci-chemistry/azara/files/2.8-impl-dec.patch
new file mode 100644
index 000000000000..644656a48e4a
--- /dev/null
+++ b/sci-chemistry/azara/files/2.8-impl-dec.patch
@@ -0,0 +1,12 @@
+diff --git a/global/macros.h b/global/macros.h
+index 43fc43e..bb1d267 100644
+--- a/global/macros.h
++++ b/global/macros.h
+@@ -8,6 +8,7 @@
+ #include <math.h>
+ #include <string.h>
+ #include <stdlib.h>
++#include <ctype.h>
+
+ #ifdef WIN32
+ #include <ctype.h>
diff --git a/sci-chemistry/azara/files/2.8-prll.patch b/sci-chemistry/azara/files/2.8-prll.patch
new file mode 100644
index 000000000000..20cce4534e4f
--- /dev/null
+++ b/sci-chemistry/azara/files/2.8-prll.patch
@@ -0,0 +1,312 @@
+diff --git a/DataRows/makefile b/DataRows/makefile
+index 587e710..3d49953 100644
+--- a/DataRows/makefile
++++ b/DataRows/makefile
+@@ -39,7 +39,7 @@ locals:
+ $(MAKE) local_objects
+
+ globals:
+- cd $(GLOBAL_DIR); $(MAKE) python_objects
++ $(MAKE) -C $(GLOBAL_DIR) python_objects
+
+ py_data_rows.o: py_data_rows.c
+ $(CC) -c $(CFLAGS) $(PYTHON_INCLUDE_DIR) $<
+diff --git a/azara/makefile b/azara/makefile
+index 3ba0cd9..4de1857 100644
+--- a/azara/makefile
++++ b/azara/makefile
+@@ -24,7 +24,7 @@ locals:
+ $(MAKE) local_objects
+
+ globals:
+- cd $(GLOBAL_DIR); $(MAKE) azara_objects
++ $(MAKE) -C $(GLOBAL_DIR) azara_objects
+
+ .c.o:; $(CC) -c $(CFLAGS) $<
+
+diff --git a/combine/makefile b/combine/makefile
+index a855236..11891f6 100644
+--- a/combine/makefile
++++ b/combine/makefile
+@@ -32,7 +32,7 @@ locals:
+ $(MAKE) local_objects
+
+ globals:
+- cd $(GLOBAL_DIR); $(MAKE) combine_objects
++ $(MAKE) -C $(GLOBAL_DIR) combine_objects
+
+ .c.o:; $(CC) -c $(CFLAGS) $<
+
+diff --git a/connect/makefile b/connect/makefile
+index d75e7da..4769266 100644
+--- a/connect/makefile
++++ b/connect/makefile
+@@ -35,7 +35,7 @@ locals:
+ $(MAKE) local_objects
+
+ globals:
+- cd $(GLOBAL_DIR); $(MAKE) connect_objects
++ $(MAKE) -C $(GLOBAL_DIR) connect_objects
+
+ .c.o:; $(CC) -c $(CFLAGS) $<
+
+diff --git a/contours/makefile b/contours/makefile
+index 5b832b8..895fd74 100644
+--- a/contours/makefile
++++ b/contours/makefile
+@@ -31,7 +31,7 @@ locals:
+ $(MAKE) local_objects
+
+ globals:
+- cd $(GLOBAL_DIR); $(MAKE) contours_objects
++ $(MAKE) -C $(GLOBAL_DIR) contours_objects
+
+ .c.o:; $(CC) -c $(CFLAGS) $<
+
+diff --git a/deflate/makefile b/deflate/makefile
+index 4c4e02e..0b2cdc4 100644
+--- a/deflate/makefile
++++ b/deflate/makefile
+@@ -30,7 +30,7 @@ locals:
+ $(MAKE) local_objects
+
+ globals:
+- cd $(GLOBAL_DIR); $(MAKE) deflate_objects
++ $(MAKE) -C $(GLOBAL_DIR) deflate_objects
+
+ .c.o:; $(CC) -c $(CFLAGS) $<
+
+diff --git a/extract/makefile b/extract/makefile
+index 3212cb9..b786746 100644
+--- a/extract/makefile
++++ b/extract/makefile
+@@ -30,7 +30,7 @@ locals:
+ $(MAKE) local_objects
+
+ globals:
+- cd $(GLOBAL_DIR); $(MAKE) extract_objects
++ $(MAKE) -C $(GLOBAL_DIR) extract_objects
+
+ .c.o:; $(CC) -c $(CFLAGS) $<
+
+diff --git a/help/makefile b/help/makefile
+index 9e99a7c..59a86a3 100644
+--- a/help/makefile
++++ b/help/makefile
+@@ -39,7 +39,7 @@ globals:
+
+ .c.o:; $(CC) -c $(CFLAGS) $<
+
+-hlp:
++hlp: txt2hlp
+ $(TXT2HLP) azara
+ $(TXT2HLP) combine
+ $(TXT2HLP) connect
+@@ -78,7 +78,7 @@ hlp:
+ $(TXT2HLP) plot1/text
+ $(TXT2HLP) DataRows
+
+-html:
++html: txt2html
+ $(TXT2HTML) azara
+ $(TXT2HTML) combine
+ $(TXT2HTML) connect
+diff --git a/makefile b/makefile
+index 9965b07..3cee572 100644
+--- a/makefile
++++ b/makefile
+@@ -14,7 +14,7 @@ all: help nongui DataRows gui
+ help: \
+ help_program
+
+-nongui: \
++nongui: help \
+ process_program \
+ plot2_nog_program \
+ peak_program \
+@@ -29,63 +29,63 @@ nongui: \
+ connect_program \
+ azara_program
+
+-gui: \
++gui: help \
+ plot2_program \
+ plot1_program
+
+-DataRows: \
++DataRows: help \
+ DataRows
+
+ process_program:
+- cd process; $(MAKE)
++ $(MAKE) -C process
+
+ plot2_program:
+- cd plot2; $(MAKE) plot2
++ $(MAKE) -C plot2
+
+ plot2_nog_program:
+- cd plot2; $(MAKE) plot2_nog
++ $(MAKE) -C plot2 plot2_nog
+
+ plot1_program:
+- cd plot1; $(MAKE)
++ $(MAKE) -C plot1
+
+ peak_program:
+- cd peak; $(MAKE)
++ $(MAKE) -C peak
+
+ extract_program:
+- cd extract; $(MAKE)
++ $(MAKE) -C extract
+
+ project_program:
+- cd project; $(MAKE)
++ $(MAKE) -C project
+
+ unblock_program:
+- cd unblock; $(MAKE)
++ $(MAKE) -C unblock
+
+ contours_program:
+- cd contours; $(MAKE)
++ $(MAKE) -C contours
+
+ combine_program:
+- cd combine; $(MAKE)
++ $(MAKE) -C combine
+
+ deflate_program:
+- cd deflate; $(MAKE)
++ $(MAKE) -C deflate
+
+ reflate_program:
+- cd reflate; $(MAKE)
++ $(MAKE) -C reflate
+
+ utility_program:
+- cd utility; $(MAKE)
++ $(MAKE) -C utility
+
+ connect_program:
+- cd connect; $(MAKE)
++ $(MAKE) -C connect
+
+ help_program:
+ cd help; $(MAKE)
+
+ azara_program:
+- cd azara; $(MAKE)
++ $(MAKE) -C azara
+
+ DataRows:
+- cd DataRows; $(MAKE)
++ $(MAKE) -C DataRows
+
+ clean: \
+ global_clean \
+diff --git a/peak/makefile b/peak/makefile
+index f3c13b7..77b3bac 100644
+--- a/peak/makefile
++++ b/peak/makefile
+@@ -116,7 +116,7 @@ local_find:
+ $(MAKE) local_find_objects
+
+ global_find:
+- cd $(GLOBAL_DIR); $(MAKE) peak_find_objects
++ $(MAKE) -C $(GLOBAL_DIR) peak_find_objects
+
+ local_fit_objects: $(LOCAL_FIT_OBJS)
+
+@@ -124,10 +124,10 @@ local_fit:
+ $(MAKE) local_fit_objects
+
+ global_fit:
+- cd $(GLOBAL_DIR); $(MAKE) peak_fit_objects
++ $(MAKE) -C $(GLOBAL_DIR) peak_fit_objects
+
+ commands:
+- cd $(COMMAND_DIR); $(MAKE) peak
++ $(MAKE) -C $(COMMAND_DIR) peak
+
+
+ .c.o:; $(CC) -c $(CFLAGS) $<
+diff --git a/plot1/makefile b/plot1/makefile
+index d1dce2d..73ed1ac 100644
+--- a/plot1/makefile
++++ b/plot1/makefile
+@@ -108,7 +108,7 @@ locals:
+ $(MAKE) local_objects
+
+ globals:
+- cd $(GLOBAL_DIR); $(MAKE) plot1_objects
++ $(MAKE) -C $(GLOBAL_DIR) plot1_objects
+
+ .c.o:; $(CC) $(X11_INCLUDE_DIR) $(MOTIF_INCLUDE_DIR) -c $(CFLAGS) $<
+
+diff --git a/plot2/makefile b/plot2/makefile
+index a6b7b4a..f1cd86c 100644
+--- a/plot2/makefile
++++ b/plot2/makefile
+@@ -149,7 +149,7 @@ local_plot2:
+ $(MAKE) local_plot2_objects
+
+ global_plot2:
+- cd $(GLOBAL_DIR); $(MAKE) plot2_objects
++ $(MAKE) -C $(GLOBAL_DIR) plot2_objects
+
+ local_plot2_nog_objects: $(LOCAL_PLOT2_NOG_OBJS)
+
+diff --git a/process/makefile b/process/makefile
+index 22ceeed..33e811b 100644
+--- a/process/makefile
++++ b/process/makefile
+@@ -86,7 +86,7 @@ locals:
+ $(MAKE) local_objects
+
+ globals:
+- cd $(GLOBAL_DIR); $(MAKE) process_objects
++ $(MAKE) -C $(GLOBAL_DIR) process_objects
+
+ peak:
+ $(MAKE) peak_objects
+diff --git a/project/makefile b/project/makefile
+index 78143fc..6d7745c 100644
+--- a/project/makefile
++++ b/project/makefile
+@@ -30,7 +30,7 @@ locals:
+ $(MAKE) local_objects
+
+ globals:
+- cd $(GLOBAL_DIR); $(MAKE) project_objects
++ $(MAKE) -C $(GLOBAL_DIR) project_objects
+
+ .c.o:; $(CC) -c $(CFLAGS) $<
+
+diff --git a/reflate/makefile b/reflate/makefile
+index 079a3fc..cdf8d8d 100644
+--- a/reflate/makefile
++++ b/reflate/makefile
+@@ -30,7 +30,7 @@ locals:
+ $(MAKE) local_objects
+
+ globals:
+- cd $(GLOBAL_DIR); $(MAKE) reflate_objects
++ $(MAKE) -C $(GLOBAL_DIR) reflate_objects
+
+ .c.o:; $(CC) -c $(CFLAGS) $<
+
+diff --git a/unblock/makefile b/unblock/makefile
+index 510dc9e..e006685 100644
+--- a/unblock/makefile
++++ b/unblock/makefile
+@@ -30,7 +30,7 @@ locals:
+ $(MAKE) local_objects
+
+ globals:
+- cd $(GLOBAL_DIR); $(MAKE) unblock_objects
++ $(MAKE) -C $(GLOBAL_DIR) unblock_objects
+
+ .c.o:; $(CC) -c $(CFLAGS) $<
+