summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-10-10 08:19:27 +0000
committerJustin Lecher <jlec@gentoo.org>2014-10-10 08:19:27 +0000
commit2adeb3c72e3deb7556aeb1c3649f48e6fe7a3cc5 (patch)
tree65f28ff71aa890ff66f0a3c533cc01d272ff078c /sci-chemistry
parentStable for HPPA (bug #524870). (diff)
downloadgentoo-2-2adeb3c72e3deb7556aeb1c3649f48e6fe7a3cc5.tar.gz
gentoo-2-2adeb3c72e3deb7556aeb1c3649f48e6fe7a3cc5.tar.bz2
gentoo-2-2adeb3c72e3deb7556aeb1c3649f48e6fe7a3cc5.zip
sci-chemistry/relax: Version BUmp
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/relax/ChangeLog7
-rw-r--r--sci-chemistry/relax/relax-3.3.1.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/sci-chemistry/relax/ChangeLog b/sci-chemistry/relax/ChangeLog
index 12f76460f9e2..065a8df62162 100644
--- a/sci-chemistry/relax/ChangeLog
+++ b/sci-chemistry/relax/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/relax
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/ChangeLog,v 1.27 2014/09/15 12:27:07 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/ChangeLog,v 1.28 2014/10/10 08:19:27 jlec Exp $
+
+*relax-3.3.1 (10 Oct 2014)
+
+ 10 Oct 2014; Justin Lecher <jlec@gentoo.org> +relax-3.3.1.ebuild:
+ Version BUmp
*relax-3.3.0 (15 Sep 2014)
diff --git a/sci-chemistry/relax/relax-3.3.1.ebuild b/sci-chemistry/relax/relax-3.3.1.ebuild
new file mode 100644
index 000000000000..af1549b38955
--- /dev/null
+++ b/sci-chemistry/relax/relax-3.3.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/relax-3.3.1.ebuild,v 1.1 2014/10/10 08:19:27 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+WX_GTK_VER="2.9"
+
+inherit eutils multiprocessing python-single-r1 scons-utils toolchain-funcs wxwidgets virtualx
+
+DESCRIPTION="Molecular dynamics by NMR data analysis"
+HOMEPAGE="http://www.nmr-relax.com/"
+SRC_URI="http://download.gna.org/relax/${P}.src.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/Numdifftools[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/wxpython:${WX_GTK_VER}[${PYTHON_USEDEP}]
+ sci-chemistry/molmol
+ sci-chemistry/pymol[${PYTHON_USEDEP}]
+ sci-chemistry/vmd
+ >=sci-libs/bmrblib-1.0.3[${PYTHON_USEDEP}]
+ >=sci-libs/minfx-1.0.11[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-visualization/grace
+ sci-visualization/opendx
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+DEPEND="${RDEPEND}
+ media-gfx/pngcrush"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ rm -rf minfx bmrblib extern/numdifftools || die
+ tc-export CC
+}
+
+src_compile() {
+ escons
+}
+
+src_test() {
+ VIRTUALX_COMMAND="${EPYTHON} ./${PN}.py -x --traceback"
+ virtualmake
+}
+
+src_install() {
+ dodoc README docs/{CHANGES,COMMITTERS,JOBS,relax.pdf}
+
+ python_moduleinto ${PN}
+ python_domodule *
+
+ rm ${PN} README || die
+
+ make_wrapper ${PN}-nmr "${EPYTHON} $(python_get_sitedir)/${PN}/${PN}.py $@"
+}