summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-09-14 19:49:58 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-09-14 19:49:58 +0000
commit0a396caaca1c1a8f28464f810e5e9cc303ba9349 (patch)
treecb5a8b70bc9819438aebc17a8a06d86cbeb17c84 /sci-chemistry
parentRemove stupid static-libs USE flag as the package should _not_ install static... (diff)
downloadgentoo-2-0a396caaca1c1a8f28464f810e5e9cc303ba9349.tar.gz
gentoo-2-0a396caaca1c1a8f28464f810e5e9cc303ba9349.tar.bz2
gentoo-2-0a396caaca1c1a8f28464f810e5e9cc303ba9349.zip
Fix building with libpng15 wrt #378737 by Diego Elio Pettenò. Fix missing dependencies; freeglut, giflib, libpng, zlib, glu, jpeg, opengl and libX11.
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/povscript+/ChangeLog7
-rw-r--r--sci-chemistry/povscript+/files/povscript+-2.1.2.2.19-libpng15.patch19
-rw-r--r--sci-chemistry/povscript+/povscript+-2.1.2.2.19.ebuild34
3 files changed, 49 insertions, 11 deletions
diff --git a/sci-chemistry/povscript+/ChangeLog b/sci-chemistry/povscript+/ChangeLog
index e7679e590a3f..0173ff209d87 100644
--- a/sci-chemistry/povscript+/ChangeLog
+++ b/sci-chemistry/povscript+/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/povscript+
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/povscript+/ChangeLog,v 1.4 2011/03/02 17:51:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/povscript+/ChangeLog,v 1.5 2011/09/14 19:49:57 ssuominen Exp $
+
+ 14 Sep 2011; Samuli Suominen <ssuominen@gentoo.org>
+ povscript+-2.1.2.2.19.ebuild, +files/povscript+-2.1.2.2.19-libpng15.patch:
+ Fix building with libpng15 wrt #378737 by Diego Elio Pettenò. Fix missing
+ dependencies; freeglut, giflib, libpng, zlib, glu, jpeg, opengl and libX11.
02 Mar 2011; Justin Lecher <jlec@gentoo.org> povscript+-2.1.2.2.18.ebuild,
povscript+-2.1.2.2.19.ebuild:
diff --git a/sci-chemistry/povscript+/files/povscript+-2.1.2.2.19-libpng15.patch b/sci-chemistry/povscript+/files/povscript+-2.1.2.2.19-libpng15.patch
new file mode 100644
index 000000000000..054967d6555c
--- /dev/null
+++ b/sci-chemistry/povscript+/files/povscript+-2.1.2.2.19-libpng15.patch
@@ -0,0 +1,19 @@
+--- src/png_img.c
++++ src/png_img.c
+@@ -18,6 +18,7 @@
+
+ #include MS_GL_H
+
++#include <zlib.h>
+ #include <png.h>
+
+ #include "clib/str_utils.h"
+@@ -69,7 +70,7 @@
+ info_ptr = png_create_info_struct (png_ptr);
+ if (info_ptr == NULL)
+ yyerror ("png_img: could not create PNG info structure");
+- if (setjmp (png_ptr->jmpbuf)) yyerror ("png_img: could not setjmp");
++ if (setjmp (png_jmpbuf(png_ptr))) yyerror ("png_img: could not setjmp");
+
+ png_init_io (png_ptr, outfile);
+ png_set_compression_level (png_ptr, compression_level);
diff --git a/sci-chemistry/povscript+/povscript+-2.1.2.2.19.ebuild b/sci-chemistry/povscript+/povscript+-2.1.2.2.19.ebuild
index f0f42396fc32..9da8aa72b8db 100644
--- a/sci-chemistry/povscript+/povscript+-2.1.2.2.19.ebuild
+++ b/sci-chemistry/povscript+/povscript+-2.1.2.2.19.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/povscript+/povscript+-2.1.2.2.19.ebuild,v 1.2 2011/03/02 17:51:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/povscript+/povscript+-2.1.2.2.19.ebuild,v 1.3 2011/09/14 19:49:57 ssuominen Exp $
-EAPI="1"
-
-inherit versionator
+EAPI=4
+inherit eutils versionator
V1=$(get_version_component_range 1 ${PV})
V2=$(get_version_component_range 2 ${PV})
@@ -12,22 +11,37 @@ V3=$(get_version_component_range 3 ${PV})
V4=$(get_version_component_range 4 ${PV})
V5=$(get_version_component_range 5 ${PV})
-MY_P="molscript-${V1}.${V2}.${V3}pov${V4}.${V5}"
+MY_P=molscript-${V1}.${V2}.${V3}pov${V4}.${V5}
+
DESCRIPTION="Modified molscript that uses POV-Ray, does thermal ellipsoids, and more"
HOMEPAGE="http://www.stanford.edu/~fenn/povscript/"
SRC_URI="http://www.stanford.edu/~fenn/packs/${MY_P}.tar.gz"
+
LICENSE="glut molscript"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-RDEPEND="
- dev-libs/glib:2
- sci-libs/gts"
+
+RDEPEND="dev-libs/glib:2
+ media-libs/freeglut
+ media-libs/giflib
+ >=media-libs/libpng-1.4
+ sci-libs/gts
+ sys-libs/zlib
+ virtual/glu
+ virtual/jpeg
+ virtual/opengl
+ x11-libs/libX11"
DEPEND="${RDEPEND}"
-S="${WORKDIR}/${MY_P}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng15.patch
+}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install
cd "${D}"/usr/bin
mv molscript povscript+
mv molauto povauto+