summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2009-08-06 14:19:15 +0000
committerMarkus Dittrich <markusle@gentoo.org>2009-08-06 14:19:15 +0000
commit9d46232b51b154befd652a1a78a88d6af6529bba (patch)
treeeb6fac00f5f801002ef1507bb903776b9e2ce322 /sci-chemistry/vmd
parentProxy commit for Anarchy: missed update from overlay to enable audio. (diff)
downloadgentoo-2-9d46232b51b154befd652a1a78a88d6af6529bba.tar.gz
gentoo-2-9d46232b51b154befd652a1a78a88d6af6529bba.tar.bz2
gentoo-2-9d46232b51b154befd652a1a78a88d6af6529bba.zip
Version bump (fixes bug #262275).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/vmd')
-rw-r--r--sci-chemistry/vmd/ChangeLog8
-rw-r--r--sci-chemistry/vmd/files/vmd-1.8.7-config.patch131
-rw-r--r--sci-chemistry/vmd/files/vmd-1.8.7-use-bash-startup.patch13
-rw-r--r--sci-chemistry/vmd/vmd-1.8.7.ebuild157
4 files changed, 308 insertions, 1 deletions
diff --git a/sci-chemistry/vmd/ChangeLog b/sci-chemistry/vmd/ChangeLog
index 2b86734de4dd..854a80b5321d 100644
--- a/sci-chemistry/vmd/ChangeLog
+++ b/sci-chemistry/vmd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/vmd
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/ChangeLog,v 1.22 2009/07/07 22:54:52 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/ChangeLog,v 1.23 2009/08/06 14:19:15 markusle Exp $
+
+*vmd-1.8.7 (05 Aug 2009)
+
+ 05 Aug 2009; Markus Dittrich <markusle@gentoo.org> +vmd-1.8.7.ebuild,
+ +files/vmd-1.8.7-config.patch, +files/vmd-1.8.7-use-bash-startup.patch:
+ Version bump (fixes bug #262275).
07 Jul 2009; Diego E. Pettenò <flameeyes@gentoo.org> vmd-1.8.6-r1.ebuild:
Use elog for fetch error.
diff --git a/sci-chemistry/vmd/files/vmd-1.8.7-config.patch b/sci-chemistry/vmd/files/vmd-1.8.7-config.patch
new file mode 100644
index 000000000000..633337105e97
--- /dev/null
+++ b/sci-chemistry/vmd/files/vmd-1.8.7-config.patch
@@ -0,0 +1,131 @@
+diff -Naur vmd-1.8.7/configure vmd-1.8.7.new/configure
+--- vmd-1.8.7/configure 2009-08-01 03:19:34.000000000 -0400
++++ vmd-1.8.7.new/configure 2009-08-05 09:07:08.000000000 -0400
+@@ -13,10 +13,10 @@
+ $install_name = "vmd";
+
+ # Directory where VMD startup script is installed, should be in users' paths.
+-$install_bin_dir="/usr/local/bin";
++$install_bin_dir="gentoo-bindir";
+
+ # Directory where VMD files and executables are installed
+-$install_library_dir="/usr/local/lib/$install_name";
++$install_library_dir="gentoo-libdir/$install_name";
+
+
+ # optionally override hard-coded defaults above with environment variables
+@@ -128,29 +128,6 @@
+ # Configure script code begins here
+ ############################################################################
+
+-## Test for existence of a properly compiled plugin tree
+-if (!(-e "plugins")) {
+- print "\n";
+- print "VMD plugin directory not found.\n";
+- print "Please compile the VMD plugins and do 'make distrib' to copy them\n";
+- print "into a 'plugins' directory linked or located in this directory.\n";
+- print "Be sure your PLUGINDIR environment variable is set before running\n";
+- print "'make distrib' in the plugin build area.\n";
+- print "\n";
+- die "Halting configuration until VMD plugins are built.\n";
+-} else {
+- if (!(-e "plugins/include/vmdplugin.h")) {
+- print "\n";
+- print "VMD plugin include files or directory not found.\n";
+- print "Please compile the VMD plugins and do 'make distrib' to copy them\n";
+- print "into a 'plugins' directory linked or located in this directory.\n";
+- print "Be sure your PLUGINDIR environment variable is set before running\n";
+- print "'make distrib' in the plugin build area.\n";
+- print "\n";
+- die "Halting configuration until VMD plugins are built.\n";
+- }
+-}
+-
+ #################### Parse command line options ###########
+ # list of allowed architectures
+ @archlist=('IRIX6', 'IRIX6_64', 'FREEBSD', 'HPUX11', 'AIX4', 'AIX5', 'AIX5_64', 'AIX6_64', 'LINUX', 'LINUXALPHA', 'LINUXAMD64', 'LINUXIA64', 'LINUXPPC', 'LINUXPPC64', 'MACOSX', 'MACOSXX86', 'MACOSXX86_64', 'TRU64', 'SOLARIS2', 'SOLARIS2_64', 'SOLARISX86', 'SOLARISX86_64', 'WIN32', 'WIN64');
+@@ -435,7 +412,7 @@
+
+ ################ Plugin options
+ #
+-$plugin_dir = "../plugins";
++$plugin_dir = "gentoo-plugindir";
+ $plugin_include = "-I$plugin_dir/include";
+ $plugin_library = "";
+ $plugin_libs = "";
+@@ -448,7 +425,7 @@
+ @plugin_extra = ();
+
+ if ($config_staticplugin) {
+- $molfile_dir = "$plugin_dir/$config_arch/molfile";
++ $molfile_dir = "$plugin_dir/compile/lib_LINUX/molfile";
+ $plugin_include .= " -I$molfile_dir";
+ $plugin_library .= " -L$molfile_dir";
+ $plugin_libs .= " -lmolfile_plugin";
+@@ -550,8 +527,8 @@
+ ################ FLTK GUI
+ $fltk_defines = "-DVMDGUI -DVMDFLTK";
+ $fltk_dir = "$vmd_library_dir/fltk";
+-$fltk_include = "-I$fltk_dir/include";
+-$fltk_library = "-L$fltk_dir/$config_arch";
++$fltk_include = "-Igentoo-fltk-include";
++$fltk_library = "-Lgentoo-fltk-libs";
+ $fltk_libs = "-lfltk -lX11";
+ #@fltk_cc = ('forms_ui.c');
+ @fltk_cu = ();
+@@ -938,8 +915,8 @@
+ #######################
+ $netcdf_defines = "";
+ $netcdf_dir = "$vmd_library_dir/netcdf";
+-$netcdf_include = "-I$netcdf_dir/include";
+-$netcdf_library = "-L$netcdf_dir/lib_$config_arch";
++$netcdf_include = "-Igentoo-netcdf-include";
++$netcdf_library = "-Lgentoo-netcdf-libs";
+ $netcdf_libs = "-lnetcdf";
+ @netcdf_cc = ();
+ @netcdf_cu = ();
+@@ -1007,9 +984,9 @@
+ $python_defines = "-DVMDPYTHON";
+ $python_dir = "$vmd_library_dir/python";
+ $numpy_dir = "$vmd_library_dir/numpy";
+-$python_include = "-I$python_dir/lib_$config_arch/include/python2.5 -I$numpy_dir/lib_$config_arch/include -I$python_dir/lib_$config_arch/lib/python2.5/site-packages/numpy/core/include";
+-$python_library = "-L$python_dir/lib_$config_arch/lib/python2.5/config";
+-$python_libs = "-lpython2.5 -lpthread";
++$python_include = "-Igentoo-python-include -Igentoo-numpy-include";
++$python_library = "-Lgentoo-python-lib";
++$python_libs = "-lgentoo-python-link -lpthread";
+ @python_h = ('PythonTextInterp.h',
+ 'VMDTkinterMenu.h',
+ 'py_commands.h',
+@@ -1621,8 +1598,8 @@
+
+ # XFree 4.0 Direct Rendering Interface and GLX
+ $opengl_dir = "/usr/X11R6";
+- $opengl_include = "-I$opengl_dir/include";
+- $opengl_library = "-L$opengl_dir/lib";
++ $opengl_include = "-Igentoo-opengl-include";
++ $opengl_library = "-Lgentoo-opengl-libs";
+ $opengl_libs = "-lGL -lGLU";
+ # $opengl_libs = "-L/usr/X11R6/lib -lGL -lGLU -lXext -lX11";
+
+@@ -1650,15 +1627,15 @@
+ $arch_lopts .= "-i-static ";
+ } else {
+ # compling with GCC
+- $arch_cc = "gcc";
+- $arch_ccpp = "g++";
++ $arch_cc = "gentoo-gcc";
++ $arch_ccpp = "gentoo-g++";
+ $arch_depend_flag = "-MM";
+- $arch_shld = "g++ -shared";
++ $arch_shld = "gentoo-g++ -shared";
+ $arch_shlibname = "so";
+ $arch_shcppopts = "-fPIC";
+ $arch_shldopts = "";
+- $arch_opt_flag = "-m32 -fno-for-scope -Wno-deprecated -Wall -O3";
+- $arch_copts = "-m32 -Wall -O3";
++ $arch_opt_flag = "gentoo-cflags";
++ $arch_copts = "gentoo-cflags";
+
+ if ($config_static) {
+ $arch_lopts = "-static";
diff --git a/sci-chemistry/vmd/files/vmd-1.8.7-use-bash-startup.patch b/sci-chemistry/vmd/files/vmd-1.8.7-use-bash-startup.patch
new file mode 100644
index 000000000000..422d95c69d11
--- /dev/null
+++ b/sci-chemistry/vmd/files/vmd-1.8.7-use-bash-startup.patch
@@ -0,0 +1,13 @@
+diff -Naur vmd-1.8.7.old/configure vmd-1.8.7/configure
+--- vmd-1.8.7.old/configure 2009-08-01 03:19:34.000000000 -0400
++++ vmd-1.8.7/configure 2009-08-05 09:30:33.000000000 -0400
+@@ -2804,8 +2804,7 @@
+ -\$(COPY) ../data/.vmdrc ../data/.vmdsensors ../data/vmd_completion.dat "$install_library_dir"
+ \$(CD) $vmd_bin_dir ; \\
+ if [ -f run_vmd_tmp ]; then \$(DELETE) run_vmd_tmp; fi ; \\
+- if [ ! -x "/bin/csh" ]; then \\
+- \$(ECHO) "Info: /bin/csh shell not found, installing Bourne shell startup script instead" ; \\
++ if [ -x "/bin/bash" ]; then \\
+ \$(ECHO) '#!/bin/sh' >> run_vmd_tmp ; \\
+ \$(ECHO) 'defaultvmddir="$install_library_dir"' >> run_vmd_tmp ; \\
+ \$(ECHO) 'vmdbasename=vmd' >> run_vmd_tmp ; \\
diff --git a/sci-chemistry/vmd/vmd-1.8.7.ebuild b/sci-chemistry/vmd/vmd-1.8.7.ebuild
new file mode 100644
index 000000000000..359d045909bc
--- /dev/null
+++ b/sci-chemistry/vmd/vmd-1.8.7.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/vmd-1.8.7.ebuild,v 1.1 2009/08/06 14:19:15 markusle Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs python
+
+DESCRIPTION="Visual Molecular Dynamics"
+LICENSE="vmd"
+HOMEPAGE="http://www.ks.uiuc.edu/Research/vmd/"
+SRC_URI="${P}.src.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RESTRICT="fetch"
+
+DEPEND="x11-libs/libXft
+ virtual/opengl
+ x11-libs/fltk:1.1
+ >=dev-lang/tcl-8.4
+ >=dev-lang/tk-8.4[-truetype]
+ =dev-lang/python-2*
+ dev-lang/perl
+ dev-python/numpy
+ sci-biology/stride
+ sci-libs/netcdf"
+
+RDEPEND="${DEPEND}
+ x11-terms/xterm"
+
+VMD_DOWNLOAD="http://www.ks.uiuc.edu/Development/Download/download.cgi?PackageName=VMD"
+
+pkg_nofetch() {
+ echo
+ elog "Please download ${SRC_URI} from"
+ elog "${VMD_DOWNLOAD}"
+ elog "after agreeing to the license and then move it to "
+ elog "${DISTDIR}"
+ echo
+}
+
+src_prepare() {
+ # apply LINUX-arch patches to vmd configure
+ epatch "${FILESDIR}/${P}-config.patch"
+ epatch "${FILESDIR}/${P}-use-bash-startup.patch"
+
+ # prepare the plugins
+ cd "${WORKDIR}"/plugins
+
+ sed -e "s:CC = gcc:CC = $(tc-getCC):" \
+ -e "s:CXX = g++:CXX = $(tc-getCXX):" \
+ -e "s:COPTO =.*\":COPTO = -fPIC -o\":" \
+ -e "s:LOPTO = .*\":LOPTO = -fPIC -o\":" \
+ -e "s:CCFLAGS =.*\":CCFLAGS = ${CFLAGS}\":" \
+ -e "s:CXXFLAGS =.*\":CXXFLAGS = ${CXXFLAGS}\":" \
+ -e "s:SHLD = gcc:SHLD = $(tc-getCC):" \
+ -e "s:-ltcl8.5:-ltcl:" \
+ -i Make-arch || die "Failed to set up plugins Makefile"
+
+ # prepare vmd itself
+ cd "${S}"
+
+ sed -e "s:gentoo-bindir:${D}/usr/bin:" \
+ -e "s:gentoo-libdir:${D}/usr/$(get_libdir):" \
+ -i configure || die "failed to adjust install paths"
+
+ sed -e "s:gentoo-opengl-include:/usr/include/GL:" \
+ -e "s:gentoo-opengl-libs:/usr/$(get_libdir):" \
+ -i configure || die "failed to adjust OpenGL paths"
+
+ sed -e "s:gentoo-gcc:$(tc-getCC):" \
+ -e "s:gentoo-g++:$(tc-getCXX):" \
+ -e "s:gentoo-cflags:${CFLAGS}:" \
+ -i configure || die "Failed to adjust C compiler/flags"
+
+ sed -e "s:gentoo-plugindir:${WORKDIR}/plugins:" \
+ -i configure || die "Failed to set up linking to plugin files"
+
+ sed -e "s:gentoo-fltk-include:/usr/include/fltk-1.1:" \
+ -e "s:gentoo-fltk-libs:/usr/$(get_libdir)/fltk-1.1:" \
+ -i configure || die "failed setting up fltk"
+
+ sed -e "s:gentoo-netcdf-include:/usr/include:" \
+ -e "s:gentoo-netcdf-libs:/usr/$(get_libdir):" \
+ -i configure || die "failed to set up netcdf"
+
+ # get installed python version
+ python_version
+ local PY="python${PYVER}"
+
+ local NUMPY_INCLUDE="site-packages/numpy/core/include"
+ sed -e "s:gentoo-python-include:/usr/include/${PY}:" \
+ -e "s:gentoo-python-lib:/usr/$(get_libdir)/${PY}:" \
+ -e "s:gentoo-python-link:${PY}:" \
+ -e "s:gentoo-numpy-include:/usr/$(get_libdir)/${PY}/${NUMPY_INCLUDE}:" \
+ -i configure || die "failed setting up python"
+
+ sed -e "s:LINUXPPC:LINUX:g" \
+ -e "s:LINUXALPHA:LINUX:g" \
+ -e "s:LINUXAMD64:LINUX:g" \
+ -i "${S}"/bin/vmd.sh || die "failed setting up vmd wrapper script"
+}
+
+
+src_configure() {
+ local myconfig="LINUX OPENGL FLTK TK TCL PTHREADS PYTHON IMD NETCDF NUMPY"
+ rm -f configure.options && echo $myconfig >> configure.options
+
+ ./configure &> /dev/null || die "failed to configure"
+}
+
+
+src_compile() {
+ # build plugins
+ cd "${WORKDIR}"/plugins
+
+ make LINUX TCLINC="-I/usr/include" \
+ TCLLIB="-L/usr/$(get_libdir)" \
+ || die "failed to build plugins"
+
+ # build vmd
+ cd "${S}"/src
+ emake || die "failed to build vmd"
+}
+
+src_install() {
+ # install plugins
+ cd "${WORKDIR}"/plugins
+ PLUGINDIR=${D}/usr/$(get_libdir)/${PN}/plugins make distrib || \
+ die "failed to install plugins"
+
+ # install vmd
+ cd "${S}"/src
+ make install || die "failed to install vmd"
+
+ # export STRIDE_BIN so VMD knows where to find stride
+ echo "STRIDE_BIN=/usr/bin/stride" > "${T}"/99${PN} || \
+ die "Failed to create vmd env file"
+ doenvd "${T}"/99${PN} || die "Failed to install vmd env file"
+
+ # install docs
+ cd "${S}"
+ dodoc Announcement README doc/ig.pdf doc/ug.pdf
+
+ # remove some of the things we don't want and need in
+ # /usr/lib
+ cd "${D}"/usr/$(get_libdir)/vmd
+ rm -fr doc README Announcement LICENSE || \
+ die "failed to clean up /usr/lib/vmd directory"
+
+ # adjust path in vmd wrapper
+ sed -e "s:${D}::" -i "${D}"/usr/bin/${PN} \
+ || die "failed to set up vmd wrapper script"
+}