summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-10-02 11:39:49 +0000
committerJustin Lecher <jlec@gentoo.org>2013-10-02 11:39:49 +0000
commit5f790ea797922be385c61f800cb31910e7ae438e (patch)
tree2be68ded043af4b49d904965799f16f8042c5805 /sci-chemistry/vmd
parentversion bump for bug #486210. (diff)
downloadgentoo-2-5f790ea797922be385c61f800cb31910e7ae438e.tar.gz
gentoo-2-5f790ea797922be385c61f800cb31910e7ae438e.tar.bz2
gentoo-2-5f790ea797922be385c61f800cb31910e7ae438e.zip
sci-chemistry/vmd: Add fix for cuda 5.5
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry/vmd')
-rw-r--r--sci-chemistry/vmd/ChangeLog6
-rw-r--r--sci-chemistry/vmd/files/vmd-1.9.1-cuda-device_ptr.patch28
-rw-r--r--sci-chemistry/vmd/vmd-1.9.1-r2.ebuild4
3 files changed, 36 insertions, 2 deletions
diff --git a/sci-chemistry/vmd/ChangeLog b/sci-chemistry/vmd/ChangeLog
index 75c4fc0db673..934542be9b45 100644
--- a/sci-chemistry/vmd/ChangeLog
+++ b/sci-chemistry/vmd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/vmd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/ChangeLog,v 1.57 2013/10/02 11:12:18 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/ChangeLog,v 1.58 2013/10/02 11:39:48 jlec Exp $
+
+ 02 Oct 2013; Justin Lecher <jlec@gentoo.org> vmd-1.9.1-r2.ebuild,
+ +files/vmd-1.9.1-cuda-device_ptr.patch:
+ Add fix for cuda 5.5
02 Oct 2013; Justin Lecher <jlec@gentoo.org> vmd-1.9.1-r2.ebuild:
Update dependency for tk
diff --git a/sci-chemistry/vmd/files/vmd-1.9.1-cuda-device_ptr.patch b/sci-chemistry/vmd/files/vmd-1.9.1-cuda-device_ptr.patch
new file mode 100644
index 000000000000..ce842448decf
--- /dev/null
+++ b/sci-chemistry/vmd/files/vmd-1.9.1-cuda-device_ptr.patch
@@ -0,0 +1,28 @@
+ vmd-1.9.1/src/CUDAMarchingCubes.cu | 1 +
+ vmd-1.9.1/src/CUDAQuickSurf.cu | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/vmd-1.9.1/src/CUDAMarchingCubes.cu b/vmd-1.9.1/src/CUDAMarchingCubes.cu
+index 5bfe7bf..36faaf0 100755
+--- a/vmd-1.9.1/src/CUDAMarchingCubes.cu
++++ b/vmd-1.9.1/src/CUDAMarchingCubes.cu
+@@ -45,6 +45,7 @@
+ #include "CUDAMarchingCubes.h"
+ #include <thrust/scan.h>
+ #include <thrust/functional.h>
++#include <thrust/device_ptr.h>
+
+ // The number of threads to use for triangle generation
+ // (limited by shared memory size)
+diff --git a/vmd-1.9.1/src/CUDAQuickSurf.cu b/vmd-1.9.1/src/CUDAQuickSurf.cu
+index a21ebde..56a42c8 100755
+--- a/vmd-1.9.1/src/CUDAQuickSurf.cu
++++ b/vmd-1.9.1/src/CUDAQuickSurf.cu
+@@ -22,6 +22,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <cuda.h>
++#include <thrust/device_ptr.h>
+
+ #if CUDART_VERSION < 4000
+ #error The VMD QuickSurf feature requires CUDA 4.0 or later
diff --git a/sci-chemistry/vmd/vmd-1.9.1-r2.ebuild b/sci-chemistry/vmd/vmd-1.9.1-r2.ebuild
index 89004e6d3f43..58d94f044413 100644
--- a/sci-chemistry/vmd/vmd-1.9.1-r2.ebuild
+++ b/sci-chemistry/vmd/vmd-1.9.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/vmd-1.9.1-r2.ebuild,v 1.4 2013/10/02 11:12:18 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/vmd-1.9.1-r2.ebuild,v 1.5 2013/10/02 11:39:48 jlec Exp $
EAPI=5
@@ -66,6 +66,8 @@ pkg_setup() {
src_prepare() {
use cuda && cuda_sanitize
+ epatch "${FILESDIR}"/${P}-cuda-device_ptr.patch
+
cd "${WORKDIR}"/plugins
epatch \