summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-12-22 14:00:25 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-12-22 14:00:25 +0000
commit2cb34707e18842fbb44f573a46c4043228e3c2c1 (patch)
tree31aae06afa85fe724eee44ea68be5f0d9fc8c751 /sci-chemistry/vmd/vmd-1.8.5.ebuild
parentMake it respect user-defined CFLAGS. (diff)
downloadgentoo-2-2cb34707e18842fbb44f573a46c4043228e3c2c1.tar.gz
gentoo-2-2cb34707e18842fbb44f573a46c4043228e3c2c1.tar.bz2
gentoo-2-2cb34707e18842fbb44f573a46c4043228e3c2c1.zip
Added netcdf support. This fixes bug #158771.
(Portage version: 2.1.2_rc3-r7)
Diffstat (limited to 'sci-chemistry/vmd/vmd-1.8.5.ebuild')
-rw-r--r--sci-chemistry/vmd/vmd-1.8.5.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/sci-chemistry/vmd/vmd-1.8.5.ebuild b/sci-chemistry/vmd/vmd-1.8.5.ebuild
index f95560d2a480..805a14c4de76 100644
--- a/sci-chemistry/vmd/vmd-1.8.5.ebuild
+++ b/sci-chemistry/vmd/vmd-1.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/vmd-1.8.5.ebuild,v 1.2 2006/11/09 14:08:51 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/vmd-1.8.5.ebuild,v 1.3 2006/12/22 14:00:25 markusle Exp $
inherit eutils toolchain-funcs python
@@ -11,7 +11,7 @@ SRC_URI="${P}.src.tar.gz"
SLOT="0"
KEYWORDS="~ppc ~x86"
-IUSE="hardened"
+IUSE="hardened netcdf"
RESTRICT="fetch"
@@ -19,11 +19,11 @@ DEPEND="app-shells/tcsh
|| ( x11-libs/libXft virtual/x11 )
virtual/opengl
x11-libs/fltk
- sci-libs/netcdf
=dev-lang/tcl-8.4*
=dev-lang/tk-8.4*
>=dev-lang/python-2.3
sci-biology/stride
+ netcdf? ( sci-libs/netcdf )
hardened? ( sys-apps/paxctl )"
@@ -43,7 +43,6 @@ src_unpack() {
# apply LINUX-arch patches to vmd configure
epatch "${FILESDIR}"/${P}-config-gentoo.patch
-# epatch "${FILESDIR}"/${P}-plugin-autopsf.patch
# prepare the plugins
@@ -80,6 +79,11 @@ src_unpack() {
-e "s:gentoo-fltk-libs:/usr/$(get_libdir)/fltk-1.1:" \
-i configure || die "failed setting up fltk"
+ if use netcdf; then
+ sed -e "s:gentoo-netcdf-include:/usr/include:" \
+ -e "s:gentoo-netcdf-libs:/usr/$(get_libdir):" \
+ -i configure || die "failed to set up netcdf"
+ fi
# get installed python version
python_version
@@ -97,6 +101,10 @@ src_unpack() {
local myconfig="LINUX OPENGL FLTK TK TCL PTHREADS PYTHON IMD"
+ if use netcdf; then
+ myconfig="${myconfig} NETCDF"
+ fi
+
rm -f configure.options && echo $myconfig >> configure.options
./configure &> /dev/null || die "failed to configure"