summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-29 06:13:10 +0000
committerJustin Lecher <jlec@gentoo.org>2013-05-29 06:13:10 +0000
commit63463113bd163987bcfe81514d7fc1bfa322bcef (patch)
treeb02b9f0f2c708cff09a071f6b48ed6b1f3801769 /sci-chemistry/theseus
parentadd py3.3 support, fixes Bug #470278 (diff)
downloadgentoo-2-63463113bd163987bcfe81514d7fc1bfa322bcef.tar.gz
gentoo-2-63463113bd163987bcfe81514d7fc1bfa322bcef.tar.bz2
gentoo-2-63463113bd163987bcfe81514d7fc1bfa322bcef.zip
sci-chemistry/theseus: Version Bump
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-chemistry/theseus')
-rw-r--r--sci-chemistry/theseus/ChangeLog7
-rw-r--r--sci-chemistry/theseus/theseus-2.0.3.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/sci-chemistry/theseus/ChangeLog b/sci-chemistry/theseus/ChangeLog
index 574895deb390..01af5f940c19 100644
--- a/sci-chemistry/theseus/ChangeLog
+++ b/sci-chemistry/theseus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/theseus
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/theseus/ChangeLog,v 1.6 2013/04/24 10:21:00 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/theseus/ChangeLog,v 1.7 2013/05/29 06:13:10 jlec Exp $
+
+*theseus-2.0.3 (29 May 2013)
+
+ 29 May 2013; Justin Lecher <jlec@gentoo.org> +theseus-2.0.3.ebuild:
+ Version Bump
*theseus-2.0.1-r1 (24 Apr 2013)
diff --git a/sci-chemistry/theseus/theseus-2.0.3.ebuild b/sci-chemistry/theseus/theseus-2.0.3.ebuild
new file mode 100644
index 000000000000..b0f2b5a7a633
--- /dev/null
+++ b/sci-chemistry/theseus/theseus-2.0.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/theseus/theseus-2.0.3.ebuild,v 1.1 2013/05/29 06:13:10 jlec Exp $
+
+EAPI=5
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="maximum likelihood superpositioning and analysis of macromolecular structures"
+HOMEPAGE="http://www.theseus3d.org/"
+SRC_URI="http://www.theseus3d.org/src/${PN}_${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ sci-libs/gsl
+ || (
+ sci-biology/probcons
+ sci-biology/mafft
+ sci-biology/t-coffee
+ sci-biology/kalign
+ sci-biology/clustalw
+ sci-biology/muscle
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${PN}_src/
+
+src_prepare() {
+ cat >> make.inc <<- EOF
+ ARCH = $(tc-getAR)
+ ARCHFLAGS = -rvs
+ RANLIB = $(tc-getRANLIB)
+ LOCALLIBDIR = "${EPREFIX}/usr/$(get_libdir)
+ SYSLIBS = $(pkg-config --libs gsl) -lpthread
+ LIBS = -ldistfit -lmsa -ldssplite -ldltmath -lDLTutils -ltheseus
+ LIBDIR = -L./lib
+ INSTALLDIR = "${ED}"/usr/bin
+ OPT =
+ WARN =
+ CFLAGS = ${CFLAGS} \$(WARN)
+ CC = $(tc-getCC)
+ EOF
+
+ sed \
+ -e 's|theseus:|theseus: libs|g' \
+ -e '/-o theseus/s:$(CC):$(CC) ${LDFLAGS}:g' \
+ -i Makefile || die
+
+ sed \
+ -e 's:/usr/bin/sed:sed:g' \
+ -e "s:/usr/local/bin/:${EPREFIX}/usr/bin/:g" \
+ -e "s:/usr/bin/:${EPREFIX}/usr/bin/:g" \
+ -i theseus_align || die
+}
+
+src_install() {
+ dobin theseus theseus_align
+ dodoc theseus_man.pdf README AUTHORS
+ use examples && insinto /usr/share/${PN} && doins -r examples
+}