summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-19 08:39:18 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-19 08:39:18 +0000
commitaf405d44078f861c4ec9d79fe077208347b9bb81 (patch)
tree623de7906a31bd287f1ab599a02f30ef7e844860 /sci-chemistry/pymol
parentMask pg pre-releases. (diff)
downloadgentoo-2-af405d44078f861c4ec9d79fe077208347b9bb81.tar.gz
gentoo-2-af405d44078f861c4ec9d79fe077208347b9bb81.tar.bz2
gentoo-2-af405d44078f861c4ec9d79fe077208347b9bb81.zip
Cleaned old revisions, fixed usage of distutils.eclass at EAPI=3, multiple python version support, Using eclasses w/o proper documentation sucks
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'sci-chemistry/pymol')
-rw-r--r--sci-chemistry/pymol/ChangeLog9
-rw-r--r--sci-chemistry/pymol/pymol-1.2.2-r1.ebuild99
-rw-r--r--sci-chemistry/pymol/pymol-1.2.2-r4.ebuild (renamed from sci-chemistry/pymol/pymol-1.2.2-r3.ebuild)22
3 files changed, 20 insertions, 110 deletions
diff --git a/sci-chemistry/pymol/ChangeLog b/sci-chemistry/pymol/ChangeLog
index e729b1d1bec4..8334d17fb0b8 100644
--- a/sci-chemistry/pymol/ChangeLog
+++ b/sci-chemistry/pymol/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/pymol
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.55 2010/02/18 13:23:48 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.56 2010/02/19 08:39:18 jlec Exp $
+
+*pymol-1.2.2-r4 (19 Feb 2010)
+
+ 19 Feb 2010; Justin Lecher (jlec) <jlec@j-schmitz.net>
+ -pymol-1.2.2-r1.ebuild, -pymol-1.2.2-r3.ebuild, +pymol-1.2.2-r4.ebuild:
+ Cleaned old revisions, fixed usage of distutils.eclass at EAPI=3, multiple
+ python version support
*pymol-1.2.2-r3 (18 Feb 2010)
diff --git a/sci-chemistry/pymol/pymol-1.2.2-r1.ebuild b/sci-chemistry/pymol/pymol-1.2.2-r1.ebuild
deleted file mode 100644
index 42de6e04825c..000000000000
--- a/sci-chemistry/pymol/pymol-1.2.2-r1.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-1.2.2-r1.ebuild,v 1.3 2010/02/06 15:26:35 pva Exp $
-
-EAPI="2"
-
-inherit eutils distutils
-
-PYTHON_MODNAME="chempy pmg_tk pymol"
-REV="3859"
-
-DESCRIPTION="A Python-extensible molecular graphics system."
-HOMEPAGE="http://pymol.sourceforge.net/"
-SRC_URI="http://pymol.svn.sourceforge.net/viewvc/pymol/trunk/pymol.tar.gz?view=tar&pathrev=${REV} -> ${P}.tar.gz"
-
-LICENSE="PSF-2.2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="apbs numpy shaders vmd"
-
-DEPEND=">=dev-lang/python-2.4[tk]
- dev-python/numpy
- dev-python/pmw
- media-libs/freetype:2
- media-libs/libpng
- media-video/mpeg-tools
- sys-libs/zlib
- virtual/glut
- apbs? (
- dev-libs/maloc
- sci-chemistry/apbs
- sci-chemistry/pdb2pqr
- sci-chemistry/pymol-apbs-plugin
- )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}"/${PN}
-
-pkg_setup(){
- python_version
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/1.2.1/${PN}-1.2.1-data-path.patch \
- || die "Failed to apply data-path.patch"
-
- # Turn off splash screen. Please do make a project contribution
- # if you are able though. #299020
- epatch "${FILESDIR}"/1.2.1/nosplash-gentoo.patch
-
- # Respect CFLAGS
- sed -i \
- -e "s:\(ext_comp_args=\).*:\1[]:g" \
- "${S}"/setup.py || die "Failed running sed on setup.py"
-
- use shaders && epatch "${FILESDIR}"/${P}-shaders.patch
-
- use vmd && epatch "${FILESDIR}"/${P}-vmd.patch
-
- use numpy && \
- sed \
- -e '/PYMOL_NUMPY/s:^#::g' \
- -i setup.py
-}
-
-src_configure() {
- :
-}
-
-src_install() {
- distutils_src_install
-
- # These environment variables should not go in the wrapper script, or else
- # it will be impossible to use the PyMOL libraries from Python.
- cat >> "${T}"/20pymol <<- EOF
- PYMOL_PATH=$(python_get_sitedir)/${PN}
- PYMOL_DATA="/usr/share/pymol/data"
- PYMOL_SCRIPTS="/usr/share/pymol/scripts"
- EOF
-
- doenvd "${T}"/20pymol || die "Failed to install env.d file."
-
- cat >> "${T}"/pymol <<- EOF
- #!/bin/sh
- ${python} -O \${PYMOL_PATH}/__init__.py \$*
- EOF
-
- dobin "${T}"/pymol || die "Failed to install wrapper."
-
- insinto /usr/share/pymol
- doins -r test data scripts || die "no shared data"
-
- insinto /usr/share/pymol/examples
- doins -r examples || die "Failed to install docs."
-
- dodoc DEVELOPERS README || die "Failed to install docs."
-
- rm "${D}"$(python_get_sitedir)/pmg_tk/startup/apbs_tools.py
-}
diff --git a/sci-chemistry/pymol/pymol-1.2.2-r3.ebuild b/sci-chemistry/pymol/pymol-1.2.2-r4.ebuild
index e480beed14b6..5505a602c592 100644
--- a/sci-chemistry/pymol/pymol-1.2.2-r3.ebuild
+++ b/sci-chemistry/pymol/pymol-1.2.2-r4.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-1.2.2-r3.ebuild,v 1.1 2010/02/18 13:23:48 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-1.2.2-r4.ebuild,v 1.1 2010/02/19 08:39:18 jlec Exp $
EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
PYTHON_USE_WITH="tk"
-PYTHON_DEPEND="2:2.5"
-PYTHON_MODNAME="chempy pmg_tk pymol"
REV="3859"
inherit eutils distutils prefix
@@ -35,13 +34,10 @@ DEPEND="
sci-chemistry/pymol-apbs-plugin
)"
RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.* 2.4"
S="${WORKDIR}"/${PN}
-pkg_setup() {
- python_set_active_version 2
-}
-
src_prepare() {
epatch "${FILESDIR}"/${PV}-data-path.patch
@@ -65,6 +61,12 @@ src_prepare() {
sed \
-e '/PYMOL_NUMPY/s:^#::g' \
-i setup.py
+
+ rm ./modules/pmg_tk/startup/apbs_tools.py || die
+
+ # python 3.* fix
+ # sed '452,465d' -i setup.py
+ distutils_src_prepare
}
src_configure() {
@@ -77,7 +79,7 @@ src_install() {
# These environment variables should not go in the wrapper script, or else
# it will be impossible to use the PyMOL libraries from Python.
cat >> "${T}"/20pymol <<- EOF
- PYMOL_PATH="${EPREFIX}/$(python_get_sitedir)/${PN}"
+ PYMOL_PATH="${EPREFIX}/$(python_get_sitedir -f)/${PN}"
PYMOL_DATA="${EPREFIX}/usr/share/pymol/data"
PYMOL_SCRIPTS="${EPREFIX}/usr/share/pymol/scripts"
EOF
@@ -86,7 +88,7 @@ src_install() {
cat >> "${T}"/pymol <<- EOF
#!/bin/sh
- $(PYTHON -A -a) -O \${PYMOL_PATH}/__init__.py \$*
+ $(PYTHON -f) -O \${PYMOL_PATH}/__init__.py \$*
EOF
dobin "${T}"/pymol || die "Failed to install wrapper."
@@ -99,5 +101,5 @@ src_install() {
dodoc DEVELOPERS README || die "Failed to install docs."
- rm "${D}"$(python_get_sitedir)/pmg_tk/startup/apbs_tools.py
+# rm "${D}"$(python_get_sitedir)/pmg_tk/startup/apbs_tools.py
}