summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-10 11:22:35 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-10 11:22:35 +0000
commit4f27d63f20af7ad94647ccd7971867396d93d777 (patch)
tree5ca96522fa6fd9db909336d7bc08c4b45139cf36 /sci-chemistry/pymol
parentVersion bump wrt #300556, thanks to Jeroen Roovers for reporting. (diff)
downloadgentoo-2-4f27d63f20af7ad94647ccd7971867396d93d777.tar.gz
gentoo-2-4f27d63f20af7ad94647ccd7971867396d93d777.tar.bz2
gentoo-2-4f27d63f20af7ad94647ccd7971867396d93d777.zip
Fixing PYMOL_DATA again per 304259
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'sci-chemistry/pymol')
-rw-r--r--sci-chemistry/pymol/ChangeLog8
-rw-r--r--sci-chemistry/pymol/files/1.2.2-data-path.patch75
-rw-r--r--sci-chemistry/pymol/pymol-1.2.2-r2.ebuild99
3 files changed, 181 insertions, 1 deletions
diff --git a/sci-chemistry/pymol/ChangeLog b/sci-chemistry/pymol/ChangeLog
index 29a9fa740110..b5d58281abc3 100644
--- a/sci-chemistry/pymol/ChangeLog
+++ b/sci-chemistry/pymol/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/pymol
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.53 2010/02/06 15:26:35 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.54 2010/02/10 11:22:34 jlec Exp $
+
+*pymol-1.2.2-r2 (10 Feb 2010)
+
+ 10 Feb 2010; Justin Lecher (jlec) <jlec@j-schmitz.net>
+ +files/1.2.2-data-path.patch, +pymol-1.2.2-r2.ebuild:
+ Fixing PYMOL_DATA again per 304259
06 Feb 2010; Peter Volkov <pva@gentoo.org> pymol-1.2.1.ebuild,
pymol-1.2.2.ebuild, pymol-1.2.2-r1.ebuild:
diff --git a/sci-chemistry/pymol/files/1.2.2-data-path.patch b/sci-chemistry/pymol/files/1.2.2-data-path.patch
new file mode 100644
index 000000000000..cf1bf59af0c6
--- /dev/null
+++ b/sci-chemistry/pymol/files/1.2.2-data-path.patch
@@ -0,0 +1,75 @@
+Index: modules/pymol/importing.py
+===================================================================
+--- modules/pymol/importing.py (revision 3889)
++++ modules/pymol/importing.py (working copy)
+@@ -191,7 +191,7 @@
+ '''
+ r = DEFAULT_ERROR
+
+- tables = { 'cmyk' : "$PYMOL_PATH/data/pymol/cmyk.png",
++ tables = { 'cmyk' : "$PYMOL_DATA/pymol/cmyk.png",
+ 'pymol' : 'pymol',
+ 'rgb' : 'rgb',
+ 'greyscale': 'greyscale' }
+Index: modules/pymol/wizard/mutagenesis.py
+===================================================================
+--- modules/pymol/wizard/mutagenesis.py (revision 3889)
++++ modules/pymol/wizard/mutagenesis.py (working copy)
+@@ -53,8 +53,8 @@
+
+ self.dep = default_dep
+
+- self.ind_library = io.pkl.fromFile(os.environ['PYMOL_PATH']+
+- "/data/chempy/sidechains/sc_bb_ind.pkl")
++ self.ind_library = io.pkl.fromFile(os.environ['PYMOL_DATA']+
++ "/chempy/sidechains/sc_bb_ind.pkl")
+ self.load_library()
+ self.status = 0 # 0 no selection, 1 mutagenizing
+ self.bump_check = 1
+@@ -218,8 +218,8 @@
+ def load_library(self):
+ if self.dep == 'dep':
+ if not hasattr(self,'dep_library'):
+- self.dep_library = io.pkl.fromFile(os.environ['PYMOL_PATH']+
+- "/data/chempy/sidechains/sc_bb_dep.pkl")
++ self.dep_library = io.pkl.fromFile(os.environ['PYMOL_DATA']+
++ "/chempy/sidechains/sc_bb_dep.pkl")
+
+ def set_mode(self,mode):
+ cmd=self.cmd
+Index: modules/pymol/commanding.py
+===================================================================
+--- modules/pymol/commanding.py (revision 3889)
++++ modules/pymol/commanding.py (working copy)
+@@ -219,11 +219,11 @@
+ _self.unlock(0,_self)
+ r = DEFAULT_SUCCESS
+ if show_splash==1: # generic / open-source
+- png_path = _self.exp_path("$PYMOL_PATH/data/pymol/splash.png")
++ png_path = _self.exp_path("$PYMOL_DATA/pymol/splash.png")
+ elif show_splash==2: # evaluation builds
+- png_path = _self.exp_path("$PYMOL_PATH/data/pymol/epymol.png")
++ png_path = _self.exp_path("$PYMOL_DATA/pymol/epymol.png")
+ else: # incentive builds
+- png_path = _self.exp_path("$PYMOL_PATH/data/pymol/ipymol.png")
++ png_path = _self.exp_path("$PYMOL_DATA/pymol/ipymol.png")
+ if os.path.exists(png_path):
+ _self.do("_ cmd.load_png('%s',0,quiet=1)"%png_path)
+ else:
+Index: modules/chempy/tinker/__init__.py
+===================================================================
+--- modules/chempy/tinker/__init__.py (revision 3889)
++++ modules/chempy/tinker/__init__.py (working copy)
+@@ -145,9 +145,9 @@
+ bin_path = ''
+ params_path = ''
+
+-if os.environ.has_key('PYMOL_PATH'):
+- pymol_path = os.environ['PYMOL_PATH']
+- test_path = pymol_path + '/data/chempy/tinker/'
++if os.environ.has_key('PYMOL_DATA'):
++ pymol_path = os.environ['PYMOL_DATA']
++ test_path = pymol_path + '/chempy/tinker/'
+ if os.path.exists(test_path):
+ params_path = test_path
+
diff --git a/sci-chemistry/pymol/pymol-1.2.2-r2.ebuild b/sci-chemistry/pymol/pymol-1.2.2-r2.ebuild
new file mode 100644
index 000000000000..d62ccb3dd719
--- /dev/null
+++ b/sci-chemistry/pymol/pymol-1.2.2-r2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-1.2.2-r2.ebuild,v 1.1 2010/02/10 11:22:34 jlec Exp $
+
+EAPI="2"
+
+inherit eutils distutils
+
+PYTHON_MODNAME="chempy pmg_tk pymol"
+REV="3859"
+
+DESCRIPTION="A Python-extensible molecular graphics system."
+HOMEPAGE="http://pymol.sourceforge.net/"
+SRC_URI="http://pymol.svn.sourceforge.net/viewvc/pymol/trunk/pymol.tar.gz?view=tar&pathrev=${REV} -> ${P}.tar.gz"
+
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="apbs numpy shaders vmd"
+
+DEPEND=">=dev-lang/python-2.4[tk]
+ dev-python/numpy
+ dev-python/pmw
+ media-libs/freetype:2
+ media-libs/libpng
+ media-video/mpeg-tools
+ sys-libs/zlib
+ virtual/glut
+ apbs? (
+ dev-libs/maloc
+ sci-chemistry/apbs
+ sci-chemistry/pdb2pqr
+ sci-chemistry/pymol-apbs-plugin
+ )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}
+
+pkg_setup(){
+ python_version
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-data-path.patch \
+ || die "Failed to apply data-path.patch"
+
+ # Turn off splash screen. Please do make a project contribution
+ # if you are able though. #299020
+ epatch "${FILESDIR}"/1.2.1/nosplash-gentoo.patch
+
+ # Respect CFLAGS
+ sed -i \
+ -e "s:\(ext_comp_args=\).*:\1[]:g" \
+ "${S}"/setup.py || die "Failed running sed on setup.py"
+
+ use shaders && epatch "${FILESDIR}"/${P}-shaders.patch
+
+ use vmd && epatch "${FILESDIR}"/${P}-vmd.patch
+
+ use numpy && \
+ sed \
+ -e '/PYMOL_NUMPY/s:^#::g' \
+ -i setup.py
+}
+
+src_configure() {
+ :
+}
+
+src_install() {
+ distutils_src_install
+
+ # These environment variables should not go in the wrapper script, or else
+ # it will be impossible to use the PyMOL libraries from Python.
+ cat >> "${T}"/20pymol <<- EOF
+ PYMOL_PATH=$(python_get_sitedir)/${PN}
+ PYMOL_DATA="/usr/share/pymol/data"
+ PYMOL_SCRIPTS="/usr/share/pymol/scripts"
+ EOF
+
+ doenvd "${T}"/20pymol || die "Failed to install env.d file."
+
+ cat >> "${T}"/pymol <<- EOF
+ #!/bin/sh
+ ${python} -O \${PYMOL_PATH}/__init__.py \$*
+ EOF
+
+ dobin "${T}"/pymol || die "Failed to install wrapper."
+
+ insinto /usr/share/pymol
+ doins -r test data scripts || die "no shared data"
+
+ insinto /usr/share/pymol/examples
+ doins -r examples || die "Failed to install docs."
+
+ dodoc DEVELOPERS README || die "Failed to install docs."
+
+ rm "${D}"$(python_get_sitedir)/pmg_tk/startup/apbs_tools.py
+}