summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-20 12:16:49 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-20 12:16:49 +0000
commit235a306a4536c163d60efcf75b2efbaff92e2310 (patch)
treed91b24dbf4b5cfe67473b1f116cb025d6967e3e8 /sci-chemistry/pymol-plugins-promol
parentamd64/x86 stable wrt #300393 (diff)
downloadgentoo-2-235a306a4536c163d60efcf75b2efbaff92e2310.tar.gz
gentoo-2-235a306a4536c163d60efcf75b2efbaff92e2310.tar.bz2
gentoo-2-235a306a4536c163d60efcf75b2efbaff92e2310.zip
ProMol plugin for pymol, grep from #209970
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/pymol-plugins-promol')
-rw-r--r--sci-chemistry/pymol-plugins-promol/ChangeLog10
-rw-r--r--sci-chemistry/pymol-plugins-promol/metadata.xml7
-rw-r--r--sci-chemistry/pymol-plugins-promol/pymol-plugins-promol-3.0.2.ebuild61
3 files changed, 78 insertions, 0 deletions
diff --git a/sci-chemistry/pymol-plugins-promol/ChangeLog b/sci-chemistry/pymol-plugins-promol/ChangeLog
new file mode 100644
index 000000000000..2aee65bc6438
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-promol/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/pymol-plugins-promol
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-promol/ChangeLog,v 1.1 2010/02/20 12:16:49 jlec Exp $
+
+*pymol-plugins-promol-3.0.2 (20 Feb 2010)
+
+ 20 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +pymol-plugins-promol-3.0.2.ebuild, +metadata.xml:
+ ProMol plugin for pymol, grep from #209970
+
diff --git a/sci-chemistry/pymol-plugins-promol/metadata.xml b/sci-chemistry/pymol-plugins-promol/metadata.xml
new file mode 100644
index 000000000000..6a31e9c8fbf2
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-promol/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<pkgmetadata>
+ <herd>no-herd</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/pymol-plugins-promol/pymol-plugins-promol-3.0.2.ebuild b/sci-chemistry/pymol-plugins-promol/pymol-plugins-promol-3.0.2.ebuild
new file mode 100644
index 000000000000..8440d2b1d006
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-promol/pymol-plugins-promol-3.0.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-promol/pymol-plugins-promol-3.0.2.ebuild,v 1.1 2010/02/20 12:16:49 jlec Exp $
+
+EAPI="3"
+
+SUPPORT_PYTHON_ABIS="1"
+
+inherit python
+
+DESCRIPTION="Fast and accurate regognition of active sites"
+HOMEPAGE="http://www.rit.edu/cos/ezviz/ProMOL_dl.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+LICENSE="as-is"
+IUSE=""
+
+RDEPEND="
+ sci-chemistry/pymol
+ dev-python/pmw"
+DEPEND=""
+
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+src_prepare() {
+ python_copy_sources --no-link
+ preparation() {
+ sed -e "s:./modules/pmg_tk/startup:$(python_get_sitedir)/pmg_tk/startup/ProMol:g" -i ProMOL_302.py
+ }
+ python_execute_function -s preparation
+}
+
+src_install(){
+ installation() {
+ insinto $(python_get_sitedir)/pmg_tk/startup/ProMol/
+ doins -r PDB_List AminoPics Motifs *GIF pdb_entry_type.txt Master.txt Scripts || die
+ insinto $(python_get_sitedir)/pmg_tk/startup/
+ doins *.py || die
+ dosym ../../../../../../share/doc/${PF}/html/Help \
+ $(python_get_sitedir)/pmg_tk/startup/ProMol/Help || die
+ dosym ../../../../../../share/doc/${PF}/html/Thanks.html \
+ $(python_get_sitedir)/pmg_tk/startup/ProMol/Thanks.html || die
+ dosym ../../../../../../share/doc/${PF}/html/EDMHelp.htm \
+ $(python_get_sitedir)/pmg_tk/startup/ProMol/EDMHelp.htm || die
+ }
+ python_execute_function -s installation
+
+ dodoc *doc || die
+ dohtml -r Thanks.html EDMHelp.htm Help
+}
+
+pkg_postinst(){
+ python_mod_optimize pmg_tk/startup/
+}
+
+pkg_postrm() {
+ python_mod_cleanup pmg_tk/startup/
+}
+