summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-18 10:22:58 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-18 10:22:58 +0000
commitc8ffcbf56f121a77dd4b725ea193362a5cf7195a (patch)
tree7bbc7b4a33091b25b1755dd2ac33f97f6b662102 /sci-chemistry/pymol-plugins-caver
parentFix slot-deps on gtk+ and other libs (diff)
downloadgentoo-2-c8ffcbf56f121a77dd4b725ea193362a5cf7195a.tar.gz
gentoo-2-c8ffcbf56f121a77dd4b725ea193362a5cf7195a.tar.bz2
gentoo-2-c8ffcbf56f121a77dd4b725ea193362a5cf7195a.zip
Moved from sci-chemistry/caver to sci-chemistry/pymol-plugins-caver, Version Bump
(Portage version: 2.2.0_alpha27/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/pymol-plugins-caver')
-rw-r--r--sci-chemistry/pymol-plugins-caver/ChangeLog13
-rw-r--r--sci-chemistry/pymol-plugins-caver/metadata.xml5
-rw-r--r--sci-chemistry/pymol-plugins-caver/pymol-plugins-caver-2.1.1.ebuild66
-rw-r--r--sci-chemistry/pymol-plugins-caver/pymol-plugins-caver-2.1.2.ebuild66
4 files changed, 150 insertions, 0 deletions
diff --git a/sci-chemistry/pymol-plugins-caver/ChangeLog b/sci-chemistry/pymol-plugins-caver/ChangeLog
new file mode 100644
index 000000000000..b41e77a946b0
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-caver/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for sci-chemistry/pymol-plugins-caver
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-caver/ChangeLog,v 1.1 2011/03/18 10:22:58 jlec Exp $
+
+*pymol-plugins-caver-2.1.2 (18 Mar 2011)
+*pymol-plugins-caver-2.1.1 (18 Mar 2011)
+
+ 18 Mar 2011; Justin Lecher <jlec@gentoo.org>
+ +pymol-plugins-caver-2.1.1.ebuild, +pymol-plugins-caver-2.1.2.ebuild,
+ +metadata.xml:
+ Moved from sci-chemistry/caver to sci-chemistry/pymol-plugins-caver, Version
+ Bump
+
diff --git a/sci-chemistry/pymol-plugins-caver/metadata.xml b/sci-chemistry/pymol-plugins-caver/metadata.xml
new file mode 100644
index 000000000000..9ac9ffdb3a41
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-caver/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+</pkgmetadata>
diff --git a/sci-chemistry/pymol-plugins-caver/pymol-plugins-caver-2.1.1.ebuild b/sci-chemistry/pymol-plugins-caver/pymol-plugins-caver-2.1.1.ebuild
new file mode 100644
index 000000000000..7e044a08f28f
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-caver/pymol-plugins-caver-2.1.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-caver/pymol-plugins-caver-2.1.1.ebuild,v 1.1 2011/03/18 10:22:58 jlec Exp $
+
+EAPI="3"
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit multilib python eutils versionator java-utils-2
+
+MY_PV="$(replace_all_version_separators _)"
+MY_P="Caver${MY_PV}_pymol_plugin"
+
+DESCRIPTION="Calculation of pathways from buried cavities to outside solvent in protein structures"
+HOMEPAGE="http://loschmidt.chemi.muni.cz/caver/"
+SRC_URI="${MY_P}.zip"
+
+LICENSE="CAVER"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.6
+ sci-chemistry/pymol"
+DEPEND="app-arch/unzip"
+
+RESTRICT="fetch"
+
+S="${WORKDIR}/${MY_P}"/linux_mac
+
+pkg_nofetch() {
+ elog "Download ${A}"
+ elog "from ${HOMEPAGE}. This requires registration."
+ elog "Place tarballs in ${DISTDIR}."
+}
+
+src_prepare() {
+ python_copy_sources
+}
+
+src_install() {
+ java-pkg_dojar Caver${MY_PV}/*.jar
+
+ java-pkg_jarinto /usr/share/${PN}/lib/lib/
+ java-pkg_dojar Caver${MY_PV}/lib/*.jar
+
+ installation() {
+ sed \
+ -e "s:directory/where/jar/with/plugin/is/located:${EPREFIX}/usr/share/${PN}/lib/:g" \
+ -i Caver${MY_PV}.py || die
+
+ insinto $(python_get_sitedir)/pmg_tk/startup/
+ doins Caver${MY_PV}.py || die
+ }
+ python_execute_function -s installation
+}
+
+pkg_postinst() {
+ python_mod_optimize pmg_tk/startup/Caver${MY_PV}.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup pmg_tk/startup/Caver${MY_PV}.py
+}
diff --git a/sci-chemistry/pymol-plugins-caver/pymol-plugins-caver-2.1.2.ebuild b/sci-chemistry/pymol-plugins-caver/pymol-plugins-caver-2.1.2.ebuild
new file mode 100644
index 000000000000..87f97bb1cf2d
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-caver/pymol-plugins-caver-2.1.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-caver/pymol-plugins-caver-2.1.2.ebuild,v 1.1 2011/03/18 10:22:58 jlec Exp $
+
+EAPI="3"
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit multilib python eutils versionator java-utils-2
+
+MY_PV="$(replace_all_version_separators _)"
+MY_P="Caver${MY_PV}_pymol_plugin"
+
+DESCRIPTION="Calculation of pathways from buried cavities to outside solvent in protein structures"
+HOMEPAGE="http://loschmidt.chemi.muni.cz/caver/"
+SRC_URI="${MY_P}.zip"
+
+LICENSE="CAVER"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.6
+ sci-chemistry/pymol"
+DEPEND="app-arch/unzip"
+
+RESTRICT="fetch"
+
+S="${WORKDIR}/${MY_P}"/linux_mac
+
+pkg_nofetch() {
+ elog "Download ${A}"
+ elog "from ${HOMEPAGE}. This requires registration."
+ elog "Place tarballs in ${DISTDIR}."
+}
+
+src_prepare() {
+ python_copy_sources
+}
+
+src_install() {
+ java-pkg_dojar Caver${MY_PV}/*.jar
+
+ java-pkg_jarinto /usr/share/${PN}/lib/lib/
+ java-pkg_dojar Caver${MY_PV}/lib/*.jar
+
+ installation() {
+ sed \
+ -e "s:directory/where/jar/with/plugin/is/located:${EPREFIX}/usr/share/${PN}/lib/:g" \
+ -i Caver${MY_PV}.py || die
+
+ insinto $(python_get_sitedir)/pmg_tk/startup/
+ doins Caver${MY_PV}.py || die
+ }
+ python_execute_function -s installation
+}
+
+pkg_postinst() {
+ python_mod_optimize pmg_tk/startup/Caver${MY_PV}.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup pmg_tk/startup/Caver${MY_PV}.py
+}