summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-11 20:26:16 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-11 20:26:16 +0000
commit7b13c8ae1145385d0cb8ad4fd6239824e0d8f8ee (patch)
treeb073c2b6213ce4478f7edd1881896e377cc99b51 /sci-chemistry/pymol-apbs-plugin
parentStable for HPPA (bug #288656). (diff)
downloadgentoo-2-7b13c8ae1145385d0cb8ad4fd6239824e0d8f8ee.tar.gz
gentoo-2-7b13c8ae1145385d0cb8ad4fd6239824e0d8f8ee.tar.bz2
gentoo-2-7b13c8ae1145385d0cb8ad4fd6239824e0d8f8ee.zip
Version Bump, EAPI=3 and multiple python versions support
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/pymol-apbs-plugin')
-rw-r--r--sci-chemistry/pymol-apbs-plugin/ChangeLog8
-rw-r--r--sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p15.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/sci-chemistry/pymol-apbs-plugin/ChangeLog b/sci-chemistry/pymol-apbs-plugin/ChangeLog
index 3cc02c017335..98c110499156 100644
--- a/sci-chemistry/pymol-apbs-plugin/ChangeLog
+++ b/sci-chemistry/pymol-apbs-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/pymol-apbs-plugin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-apbs-plugin/ChangeLog,v 1.1 2010/02/01 21:40:04 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-apbs-plugin/ChangeLog,v 1.2 2010/02/11 20:26:16 jlec Exp $
+
+*pymol-apbs-plugin-0_p15 (11 Feb 2010)
+
+ 11 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +pymol-apbs-plugin-0_p15.ebuild:
+ Version Bump, EAPI=3 and multiple python support
*pymol-apbs-plugin-0_p11 (01 Feb 2010)
diff --git a/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p15.ebuild b/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p15.ebuild
new file mode 100644
index 000000000000..3f195533f330
--- /dev/null
+++ b/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p15.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p15.ebuild,v 1.1 2010/02/11 20:26:16 jlec Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit python
+
+MY_PV="${PV##*_p}"
+
+DESCRIPTION="APBS plugin for pymol"
+HOMEPAGE="http://sourceforge.net/projects/pymolapbsplugin/"
+SRC_URI="http://pymolapbsplugin.svn.sourceforge.net/viewvc/pymolapbsplugin/trunk/src/apbsplugin.py?revision=${MY_PV} -> ${P}.py"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="pymol"
+IUSE=""
+
+RDEPEND="
+ sci-chemistry/apbs
+ sci-chemistry/pdb2pqr
+ !<sci-chemistry/pymol-1.2.2-r1"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ mkdir "${S}"
+ cp "${DISTDIR}"/${P}.py "${S}"/
+ python_copy_sources --no-link
+}
+
+src_install() {
+ installation() {
+ sed \
+ -e "s:^APBS_BINARY_LOCATION.*:APBS_BINARY_LOCATION = \"${EPREFIX}/usr/bin/apbs\":g" \
+ -e "s:^APBS_PSIZE_LOCATION.*:APBS_PSIZE_LOCATION = \"${EPREFIX}/$(python_get_sitedir)/pdb2pqr/src/\":g" \
+ -e "s:^APBS_PDB2PQR_LOCATION.*:APBS_PDB2PQR_LOCATION = \"${EPREFIX}/$(python_get_sitedir)/pdb2pqr/\":g" \
+ -e "s:^TEMPORARY_FILE_DIR.*:TEMPORARY_FILE_DIR = \"./\":g" \
+ -i ${P}.py
+
+ insinto $(python_get_sitedir)/pmg_tk/startup/
+ newins ${P}.py apbs_tools.py || die
+ }
+ python_execute_function -s installation
+}
+
+pkg_postinst() {
+ python_mod_optimize pmg_tk/startup/apbs_tools.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup pmg_tk/startup/apbs_tools.py
+}