summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-04-16 08:41:10 +0000
committerJustin Lecher <jlec@gentoo.org>2013-04-16 08:41:10 +0000
commit225bbb64817ced2ccacb67c39d899a631aef0cbe (patch)
tree8b1000c3432502fe217624b8cda075cd9a2c572a /sci-chemistry/pdb-tools
parentBump (diff)
downloadgentoo-2-225bbb64817ced2ccacb67c39d899a631aef0cbe.tar.gz
gentoo-2-225bbb64817ced2ccacb67c39d899a631aef0cbe.tar.bz2
gentoo-2-225bbb64817ced2ccacb67c39d899a631aef0cbe.zip
sci-chemistry/pdb-tools: Move to new python eclass
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-chemistry/pdb-tools')
-rw-r--r--sci-chemistry/pdb-tools/ChangeLog10
-rw-r--r--sci-chemistry/pdb-tools/metadata.xml14
-rw-r--r--sci-chemistry/pdb-tools/pdb-tools-0.1.4-r4.ebuild64
3 files changed, 79 insertions, 9 deletions
diff --git a/sci-chemistry/pdb-tools/ChangeLog b/sci-chemistry/pdb-tools/ChangeLog
index 757fe8c0c3b9..bf641223c83c 100644
--- a/sci-chemistry/pdb-tools/ChangeLog
+++ b/sci-chemistry/pdb-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/pdb-tools
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb-tools/ChangeLog,v 1.8 2012/10/19 10:11:54 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb-tools/ChangeLog,v 1.9 2013/04/16 08:41:10 jlec Exp $
+
+*pdb-tools-0.1.4-r4 (16 Apr 2013)
+
+ 16 Apr 2013; Justin Lecher <jlec@gentoo.org> +pdb-tools-0.1.4-r4.ebuild,
+ metadata.xml:
+ Move to new python eclass
19 Oct 2012; Justin Lecher <jlec@gentoo.org> pdb-tools-0.1.4-r3.ebuild:
Remove virtual/fortran and always call fortran-2_pkg_setup as intend by the
diff --git a/sci-chemistry/pdb-tools/metadata.xml b/sci-chemistry/pdb-tools/metadata.xml
index 7671091aa280..13e9a3c93979 100644
--- a/sci-chemistry/pdb-tools/metadata.xml
+++ b/sci-chemistry/pdb-tools/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-chemistry</herd>
- <maintainer>
- <email>jlec@gentoo.org</email>
- </maintainer>
- <upstream>
- <remote-id type="google-code">pdb-tools</remote-id>
- </upstream>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">pdb-tools</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/sci-chemistry/pdb-tools/pdb-tools-0.1.4-r4.ebuild b/sci-chemistry/pdb-tools/pdb-tools-0.1.4-r4.ebuild
new file mode 100644
index 000000000000..67ab5082e64e
--- /dev/null
+++ b/sci-chemistry/pdb-tools/pdb-tools-0.1.4-r4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb-tools/pdb-tools-0.1.4-r4.ebuild,v 1.1 2013/04/16 08:41:10 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} pypy{1_8,1_9} )
+
+inherit fortran-2 python-r1 toolchain-funcs
+
+DESCRIPTION="Tools for manipulating and doing calculations on wwPDB macromolecule structure files"
+HOMEPAGE="http://code.google.com/p/pdb-tools/"
+SRC_URI="http://${PN}.googlecode.com/files/${PN}_${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="sci-chemistry/dssp"
+DEPEND=""
+
+S="${WORKDIR}"/${PN}_${PV}
+
+src_prepare() {
+ sed \
+ -e "s:script_dir,\"pdb_data\":\"${EPREFIX}/usr/share/${PN}\",\"pdb_data\":g" \
+ -i pdb_sasa.py || die
+ sed \
+ -e "/satk_path =/s:^.*$:satk_path = \"${EPREFIX}/usr/bin\":g" \
+ -i pdb_satk.py || die
+}
+
+src_compile() {
+ mkdir bin
+ cd satk
+ for i in *.f; do
+ einfo "$(tc-getFC) ${FFLAGS} ${LDFLAGS} ${i} -o ${i/.f}"
+ $(tc-getFC) ${FFLAGS} -c ${i} -o ${i/.f/.o} || die
+ $(tc-getFC) ${LDFLAGS} -o ../bin/${i/.f} ${i/.f/.o} || die
+ sed \
+ -e "s:${i/.f}.out:${i/.f}:g" \
+ -i ../pdb_satk.py || die
+ done
+}
+
+src_install() {
+ local script
+ insinto /usr/share/${PN}
+ doins -r pdb_data/peptides
+ rm -rf pdb_data/peptides || die
+
+ for script in pdb_*.py; do
+ python_foreach_impl python_newscript ${script} ${script%.py}
+ done
+
+ python_foreach_impl python_domodule helper pdb_data
+
+ python_moduleinto ${PN}
+ python_foreach_impl python_domodule *.py
+
+ dobin bin/*
+ dodoc README
+}