summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-20 20:31:36 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-20 20:31:36 +0000
commit84b06e0ccba9bb8fb55d4c08681a27a5ddf6363b (patch)
treed98c26810281de191a52c5e4628374088f4f872b /sci-chemistry/openbabel
parentsci-chemistry/pynmr removal 316181 (diff)
downloadgentoo-2-84b06e0ccba9bb8fb55d4c08681a27a5ddf6363b.tar.gz
gentoo-2-84b06e0ccba9bb8fb55d4c08681a27a5ddf6363b.tar.bz2
gentoo-2-84b06e0ccba9bb8fb55d4c08681a27a5ddf6363b.zip
Fixed byte-compilation, thanks Arfrever
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/openbabel')
-rw-r--r--sci-chemistry/openbabel/openbabel-2.2.3.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/sci-chemistry/openbabel/openbabel-2.2.3.ebuild b/sci-chemistry/openbabel/openbabel-2.2.3.ebuild
index c5b088e8b657..566e92529c5e 100644
--- a/sci-chemistry/openbabel/openbabel-2.2.3.ebuild
+++ b/sci-chemistry/openbabel/openbabel-2.2.3.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel/openbabel-2.2.3.ebuild,v 1.2 2010/05/20 20:18:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel/openbabel-2.2.3.ebuild,v 1.3 2010/05/20 20:31:36 jlec Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
SUPPORT_PYTHON_ABIS="1"
+PYTHON_MODNAME="openbabel.py pybel.py"
inherit eutils distutils
@@ -87,3 +88,11 @@ src_install() {
fi
fi
}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}