summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-05-09 15:53:32 +0000
committerJustin Lecher <jlec@gentoo.org>2011-05-09 15:53:32 +0000
commit2508f0b28bbde86892d79679db8b21d74086e7a2 (patch)
treed963a9e6bf3b0464c4e8f9d507977285456ba2b1 /sci-chemistry/openbabel-python
parentVersion bump to latest. Drop older. (diff)
downloadgentoo-2-2508f0b28bbde86892d79679db8b21d74086e7a2.tar.gz
gentoo-2-2508f0b28bbde86892d79679db8b21d74086e7a2.tar.bz2
gentoo-2-2508f0b28bbde86892d79679db8b21d74086e7a2.zip
Fix for Prefixed installation
(Portage version: 2.2.0_alpha32/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/openbabel-python')
-rw-r--r--sci-chemistry/openbabel-python/ChangeLog5
-rw-r--r--sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild8
2 files changed, 10 insertions, 3 deletions
diff --git a/sci-chemistry/openbabel-python/ChangeLog b/sci-chemistry/openbabel-python/ChangeLog
index d05dca5118be..efc5cb32f939 100644
--- a/sci-chemistry/openbabel-python/ChangeLog
+++ b/sci-chemistry/openbabel-python/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-chemistry/openbabel-python
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-python/ChangeLog,v 1.4 2011/04/28 19:21:51 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-python/ChangeLog,v 1.5 2011/05/09 15:53:32 jlec Exp $
+
+ 09 May 2011; Justin Lecher <jlec@gentoo.org> openbabel-python-2.3.0.ebuild:
+ Fix for Prefixed installation
28 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
openbabel-python-2.3.0.ebuild,
diff --git a/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild b/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild
index f9a84f636be6..908aa8427895 100644
--- a/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild
+++ b/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild,v 1.4 2011/04/28 19:21:51 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild,v 1.5 2011/05/09 15:53:32 jlec Exp $
EAPI="3"
@@ -40,5 +40,9 @@ src_prepare() {
"${FILESDIR}"/${P}-swig.patch \
"${FILESDIR}"/${P}-system_openbabel.patch
- swig -python -c++ -small -O -templatereduce -naturalvar -I/usr/include/openbabel-2.0 -o scripts/python/openbabel-python.cpp -DHAVE_EIGEN2 -outdir scripts/python scripts/openbabel-python.i || die "Regeneration of openbabel-python.cpp failed"
+ sed \
+ -e "s:/usr:${EPREFIX}/usr:g" \
+ -i ./scripts/python/setup.py || die
+
+ swig -python -c++ -small -O -templatereduce -naturalvar -I"${EPREFIX}/usr/include/openbabel-2.0" -o scripts/python/openbabel-python.cpp -DHAVE_EIGEN2 -outdir scripts/python scripts/openbabel-python.i || die "Regeneration of openbabel-python.cpp failed"
}