summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-26 15:52:07 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-26 15:52:07 +0000
commit4ea8120727f28a26f4aaf01a8deae7575803e7de (patch)
tree85341386d632aa264b8ae80087d26f2be2953754 /sci-chemistry/openbabel-perl/openbabel-perl-2.3.0.ebuild
parentDepend on virtual/ffmpeg instead of media-video/ffmpeg. (diff)
downloadgentoo-2-4ea8120727f28a26f4aaf01a8deae7575803e7de.tar.gz
gentoo-2-4ea8120727f28a26f4aaf01a8deae7575803e7de.tar.bz2
gentoo-2-4ea8120727f28a26f4aaf01a8deae7575803e7de.zip
Perl Bindings for openbabel, writing by rei4dan, #212212
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/openbabel-perl/openbabel-perl-2.3.0.ebuild')
-rw-r--r--sci-chemistry/openbabel-perl/openbabel-perl-2.3.0.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/sci-chemistry/openbabel-perl/openbabel-perl-2.3.0.ebuild b/sci-chemistry/openbabel-perl/openbabel-perl-2.3.0.ebuild
new file mode 100644
index 000000000000..41f94e0ea36c
--- /dev/null
+++ b/sci-chemistry/openbabel-perl/openbabel-perl-2.3.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-perl/openbabel-perl-2.3.0.ebuild,v 1.1 2011/03/26 15:52:07 jlec Exp $
+
+EAPI="3"
+
+inherit cmake-utils eutils perl-module
+
+DESCRIPTION="Perl bindings for OpenBabel"
+HOMEPAGE="http://openbabel.sourceforge.net/"
+SRC_URI="mirror://sourceforge/openbabel/openbabel-${PV}.tar.gz"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+RDEPEND="
+ dev-lang/perl
+ ~sci-chemistry/openbabel-${PV}"
+DEPEND="${RDEPEND}
+ =dev-lang/swig-2.0.1
+ dev-util/cmake"
+
+S="${WORKDIR}/openbabel-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_configure() {
+ local mycmakeargs="-DPERL_BINDINGS=ON"
+ mycmakeargs="${mycmakeargs}
+ -DRUN_SWIG=ON"
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cd "${WORKDIR}/${P}_build/scripts"
+ perl-module_src_prep
+ perl-module_src_compile
+}
+
+src_test() {
+ cd "${WORKDIR}/${P}_build/scripts"
+ emake test || die "make test failed"
+}
+
+src_install() {
+ cd "${WORKDIR}/${P}_build/scripts"
+ perl-module_src_install
+}
+
+pkg_preinst() {
+ perl-module_pkg_preinst
+}
+
+pkg_postinst() {
+ perl-module_pkg_postinst
+}
+
+pkg_prerm() {
+ perl-module_pkg_prerm
+}
+
+pkg_postrm() {
+ perl-module_pkg_postrm
+}