summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-07-08 06:55:29 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-07-08 06:55:29 +0000
commite4874d7962b8e106be87475315cbe90b10453886 (patch)
tree424006e42ec2e8689e70b40ec9c274d7ffe4a905 /sci-chemistry/mopac7
parentLicense for sci-chemistry/mopac7. (diff)
downloadgentoo-2-e4874d7962b8e106be87475315cbe90b10453886.tar.gz
gentoo-2-e4874d7962b8e106be87475315cbe90b10453886.tar.bz2
gentoo-2-e4874d7962b8e106be87475315cbe90b10453886.zip
Initial commit, ebuild by me. This will be useful for the new ghemical. It's a quite solid semi-empirical package.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sci-chemistry/mopac7')
-rw-r--r--sci-chemistry/mopac7/ChangeLog11
-rw-r--r--sci-chemistry/mopac7/Manifest2
-rw-r--r--sci-chemistry/mopac7/files/digest-mopac7-1.001
-rw-r--r--sci-chemistry/mopac7/metadata.xml9
-rw-r--r--sci-chemistry/mopac7/mopac7-1.00.ebuild40
5 files changed, 63 insertions, 0 deletions
diff --git a/sci-chemistry/mopac7/ChangeLog b/sci-chemistry/mopac7/ChangeLog
new file mode 100644
index 000000000000..13192061f22d
--- /dev/null
+++ b/sci-chemistry/mopac7/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-chemistry/mopac7
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/ChangeLog,v 1.1 2005/07/08 06:55:29 spyderous Exp $
+
+*mopac7-1.00 (08 Jul 2005)
+
+ 08 Jul 2005; Donnie Berkholz <spyderous@gentoo.org>; +metadata.xml,
+ +mopac7-1.00.ebuild:
+ Initial commit, ebuild by me. This will be useful for the new ghemical. It's
+ a quite solid semi-empirical package.
+
diff --git a/sci-chemistry/mopac7/Manifest b/sci-chemistry/mopac7/Manifest
new file mode 100644
index 000000000000..d08146b96442
--- /dev/null
+++ b/sci-chemistry/mopac7/Manifest
@@ -0,0 +1,2 @@
+MD5 41f69930d2c31833445a880c52fa1b48 mopac7-1.00.ebuild 1498
+MD5 87fd0c849cee4758e25fa67f07f7240e files/digest-mopac7-1.00 61
diff --git a/sci-chemistry/mopac7/files/digest-mopac7-1.00 b/sci-chemistry/mopac7/files/digest-mopac7-1.00
new file mode 100644
index 000000000000..dacf853ca0d4
--- /dev/null
+++ b/sci-chemistry/mopac7/files/digest-mopac7-1.00
@@ -0,0 +1 @@
+MD5 d556f7166bcc809dd84ee93c8d874fa2 mopac7-1.00.tgz 1184447
diff --git a/sci-chemistry/mopac7/metadata.xml b/sci-chemistry/mopac7/metadata.xml
new file mode 100644
index 000000000000..211b8bd0f0a4
--- /dev/null
+++ b/sci-chemistry/mopac7/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+<email>spyderous@gentoo.org</email>
+<name>Donnie Berkholz</name>
+</maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/mopac7/mopac7-1.00.ebuild b/sci-chemistry/mopac7/mopac7-1.00.ebuild
new file mode 100644
index 000000000000..fbeb4b783c49
--- /dev/null
+++ b/sci-chemistry/mopac7/mopac7-1.00.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/mopac7-1.00.ebuild,v 1.1 2005/07/08 06:55:29 spyderous Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Autotooled, updated version of a powerful, fast semi-empirical package"
+HOMEPAGE="http://sourceforge.net/projects/mopac7/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+LICENSE="mopac7"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lang/f2c
+ sys-devel/autoconf
+ sys-devel/automake
+ sys-devel/libtool"
+RDEPEND="dev-lang/f2c"
+
+src_compile() {
+ libtoolize --copy --force
+
+ # This is absolutely required to avoid odd errors on MAIN__() not existing
+ # and to build the mopac7 binary, not just the library.
+ einfo "Adding required LDFLAGS for configure"
+ econf LDFLAGS="-Xlinker -defsym -Xlinker MAIN__=main" || die "econf failed"
+
+ # We need the appended LDFLAGS to activate building of the mopac7 binary,
+ # but they break the actual linking of it. Something's obviously broken.
+ einfo "Removing LDFLAGS, as they break the build"
+ sed -i "/^LDFLAGS/d" src/Makefile.in
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ sed -i "s:./src/mopac7:./mopac7:g" run_mopac7
+ dobin run_mopac7 src/.libs/mopac7
+ dodoc AUTHORS README ChangeLog
+}