summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2008-07-13 20:59:11 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2008-07-13 20:59:11 +0000
commit28d38c91773a3af0fc0d9f336671fc4f0e81fc86 (patch)
tree63a49b78ccfdd4fb2b694e72ed3beda8864b152c /sci-chemistry/mopac7
parentVersion bump (diff)
downloadgentoo-2-28d38c91773a3af0fc0d9f336671fc4f0e81fc86.tar.gz
gentoo-2-28d38c91773a3af0fc0d9f336671fc4f0e81fc86.tar.bz2
gentoo-2-28d38c91773a3af0fc0d9f336671fc4f0e81fc86.zip
Fix to use gfortran
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r5 x86_64)
Diffstat (limited to 'sci-chemistry/mopac7')
-rw-r--r--sci-chemistry/mopac7/ChangeLog7
-rw-r--r--sci-chemistry/mopac7/mopac7-1.13-r1.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/sci-chemistry/mopac7/ChangeLog b/sci-chemistry/mopac7/ChangeLog
index 1aa519e2bc49..98c3075c8c64 100644
--- a/sci-chemistry/mopac7/ChangeLog
+++ b/sci-chemistry/mopac7/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/mopac7
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/ChangeLog,v 1.15 2008/07/08 06:43:37 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/ChangeLog,v 1.16 2008/07/13 20:59:11 je_fro Exp $
+
+*mopac7-1.13-r1 (13 Jul 2008)
+
+ 13 Jul 2008; Jeff Gardner <je_fro@gentoo.org> +mopac7-1.13-r1.ebuild:
+ Fix to use gfortran
*mopac7-1.13 (08 Jul 2008)
diff --git a/sci-chemistry/mopac7/mopac7-1.13-r1.ebuild b/sci-chemistry/mopac7/mopac7-1.13-r1.ebuild
new file mode 100644
index 000000000000..7a0d9ddaaf69
--- /dev/null
+++ b/sci-chemistry/mopac7/mopac7-1.13-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/mopac7-1.13-r1.ebuild,v 1.1 2008/07/13 20:59:11 je_fro Exp $
+
+WANT_AUTOMAKE="1.8"
+WANT_AUTOCONF="latest"
+
+inherit autotools
+
+DESCRIPTION="Autotooled, updated version of a powerful, fast semi-empirical package"
+HOMEPAGE="http://sourceforge.net/projects/mopac7/"
+#SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+SRC_URI="http://www.bioinformatics.org/ghemical/download/current/${P}.tar.gz"
+LICENSE="mopac7"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND=">=dev-libs/libf2c-20070912"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Install the executable
+ sed -i \
+ -e "s:noinst_PROGRAMS = mopac7:bin_PROGRAMS = mopac7:g" \
+ src/Makefile.am \
+ || die "sed failed: install mopac7"
+ # Install the script to run the executable
+ sed -i \
+ -e "s:EXTRA_DIST = run_mopac7:if HAVE_F2C\nbin_SCRIPTS = run_mopac7\nendif:g" \
+ Makefile.am \
+ || die "sed failed: install run_mopac7"
+
+ # Fix parallel build by adding internal dependency on libmopac7.la from
+ # executable
+ sed -i \
+ -e "s:mopac7_LDFLAGS = -lmopac7 -lf2c -lm:mopac7_LDFLAGS = -lf2c -lm:g" \
+ -e "s:\(mopac7_LDFLAGS.*\):\1\nmopac7_LDADD = libmopac7.la:g" \
+ src/Makefile.am \
+ || die "sed failed: fix dependencies"
+
+ # Switch to gfortran from g77.
+ sed -i \
+ -e "s:lg2c:lgfortran:" \
+ libmopac7.pc.in \
+ || die "sed failed: fix to use gfortran in libmopac7.pc.in"
+
+ eautoreconf
+}
+
+src_install() {
+ # A correct fix would have a run_mopac7.in with @bindir@ that gets
+ # replaced by configure, and run_mopac7 added to AC_OUTPUT in configure.ac
+ sed -i "s:./src/mopac7:mopac7:g" run_mopac7
+
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS README ChangeLog
+}