summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-15 08:16:52 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-15 08:16:52 +0000
commit5b2c15322fefb49bb3bd65f27feb6bb2a8a0b734 (patch)
treeb828f1b6a1032ab32fe0744c207bc8af327c37b2 /sci-chemistry/makecif
parentdev-util/hgsvn: Remove (renamed to dev-vcs/hgsvn) (diff)
downloadgentoo-2-5b2c15322fefb49bb3bd65f27feb6bb2a8a0b734.tar.gz
gentoo-2-5b2c15322fefb49bb3bd65f27feb6bb2a8a0b734.tar.bz2
gentoo-2-5b2c15322fefb49bb3bd65f27feb6bb2a8a0b734.zip
New addition, unbundled from sci-chemistry/refmac
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/makecif')
-rw-r--r--sci-chemistry/makecif/ChangeLog11
-rw-r--r--sci-chemistry/makecif/files/5.6.6-makefile.patch49
-rw-r--r--sci-chemistry/makecif/makecif-5.6.6.ebuild42
-rw-r--r--sci-chemistry/makecif/metadata.xml17
4 files changed, 119 insertions, 0 deletions
diff --git a/sci-chemistry/makecif/ChangeLog b/sci-chemistry/makecif/ChangeLog
new file mode 100644
index 000000000000..665055a12388
--- /dev/null
+++ b/sci-chemistry/makecif/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-chemistry/makecif
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/makecif/ChangeLog,v 1.1 2010/06/15 08:16:52 jlec Exp $
+
+*makecif-5.6.6 (15 Jun 2010)
+
+ 15 Jun 2010; Justin Lecher <jlec@gentoo.org> +files/5.6.6-makefile.patch,
+ +makecif-5.6.6.ebuild, +metadata.xml:
+ New addition, unbundled from sci-chemistry/refmac
+
+
diff --git a/sci-chemistry/makecif/files/5.6.6-makefile.patch b/sci-chemistry/makecif/files/5.6.6-makefile.patch
new file mode 100644
index 000000000000..186abb92b7d8
--- /dev/null
+++ b/sci-chemistry/makecif/files/5.6.6-makefile.patch
@@ -0,0 +1,49 @@
+diff --git a/src/makefile b/src/makefile
+index 6c8264a..acdec20 100755
+--- a/src/makefile
++++ b/src/makefile
+@@ -22,6 +22,8 @@ MAKEDIC = $(MAKECIF)/dic/
+ # setenv BLANC_FORT "f77 -O1"
+ #
+
++all: makecif_all libcheck_all modcheck_all emin_all
++
+ clean:
+ rm -f temp_makecif_path.fh
+ rm -f ../bin/*
+@@ -118,7 +120,7 @@ makecif.o: makecif.f lib_com.fh crd_com.fh
+ $(BLANC_FORT) -c makecif.f
+
+ mkcif: main_makecif.o make_lib11.o make_lib12.o make_lib2.o make_vdw.o make_CIF.o make_crd1.o make_crd2.o make_new1.o make_new2.o make_rst1.o make_rst2.o make_PDB.o makecif.o make_unix.o make_subr_2.o make_subr.o set_num.o vdw_flexible.o emin.o libcheck_min.o math_refmac.o iheap_sort.o cell_symm_subrs.o subnumrec.o mol2_file.o sdf_files.o libcheck.o
+- $(BLANC_FORT) -o ../bin/makecif main_makecif.o makecif.o make_vdw.o make_CIF.o make_PDB.o make_crd1.o make_crd2.o make_new1.o make_new2.o make_rst1.o make_rst2.o make_unix.o make_subr_2.o make_subr.o make_lib11.o make_lib12.o make_lib2.o set_num.o vdw_flexible.o emin.o libcheck_min.o math_refmac.o iheap_sort.o cell_symm_subrs.o subnumrec.o mol2_file.o sdf_files.o libcheck.o
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/makecif main_makecif.o makecif.o make_vdw.o make_CIF.o make_PDB.o make_crd1.o make_crd2.o make_new1.o make_new2.o make_rst1.o make_rst2.o make_unix.o make_subr_2.o make_subr.o make_lib11.o make_lib12.o make_lib2.o set_num.o vdw_flexible.o emin.o libcheck_min.o math_refmac.o iheap_sort.o cell_symm_subrs.o subnumrec.o mol2_file.o sdf_files.o libcheck.o
+ # -------------
+ libcheck.o: libcheck.f lib_com.fh crd_com.fh
+ $(BLANC_FORT) -c libcheck.f
+@@ -130,7 +132,7 @@ main_libcheck.o: main_libcheck.f libcheck_version.fh
+ $(BLANC_FORT) -c main_libcheck.f
+
+ lbcheck: main_libcheck.o make_subr_2.o make_subr.o make_lib11.o make_lib12.o make_lib2.o libcheck.o make_PDB.o make_CIF.o make_new1.o make_new2.o make_crd1.o make_crd2.o make_unix.o set_num.o vdw_flexible.o emin.o libcheck_min.o math_refmac.o iheap_sort.o cell_symm_subrs.o subnumrec.o mol2_file.o sdf_files.o
+- $(BLANC_FORT) -o ../bin/libcheck main_libcheck.o libcheck.o make_PDB.o make_CIF.o make_new1.o make_new2.o make_crd1.o make_crd2.o make_lib11.o make_lib12.o make_lib2.o make_unix.o make_subr_2.o make_subr.o set_num.o vdw_flexible.o emin.o libcheck_min.o math_refmac.o iheap_sort.o cell_symm_subrs.o subnumrec.o mol2_file.o sdf_files.o
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/libcheck main_libcheck.o libcheck.o make_PDB.o make_CIF.o make_new1.o make_new2.o make_crd1.o make_crd2.o make_lib11.o make_lib12.o make_lib2.o make_unix.o make_subr_2.o make_subr.o set_num.o vdw_flexible.o emin.o libcheck_min.o math_refmac.o iheap_sort.o cell_symm_subrs.o subnumrec.o mol2_file.o sdf_files.o
+ # ------------
+
+ emin.o: emin.f crd_com.fh atom_com.fh
+@@ -143,7 +145,7 @@ main_emin.o: main_emin.f
+ $(BLANC_FORT) -c main_emin.f
+
+ emn: main_emin.o emin_new.o angle_subr.o make_unix.o make_CIF.o make_subr_2.o make_subr.o
+- $(BLANC_FORT) -o ../bin/emin main_emin.o emin_new.o make_CIF.o angle_subr.o make_unix.o make_subr_2.o make_subr.o
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/emin main_emin.o emin_new.o make_CIF.o angle_subr.o make_unix.o make_subr_2.o make_subr.o
+
+ # -------------
+
+@@ -155,7 +157,7 @@ main_modcheck.o: main_modcheck.f
+ $(BLANC_FORT) -c main_modcheck.f
+
+ mdcheck: main_modcheck.o modcheck.o mod_subr.o make_CIF.o make_unix.o make_subr_2.o make_subr.o
+- $(BLANC_FORT) -o ../bin/modcheck main_modcheck.o make_CIF.o modcheck.o mod_subr.o make_unix.o make_subr_2.o make_subr.o
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/modcheck main_modcheck.o make_CIF.o modcheck.o mod_subr.o make_unix.o make_subr_2.o make_subr.o
+
+
+ # ======================================
diff --git a/sci-chemistry/makecif/makecif-5.6.6.ebuild b/sci-chemistry/makecif/makecif-5.6.6.ebuild
new file mode 100644
index 000000000000..fe041c47c902
--- /dev/null
+++ b/sci-chemistry/makecif/makecif-5.6.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/makecif/makecif-5.6.6.ebuild,v 1.1 2010/06/15 08:16:52 jlec Exp $
+
+EAPI="3"
+
+FORTRANC="ifc gfortran"
+
+inherit eutils fortran
+
+DESCRIPTION="PDB --> CIF convertor"
+HOMEPAGE="http://www.ysbl.york.ac.uk/~alexei/makecif.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="ccp4"
+IUSE=""
+
+S="${WORKDIR}"/${PN}
+
+DEPEND=""
+RDEPEND="
+ sci-libs/monomer-db
+ !<sci-chemistry/refmac-5.5.0110-r1"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-makefile.patch
+}
+
+src_compile() {
+ cd src && emake clean
+ emake \
+ BLANC_FORT="$(tc-getFC) ${FFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ || die
+}
+
+src_install() {
+ dobin bin/* || die
+ dodoc readme || die
+}
diff --git a/sci-chemistry/makecif/metadata.xml b/sci-chemistry/makecif/metadata.xml
new file mode 100644
index 000000000000..b8cee3034ed8
--- /dev/null
+++ b/sci-chemistry/makecif/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+<longdescription>
+PDB --> CIF convertor
+check and create correct structure description
+create the list of restraints
+create dictionary description of new ligands
+rebuild missing atoms
+create tree like structure
+also the part of REFMAC
+can use additional user's dictionary
+</longdescription>
+</pkgmetadata>