summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-11-03 06:51:02 +0000
committerJustin Lecher <jlec@gentoo.org>2011-11-03 06:51:02 +0000
commit9a847aa664eef2f911c429b566aa9ca1f5cf2f78 (patch)
tree2e4a69d970fcc6be95c8dd6d8c563b6bdd60b9e8 /sci-chemistry/hollow/hollow-1.2.ebuild
parentBump to 3.2.1 from the gnome overlay. Drop old. Move to EAPI4. Drop alpha, ar... (diff)
downloadgentoo-2-9a847aa664eef2f911c429b566aa9ca1f5cf2f78.tar.gz
gentoo-2-9a847aa664eef2f911c429b566aa9ca1f5cf2f78.tar.bz2
gentoo-2-9a847aa664eef2f911c429b566aa9ca1f5cf2f78.zip
Version Bump
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/hollow/hollow-1.2.ebuild')
-rw-r--r--sci-chemistry/hollow/hollow-1.2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sci-chemistry/hollow/hollow-1.2.ebuild b/sci-chemistry/hollow/hollow-1.2.ebuild
new file mode 100644
index 000000000000..6691ae6c4757
--- /dev/null
+++ b/sci-chemistry/hollow/hollow-1.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/hollow/hollow-1.2.ebuild,v 1.1 2011/11/03 06:51:02 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit python
+
+DESCRIPTION="Production of surface images of proteins"
+HOMEPAGE="http://hollow.sourceforge.net/"
+#SRC_URI="mirror://sourceforge/${P}.zip"
+SRC_URI="http://hollow.sourceforge.net/${P}.zip"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+IUSE=""
+
+RDEPEND="sci-chemistry/pymol"
+DEPEND="app-arch/unzip"
+
+src_install() {
+ rm -rf pdbstruct/.svn || die
+ installation() {
+ insinto $(python_get_sitedir)
+ doins -r pdbstruct || die
+
+ insinto $(python_get_sitedir)/${PN}
+ doins *.py hollow.txt || die
+
+ cat >> ${PN} <<- EOF
+ $(PYTHON) -O "${EPREFIX}$(python_get_sitedir)/${PN}/${PN}.py" \$@
+ EOF
+
+ dobin ${PN}
+ }
+ python_execute_function installation
+
+ dodoc README || die
+}
+
+pkg_postinst() {
+ python_mod_optimize ${PN} pdbstruct
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${PN} pdbstruct
+}