summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-11-03 09:37:05 +0000
committerJustin Lecher <jlec@gentoo.org>2010-11-03 09:37:05 +0000
commita978fd977c92991209019c88914e96f36e59e425 (patch)
treecce5374665d5b43704d8f896d00c300ba7ff5004 /sci-chemistry/gsim
parentx86 stable wrt security bug #343911 (diff)
downloadgentoo-2-a978fd977c92991209019c88914e96f36e59e425.tar.gz
gentoo-2-a978fd977c92991209019c88914e96f36e59e425.tar.bz2
gentoo-2-a978fd977c92991209019c88914e96f36e59e425.zip
New Addition, imported from sci opverlay
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/gsim')
-rw-r--r--sci-chemistry/gsim/ChangeLog10
-rw-r--r--sci-chemistry/gsim/files/0.19.1-build.conf.patch44
-rw-r--r--sci-chemistry/gsim/gsim-0.19.1.ebuild63
-rw-r--r--sci-chemistry/gsim/metadata.xml11
4 files changed, 128 insertions, 0 deletions
diff --git a/sci-chemistry/gsim/ChangeLog b/sci-chemistry/gsim/ChangeLog
new file mode 100644
index 000000000000..a0930695c62b
--- /dev/null
+++ b/sci-chemistry/gsim/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/gsim
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gsim/ChangeLog,v 1.1 2010/11/03 09:37:05 jlec Exp $
+
+*gsim-0.19.1 (03 Nov 2010)
+
+ 03 Nov 2010; Justin Lecher <jlec@gentoo.org>
+ +files/0.19.1-build.conf.patch, +gsim-0.19.1.ebuild, +metadata.xml:
+ New Addition, imported from sci opverlay
+
diff --git a/sci-chemistry/gsim/files/0.19.1-build.conf.patch b/sci-chemistry/gsim/files/0.19.1-build.conf.patch
new file mode 100644
index 000000000000..ed21a58d4519
--- /dev/null
+++ b/sci-chemistry/gsim/files/0.19.1-build.conf.patch
@@ -0,0 +1,44 @@
+diff --git a/gsim.pro b/gsim.pro
+index 60550e9..d159b19 100755
+--- a/gsim.pro
++++ b/gsim.pro
+@@ -1,36 +1,7 @@
+-###################################################################################################
+-# Change this part according to your system configuration #
+-###################################################################################################
+-
+-#Uncomment next line if you want to have a system console running alongside GSim on Windows
+-#win32: CONFIG +=console
+-
+-#Uncomment next line if you want to use OpenGL
+-#CONFIG+=use_opengl
+-
+-#Uncomment next line if you want to use EMF output
+-#EMF output requires libEMF or Wine on X11 systems and MAC(?)
+-CONFIG+=use_emf
+-
+-#DO NOT UNCOMMENT NEXT LINE. The scripting possibilty won't work at the moment
+-#CONFIG+=use_script
+-
+-# Change directories locations for libcmatrix, MinUIT and muParser libraries
+-unix:INCLUDEPATH += /home/vnmr1/libcmatrixR3/include \
+- /home/vnmr1/Minuit2/include \
+- /home/vnmr1/muparser/include
+-win32:INCLUDEPATH += "C:\Documents and Settings\vadzorin\My Documents\gsim\libcmatrixR3\include" "C:\Documents and Settings\vadzorin\My Documents\gsim\Minuit2\include" "C:\Documents and Settings\vadzorin\My Documents\gsim\muparser\include"
+-
+-unix:LIBS += -lcmatrix -L/home/vnmr1/libcmatrixR3 -lMinuit2Base -L/home/vnmr1/Minuit2/lib -L/home/vnmr1/muparser/lib -lmuparser
+-win32:LIBS += -lcmatrix -L"C:\Documents and Settings\vadzorin\My Documents\gsim\libcmatrixR3" -lMinuit2 -L"C:\Documents and Settings\vadzorin\My Documents\gsim\Minuit2\lib" -L"C:\Documents and Settings\vadzorin\My Documents\gsim\muparser\lib" -lmuparser
+-
+-#Change directories location for libEMF (if used)
+-use_emf {
+- DEFINES+=USE_EMF_OUTPUT
+- unix:LIBS +=-lEMF -L/usr/include/libEmf
+- win32:LIBS +=-lgdi32
++GSIM_ROOT = .
++!include( $$GSIM_ROOT/build.conf ) {
++ message( "You need a build.conf file with local settings!" )
+ }
+-
+ #################################################################################################
+ # Don't change anything below this line #
+ #################################################################################################
diff --git a/sci-chemistry/gsim/gsim-0.19.1.ebuild b/sci-chemistry/gsim/gsim-0.19.1.ebuild
new file mode 100644
index 000000000000..c988caa5057f
--- /dev/null
+++ b/sci-chemistry/gsim/gsim-0.19.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gsim/gsim-0.19.1.ebuild,v 1.1 2010/11/03 09:37:05 jlec Exp $
+
+EAPI="3"
+
+inherit eutils qt4-r2
+
+DESCRIPTION="Programm for visualisation and processing of experimental and simulated NMR spectra"
+HOMEPAGE="http://sourceforge.net/projects/gsim"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="emf opengl"
+
+RDEPEND="
+ x11-libs/qt-svg:4
+ dev-cpp/muParser
+ sci-libs/libcmatrix
+ virtual/blas
+ media-libs/freetype
+ emf? ( media-libs/libemf )
+ opengl? ( x11-libs/qt-opengl:4 )"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PV}-build.conf.patch )
+DOCS="release.txt README_GSIM.* quickstart.* changes.log programming.*"
+
+src_prepare() {
+ edos2unix ${PN}.pro
+
+ qt4-r2_src_prepare
+
+ cat >> build.conf <<- EOF
+ INCLUDEPATH += ${EPREFIX}/usr/include/libcmatrixR3/ \
+ ${EPREFIX}/usr/include/Minuit2 \
+ ${EPREFIX}/usr/include
+ LIBS += -lcmatrix -lMinuit2 -lmuparser $(pkg-config --libs cblas)
+ EOF
+ use opengl && echo "CONFIG+=use_opengl" >> build.conf
+ if use emf; then
+ cat >> build.conf <<- EOF
+ CONFIG+=use_emf
+ DEFINES+=USE_EMF_OUTPUT
+ LIBS += -L${EPREFIX}/usr/include/libEMF -lEMF
+ EOF
+ fi
+ sed \
+ -e "s:quickstart.pdf:../share/doc/${PF}/quickstart.pdf:g" \
+ -e "s:README_GSIM.pdf:../share/doc/${PF}/README_GSIM.pdf:g" \
+ -i mainform.h || die
+}
+
+src_install() {
+ qt4-r2_src_install
+ dobin ${PN} || die "no ${PN}"
+ insinto /usr/share/${PN}
+ doins -r images ${PN}.ico || "no images"
+ insinto /usr/share/${PN}/ui
+ doins *.ui || die
+}
diff --git a/sci-chemistry/gsim/metadata.xml b/sci-chemistry/gsim/metadata.xml
new file mode 100644
index 000000000000..fa9b76fee4b3
--- /dev/null
+++ b/sci-chemistry/gsim/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+<use>
+ <flag name='emf'>Support for .emf export</flag>
+</use>
+</pkgmetadata>