summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2011-09-10 14:47:53 +0000
committerChristoph Junghans <ottxor@gentoo.org>2011-09-10 14:47:53 +0000
commitdcdd0f84edd3829e3ee4973e1750adfe5ae492fb (patch)
tree1c3001c381fb27499cd1f79c32acf33194631909 /sci-chemistry/gromacs
parentFix sandbox violations reported in bugs #371827 and #382465. (diff)
downloadgentoo-2-dcdd0f84edd3829e3ee4973e1750adfe5ae492fb.tar.gz
gentoo-2-dcdd0f84edd3829e3ee4973e1750adfe5ae492fb.tar.bz2
gentoo-2-dcdd0f84edd3829e3ee4973e1750adfe5ae492fb.zip
Migrate to the bash-completion-r1 eclass
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'sci-chemistry/gromacs')
-rw-r--r--sci-chemistry/gromacs/ChangeLog6
-rw-r--r--sci-chemistry/gromacs/gromacs-4.5.4-r1.ebuild27
-rw-r--r--sci-chemistry/gromacs/gromacs-4.5.4-r2.ebuild27
3 files changed, 29 insertions, 31 deletions
diff --git a/sci-chemistry/gromacs/ChangeLog b/sci-chemistry/gromacs/ChangeLog
index 4b67a3f80778..922905ec9125 100644
--- a/sci-chemistry/gromacs/ChangeLog
+++ b/sci-chemistry/gromacs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/gromacs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/ChangeLog,v 1.93 2011/07/18 18:20:14 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/ChangeLog,v 1.94 2011/09/10 14:47:53 ottxor Exp $
+
+ 10 Sep 2011; Christoph Junghans <ottxor@gentoo.org> gromacs-4.5.4-r1.ebuild,
+ gromacs-4.5.4-r2.ebuild:
+ Migrate to the bash-completion-r1 eclass
18 Jul 2011; Christoph Junghans <ottxor@gentoo.org> gromacs-4.5.4-r2.ebuild:
fix for external blas/lapack (bug #373559)
diff --git a/sci-chemistry/gromacs/gromacs-4.5.4-r1.ebuild b/sci-chemistry/gromacs/gromacs-4.5.4-r1.ebuild
index 3578376a52cb..05d79b09a898 100644
--- a/sci-chemistry/gromacs/gromacs-4.5.4-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-4.5.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-4.5.4-r1.ebuild,v 1.10 2011/06/26 08:32:55 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-4.5.4-r1.ebuild,v 1.11 2011/09/10 14:47:53 ottxor Exp $
EAPI="4"
@@ -8,7 +8,7 @@ LIBTOOLIZE="true"
TEST_PV="4.0.4"
MANUAL_PV="4.5.4"
-inherit autotools-utils bash-completion flag-o-matic fortran-2 multilib toolchain-funcs
+inherit autotools-utils bash-completion-r1 flag-o-matic fortran-2 multilib toolchain-funcs
if [ "${PV%9999}" != "${PV}" ]; then
EGIT_REPO_URI="git://git.gromacs.org/gromacs"
@@ -224,7 +224,7 @@ src_install() {
doenvd "${T}/80gromacs"
rm -f "${ED}"/usr/bin/GMXRC*
- dobashcompletion "${ED}"/usr/bin/completion.bash ${PN}
+ newbashcomp "${ED}"/usr/bin/completion.bash ${PN}
if use zsh-completion ; then
insinto /usr/share/zsh/site-functions
newins "${ED}"/usr/bin/completion.zsh _${PN}
@@ -246,16 +246,13 @@ src_install() {
pkg_postinst() {
env-update && source /etc/profile
- elog
- elog "Please read and cite:"
- elog "Gromacs 4, J. Chem. Theory Comput. 4, 435 (2008). "
- elog "http://dx.doi.org/10.1021/ct700301q"
- elog
- bash-completion_pkg_postinst
- elog
- elog $(g_luck)
- elog "For more Gromacs cool quotes (gcq) add luck to your .bashrc"
- elog
- elog "Gromacs can use sci-chemistry/vmd to read additional file formats"
- elog
+ einfo
+ einfo "Please read and cite:"
+ einfo "Gromacs 4, J. Chem. Theory Comput. 4, 435 (2008). "
+ einfo "http://dx.doi.org/10.1021/ct700301q"
+ einfo
+ einfo $(g_luck)
+ einfo "For more Gromacs cool quotes (gcq) add g_luck to your .bashrc"
+ einfo
+ elog "Gromacs can use sci-chemistry/vmd to read additional file formats"
}
diff --git a/sci-chemistry/gromacs/gromacs-4.5.4-r2.ebuild b/sci-chemistry/gromacs/gromacs-4.5.4-r2.ebuild
index 2f7fee15ba12..bbcf8ae6fd31 100644
--- a/sci-chemistry/gromacs/gromacs-4.5.4-r2.ebuild
+++ b/sci-chemistry/gromacs/gromacs-4.5.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-4.5.4-r2.ebuild,v 1.7 2011/07/18 18:20:14 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-4.5.4-r2.ebuild,v 1.8 2011/09/10 14:47:53 ottxor Exp $
EAPI="4"
@@ -10,7 +10,7 @@ MANUAL_PV="4.5.4"
#to find external blas/lapack
CMAKE_MIN_VERSION="2.8.5-r2"
-inherit bash-completion cmake-utils eutils fortran-2 multilib toolchain-funcs
+inherit bash-completion-r1 cmake-utils eutils fortran-2 multilib toolchain-funcs
if [ "${PV%9999}" != "${PV}" ]; then
EGIT_REPO_URI="git://git.gromacs.org/gromacs"
@@ -211,7 +211,7 @@ src_install() {
doenvd "${T}/80gromacs"
rm -f "${ED}"/usr/bin/GMXRC*
- dobashcompletion "${ED}"/usr/bin/completion.bash ${PN}
+ newbashcomp "${ED}"/usr/bin/completion.bash ${PN}
if use zsh-completion ; then
insinto /usr/share/zsh/site-functions
newins "${ED}"/usr/bin/completion.zsh _${PN}
@@ -233,16 +233,13 @@ src_install() {
pkg_postinst() {
env-update && source /etc/profile
- elog
- elog "Please read and cite:"
- elog "Gromacs 4, J. Chem. Theory Comput. 4, 435 (2008). "
- elog "http://dx.doi.org/10.1021/ct700301q"
- elog
- bash-completion_pkg_postinst
- elog
- elog $(g_luck)
- elog "For more Gromacs cool quotes (gcq) add luck to your .bashrc"
- elog
- elog "Gromacs can use sci-chemistry/vmd to read additional file formats"
- elog
+ einfo
+ einfo "Please read and cite:"
+ einfo "Gromacs 4, J. Chem. Theory Comput. 4, 435 (2008). "
+ einfo "http://dx.doi.org/10.1021/ct700301q"
+ einfo
+ einfo $(g_luck)
+ einfo "For more Gromacs cool quotes (gcq) add g_luck to your .bashrc"
+ einfo
+ elog "Gromacs can use sci-chemistry/vmd to read additional file formats"
}