summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-03-09 15:18:52 +0000
committerChristoph Junghans <ottxor@gentoo.org>2013-03-09 15:18:52 +0000
commit25137a1692277dcb62354110e8e412db9beb47d6 (patch)
treee54d61c6ccd9502985523700b9fae5f531c4e656 /sci-chemistry/gromacs
parentVersion bump (diff)
downloadgentoo-2-25137a1692277dcb62354110e8e412db9beb47d6.tar.gz
gentoo-2-25137a1692277dcb62354110e8e412db9beb47d6.tar.bz2
gentoo-2-25137a1692277dcb62354110e8e412db9beb47d6.zip
fix cuda build (bug #460518)
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sci-chemistry/gromacs')
-rw-r--r--sci-chemistry/gromacs/ChangeLog5
-rw-r--r--sci-chemistry/gromacs/gromacs-4.6.1.ebuild9
2 files changed, 9 insertions, 5 deletions
diff --git a/sci-chemistry/gromacs/ChangeLog b/sci-chemistry/gromacs/ChangeLog
index aeaf99af3f11..8498acf0155b 100644
--- a/sci-chemistry/gromacs/ChangeLog
+++ b/sci-chemistry/gromacs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-chemistry/gromacs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/ChangeLog,v 1.121 2013/03/06 02:02:01 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/ChangeLog,v 1.122 2013/03/09 15:18:52 ottxor Exp $
+
+ 09 Mar 2013; Christoph Junghans <ottxor@gentoo.org> gromacs-4.6.1.ebuild:
+ fix cuda build (bug #460518)
*gromacs-4.6.1 (06 Mar 2013)
diff --git a/sci-chemistry/gromacs/gromacs-4.6.1.ebuild b/sci-chemistry/gromacs/gromacs-4.6.1.ebuild
index 226082edf7c4..fdf8eb5287c8 100644
--- a/sci-chemistry/gromacs/gromacs-4.6.1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-4.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-4.6.1.ebuild,v 1.1 2013/03/06 02:02:01 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-4.6.1.ebuild,v 1.2 2013/03/09 15:18:52 ottxor Exp $
EAPI=5
@@ -180,10 +180,11 @@ src_configure() {
[[ ${x} = "double" ]] && suffix="_d"
local p
[[ ${x} = "double" ]] && p="-DGMX_DOUBLE=ON" || p="-DGMX_DOUBLE=OFF"
- local cuda=$(cmake-utils_use cuda GMX_GPU)
- [[ ${x} = "double" ]] && use cuda && cuda="-DGMX_GPU=OFF"
+ local cuda=( "-DGMX_GPU=OFF" )
+ [[ ${x} = "single" ]] && use cuda && \
+ cuda=( -DGMX_GPU=ON -DCUDA_HOST_COMPILER_OPTIONS="${NVCCFLAGS}" )
mycmakeargs=( ${mycmakeargs_pre[@]} ${p} -DGMX_MPI=OFF
- $(cmake-utils_use threads GMX_THREAD_MPI) ${cuda} -DGMX_OPENMM=OFF
+ $(cmake-utils_use threads GMX_THREAD_MPI) "${cuda[@]}" -DGMX_OPENMM=OFF
"$(use test && echo -DREGRESSIONTEST_PATH="${WORKDIR}/${P}_${x}/tests")"
-DGMX_BINARY_SUFFIX="${suffix}" -DGMX_LIBS_SUFFIX="${suffix}" )
BUILD_DIR="${WORKDIR}/${P}_${x}" cmake-utils_src_configure