summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-05-13 22:24:31 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-05-13 22:24:31 +0000
commit3b739fbfd3f85d875297351bc98d21fcd57fe529 (patch)
treeaa028da99cff7703a31caa00f63db666fe6dd9e7 /sci-chemistry/ghemical/ghemical-2.01.ebuild
parent(#132835) Bump to latest release. Ebuild based on work of Donald E. Curtis. P... (diff)
downloadgentoo-2-3b739fbfd3f85d875297351bc98d21fcd57fe529.tar.gz
gentoo-2-3b739fbfd3f85d875297351bc98d21fcd57fe529.tar.bz2
gentoo-2-3b739fbfd3f85d875297351bc98d21fcd57fe529.zip
(#132835) Bump to latest release. Ebuild based on work of Donald E. Curtis.
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'sci-chemistry/ghemical/ghemical-2.01.ebuild')
-rw-r--r--sci-chemistry/ghemical/ghemical-2.01.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-chemistry/ghemical/ghemical-2.01.ebuild b/sci-chemistry/ghemical/ghemical-2.01.ebuild
new file mode 100644
index 000000000000..c098b41436e8
--- /dev/null
+++ b/sci-chemistry/ghemical/ghemical-2.01.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ghemical/ghemical-2.01.ebuild,v 1.1 2006/05/13 22:24:31 spyderous Exp $
+
+inherit eutils
+
+DESCRIPTION="Ghemical supports both quantum-mechanics (semi-empirical and ab initio) models and molecular mechanics models (there is an experimental Tripos 5.2-like force field for organic molecules). Also a tool for reduced protein models is included. Geometry optimization, molecular dynamics and a large set of visualization tools are currently available."
+HOMEPAGE="http://www.uku.fi/~thassine/ghemical/"
+SRC_URI="http://bioinformatics.org/ghemical/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="threads openbabel toolbar"
+RDEPEND="virtual/glut
+ virtual/glu
+ virtual/opengl
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/gtkglext-1.0.5
+ >=gnome-base/libglade-2.4
+ >=sci-libs/libghemical-2
+ openbabel? ( >=sci-chemistry/openbabel-2 )
+ threads? ( >=dev-libs/glib-2.4 )
+ || ( x11-libs/libXmu virtual/x11 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.15"
+
+pkg_setup() {
+ # Only works with xorg-x11 GL implementation
+ GL_IMPLEM=$(eselect opengl show)
+ eselect opengl set xorg-x11
+}
+
+src_compile() {
+ econf \
+ $(use_enable toolbar shortcuts) \
+ $(use_enable openbabel) \
+ $(use_enable threads) \
+ --enable-gamess \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ # sed -e "s:^prefix=.*:prefix=${D}/usr:" -i Makefile
+ make DESTDIR="${D}" install || die "install failed"
+}
+
+pkg_postinst() {
+ eselect opengl set ${GL_IMPLEM}
+}