summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-16 15:31:51 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-16 15:31:51 +0000
commit5707e1c2a3acb789446a3b3526890fa3df7151fe (patch)
tree007681cbab7dd424937f287f0a1eb2749078451e /sci-chemistry/gamess
parentUnmask www-client/chromium beta channel release (and also dev-lang/v8 and dev... (diff)
downloadgentoo-2-5707e1c2a3acb789446a3b3526890fa3df7151fe.tar.gz
gentoo-2-5707e1c2a3acb789446a3b3526890fa3df7151fe.tar.bz2
gentoo-2-5707e1c2a3acb789446a3b3526890fa3df7151fe.zip
Removal of fortran.eclass, #348851
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/gamess')
-rw-r--r--sci-chemistry/gamess/ChangeLog6
-rw-r--r--sci-chemistry/gamess/gamess-20090112.1-r1.ebuild36
-rw-r--r--sci-chemistry/gamess/gamess-20101001.1.ebuild24
3 files changed, 33 insertions, 33 deletions
diff --git a/sci-chemistry/gamess/ChangeLog b/sci-chemistry/gamess/ChangeLog
index c191cff3d084..5ffeb7589107 100644
--- a/sci-chemistry/gamess/ChangeLog
+++ b/sci-chemistry/gamess/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/gamess
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/ChangeLog,v 1.45 2010/12/08 18:19:10 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/ChangeLog,v 1.46 2010/12/16 15:31:51 jlec Exp $
+
+ 16 Dec 2010; Justin Lecher <jlec@gentoo.org> gamess-20090112.1-r1.ebuild,
+ gamess-20101001.1.ebuild:
+ Removal of fortran.eclass, #348851
08 Dec 2010; Alexey Shvetsov <alexxy@gentoo.org> gamess-20101001.1.ebuild:
Fix neo code
diff --git a/sci-chemistry/gamess/gamess-20090112.1-r1.ebuild b/sci-chemistry/gamess/gamess-20090112.1-r1.ebuild
index dd70beae36a0..d550ac8fd970 100644
--- a/sci-chemistry/gamess/gamess-20090112.1-r1.ebuild
+++ b/sci-chemistry/gamess/gamess-20090112.1-r1.ebuild
@@ -1,22 +1,20 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/gamess-20090112.1-r1.ebuild,v 1.8 2010/05/24 12:42:17 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/gamess-20090112.1-r1.ebuild,v 1.9 2010/12/16 15:31:51 jlec Exp $
-inherit eutils toolchain-funcs fortran flag-o-matic
+inherit eutils toolchain-funcs flag-o-matic
DESCRIPTION="A powerful quantum chemistry package"
-LICENSE="gamess"
HOMEPAGE="http://www.msg.chem.iastate.edu/GAMESS/GAMESS.html"
SRC_URI="
${P}.tar.gz
qmmm-tinker? ( tinker.tar.Z )"
+LICENSE="gamess"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="hardened qmmm-tinker"
-RESTRICT="fetch"
-
DEPEND="app-shells/tcsh
hardened? ( sys-apps/paxctl )
virtual/blas"
@@ -24,11 +22,12 @@ DEPEND="app-shells/tcsh
RDEPEND="${DEPEND}
net-misc/openssh"
+RESTRICT="fetch"
+
S="${WORKDIR}/${PN}"
GAMESS_DOWNLOAD="http://www.msg.ameslab.gov/GAMESS/License_Agreement.html"
GAMESS_VERSION="12 JAN 2009 (R1)"
-FORTRAN="ifc g77 gfortran"
pkg_nofetch() {
echo
@@ -45,10 +44,9 @@ pkg_nofetch() {
}
pkg_setup() {
- fortran_pkg_setup
# currently amd64 is only supported with gfortran
- if [[ "${ARCH}" == "amd64" ]] && [[ "${FORTRANC}" != "gfortran" ]];
+ if [[ "${ARCH}" == "amd64" ]] && [[ "$(tc-getFC)" != "gfortran" ]];
then die "You will need gfortran to compile gamess on amd64"
fi
@@ -81,7 +79,7 @@ src_unpack() {
# for hardened-gcc let't turn off ssp, since it breakes
# a few routines
- if use hardened && [[ "${FORTRANC}" = "g77" ]]; then
+ if use hardened && [[ "$(tc-getFC)" = "g77" ]]; then
FFLAGS="${FFLAGS} -fno-stack-protector-all"
fi
@@ -117,29 +115,29 @@ src_unpack() {
# insert proper FFLAGS into GAMESS' comp makefile
# in case we're using ifc let's strip all the gcc
# specific stuff
- if [[ "${FORTRANC}" == "ifc" ]]; then
+ if [[ "$(tc-getFC)" == "ifort" ]]; then
sed -e "s/gentoo-OPT = '-O2'/OPT = '${FFLAGS} -quiet'/" \
- -e "s/gentoo-g77/${FORTRANC}/" \
+ -e "s/gentoo-g77/$(tc-getFC)/" \
-i comp || die "Failed setting up comp script"
elif ! use x86; then
sed -e "s/-malign-double //" \
-e "s/gentoo-OPT = '-O2'/OPT = '${FFLAGS}'/" \
- -e "s/gentoo-g77/${FORTRANC}/" \
+ -e "s/gentoo-g77/$(tc-getFC)/" \
-i comp || die "Failed setting up comp script"
else
sed -e "s/gentoo-OPT = '-O2'/OPT = '${FFLAGS}'/" \
- -e "s/gentoo-g77/${FORTRANC}/" \
+ -e "s/gentoo-g77/$(tc-getFC)/" \
-i comp || die "Failed setting up comp script"
fi
# fix up GAMESS' linker script;
- sed -e "s/gentoo-g77/${FORTRANC}/" \
+ sed -e "s/gentoo-g77/$(tc-getFC)/" \
-e "s/gentoo-LDOPTS=' '/LDOPTS='${LDFLAGS}'/" \
-i lked || die "Failed setting up lked script"
# fix up GAMESS' ddi TCP/IP socket build
sed -e "s/gentoo-CC = 'gcc'/CC = '$(tc-getCC)'/" \
- -e "s/gentoo-g77/${FORTRANC}/" \
+ -e "s/gentoo-g77/$(tc-getFC)/" \
-i ddi/compddi || die "Failed setting up compddi script"
# fix up the checker scripts for gamess tests
@@ -151,12 +149,12 @@ src_unpack() {
src_compile() {
# build actvte
cd "${S}"/tools
- "${FORTRANC}" -o actvte.x actvte.f || \
+ "$(tc-getFC)" -o actvte.x actvte.f || \
die "Failed to compile actvte.x"
# for hardened (PAX) users and ifc we need to turn
# MPROTECT off
- if [[ "${FORTRANC}" == "ifc" ]] && use hardened; then
+ if [[ "$(tc-getFC)" == "ifort" ]] && use hardened; then
/sbin/paxctl -PemRxS actvte.x 2> /dev/null || \
die "paxctl failed on actvte.x"
fi
@@ -175,7 +173,7 @@ src_compile() {
# for hardened (PAX) users and ifc we need to turn
# MPROTECT off
- if [[ "${FORTRANC}" == "ifc" ]] && use hardened; then
+ if [[ "$(tc-getFC)" == "ifort" ]] && use hardened; then
/sbin/paxctl -PemRxS ${PN}.00.x 2> /dev/null || \
die "paxctl failed on actvte.x"
fi
@@ -235,7 +233,7 @@ pkg_postinst() {
einfo "validate the tests."
einfo "Please consult TEST.DOC and the other docs!"
- if [[ "${FORTRANC}" == "ifc" ]]; then
+ if [[ "$(tc-getFC)" == "ifort" ]]; then
echo
ewarn "IMPORTANT NOTE: We STRONGLY recommend to stay away"
ewarn "from ifc-9.0 for now and use the ifc-8.1 series of"
diff --git a/sci-chemistry/gamess/gamess-20101001.1.ebuild b/sci-chemistry/gamess/gamess-20101001.1.ebuild
index 2b05bccba992..15f64ddd2062 100644
--- a/sci-chemistry/gamess/gamess-20101001.1.ebuild
+++ b/sci-chemistry/gamess/gamess-20101001.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/gamess-20101001.1.ebuild,v 1.3 2010/12/08 18:19:09 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/gamess-20101001.1.ebuild,v 1.4 2010/12/16 15:31:51 jlec Exp $
EAPI="3"
-inherit eutils toolchain-funcs fortran flag-o-matic
+inherit eutils toolchain-funcs flag-o-matic
DESCRIPTION="A powerful quantum chemistry package"
LICENSE="gamess"
@@ -22,8 +22,6 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="hardened mpi neo qmmm-tinker"
-RESTRICT="fetch"
-
CDEPEND="app-shells/tcsh
hardened? ( sys-apps/paxctl )
mpi? ( virtual/mpi )
@@ -35,9 +33,10 @@ RDEPEND="${CDEPEND}
S="${WORKDIR}/${PN}"
+RESTRICT="fetch"
+
GAMESS_DOWNLOAD="http://www.msg.ameslab.gov/GAMESS/License_Agreement.html"
GAMESS_VERSION="1 OCT 2010 (R1)"
-FORTRAN="ifc g77 gfortran"
pkg_nofetch() {
echo
@@ -54,10 +53,9 @@ pkg_nofetch() {
}
pkg_setup() {
- fortran_pkg_setup
# currently amd64 is only supported with gfortran
- if [[ "${ARCH}" == "amd64" ]] && [[ "${FORTRANC}" != "gfortran" ]];
+ if [[ "${ARCH}" == "amd64" ]] && [[ "$(tc-getFC)" != "gfortran" ]];
then die "You will need gfortran to compile gamess on amd64"
fi
@@ -107,7 +105,7 @@ src_prepare() {
# for hardened-gcc let't turn off ssp, since it breakes
# a few routines
- if use hardened && [[ "${FORTRANC}" = "g77" ]]; then
+ if use hardened && [[ "$(tc-getFC)" = "g77" ]]; then
FFLAGS="${FFLAGS} -fno-stack-protector-all"
fi
@@ -180,7 +178,7 @@ src_prepare() {
# insert proper FFLAGS into GAMESS' comp makefile
# in case we're using ifc let's strip all the gcc
# specific stuff
- if [[ "${FORTRANC}" == "ifc" ]]; then
+ if [[ "$(tc-getFC)" == "ifort" ]]; then
sed -e "s/gentoo-OPT = '-O2'/OPT = '${FFLAGS} -quiet'/" \
-i comp || die "Failed setting up comp script"
elif ! use x86; then
@@ -214,12 +212,12 @@ src_prepare() {
src_compile() {
# build actvte
cd "${S}"/tools
- "${FORTRANC}" -o actvte.x actvte.f || \
+ "$(tc-getFC)" -o actvte.x actvte.f || \
die "Failed to compile actvte.x"
# for hardened (PAX) users and ifc we need to turn
# MPROTECT off
- if [[ "${FORTRANC}" == "ifc" ]] && use hardened; then
+ if [[ "$(tc-getFC)" == "ifort" ]] && use hardened; then
/sbin/paxctl -PemRxS actvte.x 2> /dev/null || \
die "paxctl failed on actvte.x"
fi
@@ -238,7 +236,7 @@ src_compile() {
# for hardened (PAX) users and ifc we need to turn
# MPROTECT off
- if [[ "${FORTRANC}" == "ifc" ]] && use hardened; then
+ if [[ "$(tc-getFC)" == "ifort" ]] && use hardened; then
/sbin/paxctl -PemRxS ${PN}.00.x 2> /dev/null || \
die "paxctl failed on actvte.x"
fi
@@ -302,7 +300,7 @@ pkg_postinst() {
einfo "validate the tests."
einfo "Please consult TEST.DOC and the other docs!"
- if [[ "${FORTRANC}" == "ifc" ]]; then
+ if [[ "$(tc-getFC)" == "ifort" ]]; then
echo
ewarn "IMPORTANT NOTE: We STRONGLY recommend to stay away"
ewarn "from ifc-9.0 for now and use the ifc-8.1 series of"